Results 1 to 10 of 1132

Thread: Wacom Bamboo Pen and Touch Series Development

Threaded View

  1. #1
    Join Date
    Apr 2007
    Mount Horeb, WI
    Kubuntu Development Release

    Wacom Bamboo Pen and Touch Series Development

    This thread is the development thread for the Wacom Bamboo Pen and Touch series tablets (0xd1, 0xd2, 0xd3, and 0xd4 devices). 0.8.6-1 was released a while back and that should get your device working in Karmic.

    If you are using Lucid, please try the instructions on this post.

    We are going to try a different approach on getting the driver installed. To make sure that you have all the development tools:
    sudo apt-get update
    sudo apt-get install wacom-tools xserver-xorg-input-wacom
    sudo apt-get install libhal-dev libxrandr-dev
    sudo apt-get build-dep xserver-xorg-input-wacom
    Do the following if you are NOT using Karmic:
    sudo apt-get purge wacom-tools xserver-xorg-input-wacom
    If you are using Karmic also include the following:
    sudo cp ./hid-ids.h /lib/modules/`uname -r`/build/drivers/hid/hid-ids.h
    We are going to use 0.8.6-1 for testing:
    Option A
    For now I have archived this version because of a recent release so you can download it here.
    Unpack the source:
    tar -xvjf linuxwacom-0.8.6-1.tar.bz2
    cd linuxwacom-0.8.6-1
    Compile and install:
    make clean
    make distclean
    ./configure --enable-wacom --prefix=/usr
    sudo make install
    sudo cp src/2.6.30/wacom.ko /lib/modules/$(uname -r)/kernel/drivers/input/tablet/
    sudo depmod -a
    For those using TwinView" (Thank you, alpharesearch!)
    make clean
    make distclean
    ./configure --enable-wacom --prefix=/usr --enable-quirk-tablet-rescale
    sudo make install
    sudo cp src/2.6.30/wacom.ko /lib/modules/$(uname -r)/kernel/drivers/input/tablet/
    sudo depmod -a
    Make sure that you also set the Horizontal setting to zero. See the bottom of this post for more info.

    To reload the module:
    sudo modprobe -r wacom
    sudo modprobe wacom
    NOTE: The 'make clean' and 'make distclean' will produce an error message if you have not done a ./configure before. This is because the source has never been compiled yet and the Makefiles have not been created yet (the Makefile gets built with the ./configure command). Therefore there is nothing to clean up.

    If wacomcpl is not working with your device, please try copying over the file from /usr/local/bin:
    sudo cp /usr/local/bin/wacomcpl /usr/bin
    Thanks portets for that information!

    Some helpful xsetwacom commands
    NOTE: It looks like in 0.8.6-1 the device name might be used instead of touch. You will need to check with xsetwacom list to find the actual device name. See post 870 for more detail.
    To find the list of recognized devices:
    xsetwacom list
    To set your touch so that it works like a mouse touchpad:
    xsetwacom set touch Mode Relative
    To set the resolution of your touch (Example is for the medium sized tablet -- the small is X=480 Y=320):
    xsetwacom set touch bottomx 740
    xsetwacom set touch bottomy 500
    To turn the touch on/off:
    xsetwacom set touch Touch off
    xsetwacom set touch Touch on
    For the TwinView dual screen to work, this also needs to be added to 10-linuxwacom.fdi:
    <merge key="input.x11_options.TwinView" type="string">Horizontal</merge>
    <merge key="input.x11_options.ScreenNo" type="string">0</merge>
    If there are any corrections that need to be made, please let me know.

    I am not if there are still some adjustments needed for the .fdi files. Please refer to this post.
    Last edited by Ayuthia; May 11th, 2010 at 01:38 AM. Reason: Updated for Lucid and 0.8.6-1

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts