Results 1 to 3 of 3

Thread: Installing drivers

  1. #1
    Join Date
    Feb 2010
    Beans
    2

    Installing drivers

    I just installed ubuntu-9.10-desktop-i386 on a formatted HD that I am running through an USB port (using a SATA to USB cable). The problem is: I am a noob and don't know how to install the drivers.

    The first thing I wanted to take care of was my wireless card -- I have an Intel wifi 5100 AGN. I downloaded the microcode image from http://intellinuxwireless.org/?n=Downloads and unzipped the files to flash drive.

    When I boot up ubuntu I don't know how to proceed. The text file which was included with the driver tells me that a iwlagn driver will look for the iwlwifi-5000-2.ucode file using the kernel's firmware_loader infrastructure. In order for this to work I must have it supported in my kernel. And it says I can find that option under Device Drivers ->Generic Driver Options -> Hotplug firmware loading support. (I am unable to find any Device Drivers directory).


    It also says: "You can determine if your kernel currently has firmware loader support
    by looking for the CONFIG_FW_LOADER definition on your kernel's
    .config."

    Where do I find this kernel config?

    I am completely lost! Can someone help me?

    Thanks in advance.

  2. #2
    Join Date
    Oct 2006
    Location
    Milton Keynes, UK
    Beans
    1,141
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Installing drivers

    You could try following this...

    http://baheyeldin.com/technology/lin...koala-910.html

    Will need to install build-essential (compiler etc) package first...

    Code:
    sudo apt-get update
    Code:
    sudo apt-get install build-essential
    Linux Registered User #443947 Ubuntu Regestered User #12604

    Hakunamatata ...... No worries !

  3. #3
    Join Date
    Feb 2010
    Beans
    2

    Re: Installing drivers

    Thanks for your reply.

    I tried what you suggested but to no avail. I unpacked the files cd'd to the directory and typed in the commands (sudo make install I think). Then it was doing something in the terminal for several minutes, but nothing really changed. When I typed the command "lshw -C network", it still said UNCLAIMED (or something). Then I read in the help file that comes with ubuntu that I needed something called ndisgtk so I downloaded that, but to install it I needed something else (again...) called ndiswrapper for this to work. So I got that one extracted it, built it but nothing really happened. When I tried to use the ndiswrapper commands the terminal said something like: ndiswrapper not installed. To install package type sudo apt-get install ndiswrapper-common. Did that but then it complained package not found.

    Isn't there a standard procedure to installing drivers in ubuntu? If not does anyone else have any suggestions? Getting a bit frustrated now.

    Thanks!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •