Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 59

Thread: Skype, Logitech webcam and Karmic video problem persists

  1. #11
    Join Date
    Sep 2007
    Location
    Baja Arizona
    Beans
    52
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Skype, Logitech webcam and Karmic video problem persists

    Quote Originally Posted by fabounet View Post
    This is a problem in Qt4, not in Cairo-Dock.
    there is a workaround for it :
    Code:
    export XLIB_SKIP_ARGB_VISUALS=1 && skype
    (also work for VLC, Smplayer, and any Qt applications that do video)
    That works for the current session with the -o option, openGl in cairo-dock, however it doesn't persist into the next login session.

    Anyway to make it persistent from one login session to the next?

  2. #12
    Join Date
    Dec 2004
    Beans
    1,068
    Distro
    Xubuntu 15.10 Wily Werewolf

    Re: Skype, Logitech webcam and Karmic video problem persists

    doing the above gives me a green screen in the video test window. Do I somehow have to combine the LD and export commands with the skype launch command?

    I tried
    Code:
    export XLIB_SKIP_ARGB_VISUALS=1 && LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usrin/skype
    but no luck

  3. #13
    Join Date
    Aug 2006
    Beans
    7

    Re: Skype, Logitech webcam and Karmic video problem persists

    Quote Originally Posted by pickarooney View Post
    doing the above gives me a green screen in the video test window. Do I somehow have to combine the LD and export commands with the skype launch command?

    I tried
    Code:
    export XLIB_SKIP_ARGB_VISUALS=1 && LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usrin/skype
    but no luck
    First of all, thanks to relic70 who solved my problem with Skype.

    Yes pickarooney, you have to integrate both the preload section and the export commands. I solved it in a very simple way: I right-clicked on the "Applications" menu and chose "modify menu" to bring forth the menu editor, and under "Internet -> Skype" I changed the "command" section of Skype's launcher from /usr/bin/skype to:

    sh -c 'export XLIB_SKIP_ARGB_VISUALS=1 && LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype'

    (mind the vertical apostrophes!)

    This way I can keep my OpenGL Cairo Dock and use Skype at its fullest! Yeah!

  4. #14
    Join Date
    Sep 2007
    Location
    Baja Arizona
    Beans
    52
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Skype, Logitech webcam and Karmic video problem persists

    Quote Originally Posted by hirumono View Post
    First of all, thanks to relic70 who solved my problem with Skype.


    sh -c 'export XLIB_SKIP_ARGB_VISUALS=1 && LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype'

    (mind the vertical apostrophes!)

    This way I can keep my OpenGL Cairo Dock and use Skype at its fullest! Yeah!
    Yep! Works like a charm for me too. Thanks to your extra help hirumono.

  5. #15
    Join Date
    Dec 2009
    Beans
    1

    Re: Skype, Logitech webcam and Karmic video problem persists

    Tried sh -c 'export XLIB_SKIP_ARGB_VISUALS=1 && LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype' but still get the fuzzy green video. Here is the output I get:

    ERROR: ld.so: object '/usr/lib/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.
    Gtk-Message: Failed to load module "gnomenu-panel": libgnomenu-panel.so: cannot open shared object file: No such file or directory
    Gtk-Message: Failed to load module "globalmenu-gnome": /usr/lib/gtk-2.0/modules/libglobalmenu-gnome.so: wrong ELF class: ELFCLASS64

    Any ideas what went wrong?

  6. #16
    Join Date
    Sep 2007
    Location
    Baja Arizona
    Beans
    52
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Skype, Logitech webcam and Karmic video problem persists

    Quote Originally Posted by fleghorn View Post
    Tried sh -c 'export XLIB_SKIP_ARGB_VISUALS=1 && LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype' but still get the fuzzy green video. Here is the output I get:

    ERROR: ld.so: object '/usr/lib/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.
    Gtk-Message: Failed to load module "gnomenu-panel": libgnomenu-panel.so: cannot open shared object file: No such file or directory
    Gtk-Message: Failed to load module "globalmenu-gnome": /usr/lib/gtk-2.0/modules/libglobalmenu-gnome.so: wrong ELF class: ELFCLASS64

    Any ideas what went wrong?
    I'm only guessing here, but you many not have all of those files installed, particularly those that indicate "no such file or directory". Check the synaptic package manager to see if they are installed.

  7. #17
    Join Date
    Nov 2009
    Location
    Croatia/Hrvatska
    Beans
    492
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Skype, Logitech webcam and Karmic video problem persists

    i have a 64 bit karmic... do i have to write LD_PRELOAD=/usr/lib64/ instead of LD_PRELOAD=/usr/lib/ ?
    i tried this and cant get my video to work.. my cam works fine with cheese, but not with skype... i can get sound from my webcam but no video and i see the video of the other person, just cant start my video...

  8. #18
    Join Date
    Dec 2009
    Beans
    Hidden!
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Skype, Logitech webcam and Karmic video problem persists

    Quote Originally Posted by marin123 View Post
    i have a 64 bit karmic... do i have to write LD_PRELOAD=/usr/lib64/ instead of LD_PRELOAD=/usr/lib/ ?
    i tried this and cant get my video to work.. my cam works fine with cheese, but not with skype... i can get sound from my webcam but no video and i see the video of the other person, just cant start my video...
    Skype from the medibuntu repos worked fine but the one downloaded from Skype site gives me the same issue with my cam, I get sound but only green stripes for video. The cam works fine in Cheese, I am on Karmic x64.

  9. #19
    Join Date
    Nov 2009
    Location
    Croatia/Hrvatska
    Beans
    492
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Skype, Logitech webcam and Karmic video problem persists

    Quote Originally Posted by Linuxforall View Post
    Skype from the medibuntu repos worked fine but the one downloaded from Skype site gives me the same issue with my cam, I get sound but only green stripes for video. The cam works fine in Cheese, I am on Karmic x64.
    i hope you solved the problem with links from that other thread

  10. #20
    Join Date
    Dec 2009
    Beans
    Hidden!
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Skype, Logitech webcam and Karmic video problem persists

    Quote Originally Posted by marin123 View Post
    i hope you solved the problem with links from that other thread
    Yep, just thinking in long run, it needs to be back in the repo for now. Many of those who switch to Ubuntu here from Windows depend on Skype as its the only audio video messenger for Linux so the medibutnu way makes it far easier than telling them to download from specific site.

Page 2 of 6 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •