Page 1 of 4 123 ... LastLast
Results 1 to 10 of 61

Thread: Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic)

Hybrid View

  1. #1
    Join Date
    Nov 2009
    Location
    Belgium
    Beans
    2
    Distro
    Ubuntu 10.04 Lucid Lynx

    Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic)

    After so many many attempts to solve my audio problems when upgrading to Karmic, I finally found a working solution !

    First, let me decribe what the problem was:
    1) no audio card was detected at all
    => cat /proc/asound/cards returned an empty content
    => cat /proc/asound/devices did not include any audio devices
    => 'Hardware' tab in sound preferences was empty
    2) the audio tray indicated a "dummy output"


    SOLUTION
    ========

    For those who do not have a fresh Karmic install (in other words those who have upgraded their Jaunty install), you should update your Grub BEFORE applying the 2 steps described hereunder:

    sudo update-grub



    Step1: make the sound card being recognized

    => Purge alsa-base and pulseaudio, eg:

    sudo apt-get remove --purge alsa-base
    sudo apt-get remove --purge pulseaudio
    sudo apt-get install alsa-base
    sudo apt-get install pulseaudio
    sudo alsa force-reload


    Now, reboot, you shoud now SEE (but maybe not yet hear) your soundcard.
    Give a try to:
    cat /proc/asound/cards
    and see if any card is listed...


    Step2 : If the sound is crapy, you MAY have to edit the alsa config file:

    sudo gedit /etc/modprobe.d/alsa-base.conf

    a) comment (#) the following line:
    # options snd-hda-intel power_save=10 power_save_controller=N

    b) Add a new line
    options snd-hda-intel probe_mask=1 model=hp

    Replace "hp" with appropriate computer model. See here

    Good luck !

    Bernard.
    Last edited by TacheDeChoco; December 26th, 2010 at 09:59 AM.

  2. #2
    Join Date
    Nov 2009
    Beans
    2
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Exclamation Re: Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic)

    Thank you for your clear explaination.
    I followed the above instructions step by step,
    but it didn't solve my "dummy output" problem directly.

    But then I figured out that my kernel was incorrect.
    So if anyone still keeps having this problem, look if you've got the right kernel.
    (there's another topic where this is clearly explained)
    Last edited by StudioCascade; November 8th, 2009 at 12:03 AM. Reason: Solved my problem with help of another topic

  3. #3
    Join Date
    Mar 2006
    Beans
    112

    Re: Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic)

    I followed all your steps and my card shows up when running cat /proc/asound/cards, but I still had a dummy output in the gnome sound preferences. But after editing /etc/modprobe.d/alsa-base.conf and adding options snd-hda-intel probe_mask=1 model=asus-v1s it finally worked!!! Thanks so much!
    Last edited by sgleo87; November 9th, 2009 at 03:35 PM.

  4. #4
    Join Date
    Oct 2009
    Beans
    5

    Re: Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic)

    Can any of you guys help me? Im new to linux and I still have no sound on Jaunty. I love the OS but if I cant get no sound im off back to Windows. Ive left loads of messages for help on here but so far not one reply.

    Could someone spare some time to talk me through what to check etc?

    Many thanks

  5. #5
    Join Date
    May 2009
    Beans
    18

    Re: Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic)

    I tried following this guide but it didn't work for me.

    I found this guide, upgrade-alsa and noticed that it failed when I tried to do

    sudo apt-get -y install linux-headers-`uname -r` libncursesw5-dev

    while it was trying to look for the drivers for version 16 of the kernel.

    Rebooted back to version 14, and the sound worked!

    Is there any way I can get that linux-header installed for version 16?

  6. #6
    Join Date
    Apr 2008
    Beans
    4

    Talking Re: Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic)

    Hey Bernard!

    You are a life saver! I followed your instructions and it worked!

    I am using a HP pavillion DV6500, by the way.

    - Chayon

  7. #7
    Join Date
    May 2008
    Beans
    2

    Re: Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic)

    I have an Intel sound card and was having trouble getting the sound to work. My card had been detected, but I was still having problems. Removing and reinstalling alsa and pulseaudio worked for me. So if your having trouble, even if your card is detected, the above instructions could still help.

  8. #8
    Join Date
    Nov 2007
    Beans
    19

    Exclamation Chek the kernel !!

    Exactly same problem to me: upgraded from 9.04, and no sound card in cat /proc/asound/cards. No way to hear any sound.

    I SOLVED it as follows:

    INTRO :

    If you upgraded from previous versions, during installation you were asked several questions... if you answer with the DEFAULT to most of them, your GRUB menu list may be the old one !

    This means that you are running the old kernel against the new software packages of Karmic Koala... this is presumably the reason of alsa driver messing up.

    PROCEDURE :

    open two terminal window and place them side to side.
    On the first one type

    ls /boot/ -all

    search for the LAST version of the kernel, in my case was
    vmlinuz-2.6.31-17-generic

    on the other window type

    sudo nano /boot/grub/menu.lst

    go down and search for your boot section: it should look something like this:

    title Ubuntu 9.04
    root (hd0,4)
    kernel /boot/vmlinuz-2.6.31-17-generic root=UUID=922c9$
    initrd /boot/initrd.img-2.6.31-17-generic
    quiet

    now: the point here are the numbers after vmlinuz. They represent your kernel version. Using the adjacent other terminal window, look at the dates and VERIFY that your current vmlinuz version is actually the last one.

    If not EDIT the kernel and initrd lines accordingly. You have just to change the numbers of vmlinuz-2.6.xx-yy-generic and initrd.img-2.6.xx-yy-generic. Make it match the last version you have.

    =====================================

    After you fix this SAVE and close the file. Then do in terminal:

    sudo update-grub

    THEN remove all alsa and pulseadio and install them again. To do this go in terminal and do:

    sudo apt-get remove --purge alsa-base
    sudo apt-get remove --purge pulseaudio
    sudo apt-get clean && sudo apt-get autoremove
    sudo apt-get install alsa-base
    sudo apt-get install pulseaudio

    then reset, your sound should be OK now.

    This is the way I fixed my system after an update from 9.04 to 9.10. Cross your fingers and everything should work for you too.

    Greg Ruo


  9. #9
    Join Date
    Oct 2009
    Beans
    6
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic)

    Thanks a ton! that worked!

    Procedure:
    1. check the kernel [thanks la1234uk]
    2. then continue from sudo update-grub --- [thanks TacheDeChoco]

    Note: while editing the alsa-base-conf, model = auto worked for me too [thanks mammoth23]


    -- Sagar Hatekar
    Last edited by wild_ecstasy1985; January 17th, 2010 at 09:33 AM.

  10. #10
    Join Date
    Nov 2009
    Beans
    3

    Re: Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic)

    Quote Originally Posted by sgleo87 View Post
    I followed all your steps and my card shows up when running cat /proc/asound/cards, but I still had a dummy output in the gnome sound preferences. But after editing /etc/modprobe.d/alsa-base.conf and adding options snd-hda-intel probe_mask=1 model=asus-v1s it finally worked!!! Thanks so much!
    The exact same happened here, the card showed up but was still dummy output, editing /etc/modprobe.d/alsa-base.conf did the trick for me.

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •