Page 2 of 7 FirstFirst 1234 ... LastLast
Results 11 to 20 of 61

Thread: Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic)

  1. #11
    Join Date
    Dec 2008
    Beans
    165

    Re: Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic)

    Bummer
    Last edited by HuaiDan; November 15th, 2009 at 07:30 AM. Reason: Needless rant

  2. #12
    Join Date
    Dec 2008
    Beans
    165

    Re: Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic)

    Finally got it, here.s what I had to do:

    Purged pulseaudio, didn't reinstall it throughout the whole procedure.

    Whenever I force reloaded alsa, I noticed my compositing flickered and my cairo dock did funny things. Digging into that problem revealed that I had the old NVidia driver still trying to load for the old kernel, and my menu.lst wasn't loading the new kernel, which was trying to load the new Linux video driver (phew!)

    Edited my menu.lst to load the new kernel, removed new linux video driver, the installed the new NVidia driver from the Nvidia website (190 version). Rebooted. Now I had beautiful compositing, still no sound.

    Then I edited /etc/modprobe.d conf files.
    Removed the modem blacklist entries there.
    Two files there I didn't quite understand: alsa-base-conf and als-base.conf
    Made sure these two files had the same content. Not sure if this was necessary, but...
    Put this entry into both :
    options snd-hda-intel model=3stack

    Completely deleted the power saving entry, because I have had suspicious results before trying to comment out lines in .conf files.


    Did a hard reboot, checked system/preferences/multimedia systems selector (you may need to add this to the menu, but it's there), selected ALSA and default for everything (dare not experiment there because...)

    Got tone when I tested. Music in Amarok. Finally.


    It really sucks having gone through all that. Kind of a psychological mind f*** if you ask me.

  3. #13
    Join Date
    Oct 2009
    Beans
    1

    Re: Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic)

    I had the same problem. I used to force reload alsa as described above to get the sound, but today I also found a simpler solution from this post

    https://bugs.launchpad.net/system76/+bug/463874

    after removing the software modem driver I finally got the sound back.

  4. #14
    Join Date
    Apr 2007
    Beans
    3

    Re: Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic)

    Quote Originally Posted by mammoth23 View Post
    Thanks for the perfect hint. I followed all your steps even though my sound card was identified from the very first. Nevertheless, I didn't hear anything and only a dummy output showed up in pulseaudio.

    My configuration: Acer Travelmate 8100, Soundcard: HDA Intel, Chip: Realtek ALC880.
    using options snd-hda-intel probe_mask=1 model=auto did the job.

    Many thanks!
    "model=auto" did it! Thanks

  5. #15
    Join Date
    Dec 2008
    Beans
    165

    Re: Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic)

    Addendum:

    Reinstalled Pulseaudio, got my sound controls back.

    re-edited my alsa-base.conf and alsa-base-conf to read:

    options snd-hda-intel model=6stack-dig

    Don't know if that last one made a difference, but that's what I have.

  6. #16
    Join Date
    Nov 2009
    Beans
    1
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic)

    removing software modems from system>hardware drivers worked for me too

  7. #17
    Join Date
    Dec 2008
    Beans
    165

    Re: Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic)

    Addendum:


    Use this webpage to get the model number for the conf files, based on your sound chipset info you get from sudo lspci. That should really narrow the field.

    http://forumubuntusoftware.info/view...php?f=7&t=3398

    I then aliased the soundcard paths in alsa-base.conf and alsa-base-conf as follows, and added index=0:
    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel
    options snd-hda-intel model=6stack-dig index=0



    Doing this really fine tuned the audio options. Whereas before I had one default option under sound preferences/hardware/Settings for the selected device:, now I have several for surround, digital, analog, stereo, which upon testing work as intended. Truly functional at this point.

    Think I've reached a good stopping point, audio has been optimized. Thanks to all for contributing their valuable input.

  8. #18
    Join Date
    Feb 2008
    Beans
    53

    Re: Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic)

    Quote Originally Posted by tangled View Post
    "model=auto" did it! Thanks


    Yeah this did it for me too.

  9. #19
    Join Date
    Nov 2008
    Beans
    98

    Re: Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic)

    Removing software modems fixed it for me too.

  10. #20
    Join Date
    Dec 2009
    Beans
    6

    Re: Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic)

    Thank you very much for this solution. I've tried lots of attempts to make my sound work, but this only worked. One more time THANK YOU!!!!

Page 2 of 7 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •