Results 1 to 3 of 3

Thread: ati radeon x2300 support problem in ubuntu 9.04

  1. #1
    Join Date
    Sep 2009

    ati radeon x2300 support problem in ubuntu 9.04

    When my system shuts down, it shows some error message saying there is some "hardware problem in PCI0" and screen becomes red and turns off.

    After updating my system the system is unable to get into the gui interface that is the loading screen comes and some gradient colour change occurs.
    What to do

    System-Sony vaio cr353
    intel core 2 duo T8100
    ati radeon X2300
    Last edited by nidhinkrishnanv; October 15th, 2009 at 12:15 PM.

  2. #2
    Join Date
    Oct 2009

    Smile Re: ati radeon x2300 support problem in ubuntu 9.04

    Ok dude

    I had the some problem with the ATI Mobility Radeon X2300 HD

    And I got lucky and a smart dude told me what to do

    But this was for the 9.04 and I got the advice some time ago but I wrote it all down but I do not remember all details just that it worked and if it fails you might have to do a complete reinstall so save all your stuff and do this

    After every line press enter

    Applications > Accesories > Terminal

    sudo apt-get install git-core

    sudo apt-get build-dep libdrm mesa

    git clone git://

    cd mesa

    git checkout -b radeon-rewrite origin/radeon-rewrite

    ./ --prefix=/usr (Not needed)

    gedit configs/linux-dri

    Remove i810 i915 i965 mach64 mga r128 r200 s3v \ savage sis tdfx trident unichrome ffb swrast only r300 and radeon should stay take out the slash too only ---> DRI_DIRS = r300 radeon <--- left

    sudo apt-get install python-qt3-gl python-qt4-gl freeglut3

    sudo apt-get install qt3-dev-tools qt4-dev-tools

    sudo apt-get install xorg-dev

    sudo apt-get install build-essential libstdc++5

    make linux-dri-x86

    sudo cp lib/lib* /usr/lib && sudo cp lib/* /usr/lib/dri

    sudo mkdir /usr/local/lib/dri && sudo cp lib/* /usr/local/lib/dri

    Restart computer

  3. #3
    Join Date
    Sep 2009

    Re: ati radeon x2300 support problem in ubuntu 9.04

    when i tried the command

    git clone git://

    message :
    Initialized empty Git repository in /home/nidhin/mesa/mesa/.git/[0:]: errno=Connection timed out
    fatal: unable to connect a socket (Connection timed out)



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts