Results 1 to 3 of 3

Thread: Disabling login drumbeat in Karmic

Hybrid View

  1. #1
    Join Date
    Dec 2008
    Beans
    29
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Disabling login drumbeat in Karmic

    Hello all,

    Just upgraded my eee to Koala and that drumbeat noise on login is back. I had disabled it in Jaunty in system>>administration>>login screen, but my settings weren't carried over during the upgrade and the option to disable the sound is no longer in system>>adminstration>>login screen. I have all alert sounds disabled under system>>sounds. All of the threads I've found relating to the drumbeat are for older versions of Ubuntu. Any help would be appreciated.

  2. #2
    Join Date
    Aug 2007
    Location
    Off the Alaskan Coast
    Beans
    794
    Distro
    Ubuntu Development Release

    Re: Disabling login drumbeat in Karmic

    I think the sound file is: /usr/share/sounds/ubuntu/stereo/dialog-question.ogg, I don't know where to disable it though..but with this info you should be able to change it at least.

    Edit: This seems to be a known bug with Gnome, try this command to disable the login drumbeat:
    Code:
    sudo -u gdm dbus-launch gconftool-2 --set /desktop/gnome/sound/event_sounds --type bool false
    Last edited by JBAlaska; November 5th, 2009 at 06:10 PM.
    FIC K8-800T AMD64 3200+ 2GB PC3200 GeForce 6800GT Mandriva 2010 KDE+Compiz+Emerald
    MSI K9N2GM AMD 9950BE 4GB DDR2-800 GeForce 8200 10.10 WUSB600N
    Acer 6920 Core 2 Duo 4GB GeForce 9500GS 10.04 Ubuntu User #17586

  3. #3
    Join Date
    Sep 2009
    Beans
    11

    Re: Disabling login drumbeat in Karmic

    The above command worked for me. I was puzzled why turning off the alert sound events did not work, but this command clarified it.

    Your settings apply only to your user account, but at the time the login screen appears you are not logged in yet, so your settings are not yet loaded.

    What the above command does is turn off the alert sound events for the 'gdm'-user, the virtual user in charge of the login screen. Problem solved!

    It is a terminal way of logging in as the gdm-user, loading up gconf-editor, navigating to the sound settings (/desktop/gnome/sound/) and unticking the 'event_sounds' checkbox.

    Here's the bug report on launchpad:
    https://bugs.launchpad.net/ubuntu/+s...dm/+bug/437429
    Last edited by Konrad Ansehelm; November 17th, 2009 at 01:14 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •