Results 1 to 3 of 3

Thread: Can't connect to ieee1394b camera (Karmic)

  1. #1
    Join Date
    Nov 2009
    Beans
    3

    Question Can't connect to ieee1394b camera (Karmic)

    Hi!

    This is the first time I'm posting a question to ubuntuforums - my apologies if I picked a wrong category.

    I'm having problems with an ieee1394b camera (Sony XCD-U100). The FireWire card, as well as the camera are detected (at least on some level), since lsmod | grep 1394 gives:
    raw1394 29096 0
    video1394 18600 1
    ohci1394 33780 1 video1394
    ieee1394 100896 3 raw1394,video1394,ohci1394


    lspci shows that the card is present:
    12:04.0 FireWire (IEEE 1394): Texas Instruments TSB82AA2 IEEE-1394b Link Layer Controller (rev 01)

    and

    cat /var/log/messages | grep ieee
    Nov 2 16:50:45 nnn kernel: [ 13.081697] ieee1394: raw1394: /dev/raw1394 device initialized


    also raw1394 is present in /dev/ and I ran chmod 666 /dev/raw1394

    I've installed Coriander and it also shows that the camera is detected - however I can't get any images.

    In Kino, when I switch to Capture tab I get "No AV/C compliant cam connected or not switched on?"

    testlibraw shows 1 connected device and agrees to talk with it
    dvgrab tells me: "Error: no camera exists"

    I don't think it's even necessary to say, but I'm not an expert on this field , so *any* help would be great!

    cheers,
    Mathias
    Last edited by essenv; November 5th, 2009 at 09:38 AM.

  2. #2
    Join Date
    Nov 2009
    Beans
    3

    Re: Can't connect to ieee1394b camera (Karmic)

    Bump

  3. #3
    Join Date
    Nov 2009
    Beans
    3

    Re: Can't connect to ieee1394b camera (Karmic)

    Problem solved.

    I switched the cable to the other 1394b connector (the camera has two) and got Coriander working. No idea why the other connector didn't work..

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •