Results 1 to 9 of 9

Thread: Mousepad playing up

  1. #1
    Join Date
    Sep 2009
    Beans
    16

    Mousepad playing up

    My mouse pad is acting very strangely since I installed Ubuntu, it seems like it's clicking itself if you know what I mean, it's quite annoying especially as I have a lot of essays to plow through at the moment. I'm runng 9.4 on an Acer laptop. Anyone have any ideas how to solve this? I've tried installing touch freeze but it doesn't seem to work.

  2. #2
    Join Date
    Nov 2009
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mousepad playing up

    Is tap to click enabled? Meaning when you tap your mouse track pad it clicks. Go to system, preferences, mouse, then touchpad tab and unclick "enable mouseclicks with touchpad"

  3. #3
    Join Date
    Sep 2009
    Beans
    16

    Re: Mousepad playing up

    I'd kind of like to keep the mousepad clicks though. Is there any other way around it?

  4. #4
    Join Date
    Nov 2009
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mousepad playing up

    Well, that depends, does it click itself when your hand is not over the mousepad, or does it only click itself when you are using it. Because if it is the latter then you will have to disable tap to click because it is you who are indeed unintentionally clicking it.

  5. #5
    Join Date
    Sep 2009
    Beans
    16

    Re: Mousepad playing up

    Haha no it just randomly does it, I almost went insane trying to figure out if it was me or not though.

  6. #6
    Join Date
    Nov 2009
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mousepad playing up

    1. Does it do it in any other OS?
    2. Try disabling tap to click and see if the problem goes away.
    3. Have you noticed a lag in your intentional clicks?
    4. What 3rd part mouse apps do you have installed.
    5. How recent did this start?

  7. #7
    Join Date
    Sep 2009
    Beans
    16

    Re: Mousepad playing up

    1. I don't run any other OS
    2. It has gone since I disabled the tap click
    3. I haven't noticed any lag
    4. Only touchfreeze but I've uninstalled that because it doesn't do anything and the problem persists
    5. Since I uninstalled Windows, which is most likely where the problem stems from. I'm thinking that I've probably managed to delete the drivers that keep the mousepad in check but I don't know how to sort this in Ubuntu.

  8. #8
    Join Date
    Nov 2009
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mousepad playing up

    Uninstalling Windows drivers has no affect on your Linux drivers, so thats not it. All I can say is keep tap-to-click disabled and try it again with every new update that comes out to see if that fixes it, else tap-to-click is overrated anyways. Touchpad's are capacitive and their might be a problem with your touchpad, maybe some sort of interference or short. Does your mouse ever move randomly?

  9. #9
    Join Date
    Mar 2008
    Beans
    19

    Re: Mousepad playing up

    just want to put in a bean here as i have these problems since some intrepid update.. now fresh install of karmic to counter these problems with no success..

    basically, this is not a hardware problem.. hundreds of users have similar issues.. the standard answer to change settings in mouse preference might work for some, but it isn't solving the problem for many..

    the mousepad acting by itself, right clicking, left clicking, not wanting to click in open windows before a right click, ++crazy stuff, is enough to drive me insane, and much less borrow my computer to anyone else; it took me a long time to even be able to half work with these problems..

    op: i hope you find a solution, and all the others with similar problems too. really looking forward to that day.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •