Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: gnome-panel always on top

  1. #1
    Join Date
    Aug 2006
    Location
    United States
    Beans
    Hidden!

    Question gnome-panel always on top

    Does anyone know how I might configure the gnome-panel so that open windows can cover it? I'd like to have it free floating in the middle of the desktop without always having to look at it floating on top of my applications.

    And no, I don't merely want to hide it.

  2. #2
    Join Date
    Dec 2009
    Beans
    4

    Re: gnome-panel always on top

    Late reply, but I couldn't find an answer for this anywhere else, so I might as well post the answer here.

    Right click the panel -> Properties -> Autohide
    From Compiz: Go to "Window Rules" and add "class=Gnome-panel" under "Below"

    See attachment, the top panel is covered by the browser, and it's never hidden.

    Edit:
    That didn't work the second time I did it. This did work, however:
    Uncheck Autohide
    Add the Window Rule
    Recheck Autohide

    If you don't want to do this for every panel, "Grab" the Window Title of the panel using the tool in compiz. Use that rather than "class=Gnome-panel". It'll look something like "title=Top Expanded Edge Panel".
    Attached Images Attached Images
    Last edited by sentythee; December 23rd, 2009 at 02:23 AM.

  3. #3
    Join Date
    Dec 2005
    Beans
    63

    Re: gnome-panel always on top

    Quote Originally Posted by sentythee View Post
    Late reply, but I couldn't find an answer for this anywhere else, so I might as well post the answer here.

    Right click the panel -> Properties -> Autohide
    From Compiz: Go to "Window Rules" and add "class=Gnome-panel" under "Below"

    See attachment, the top panel is covered by the browser, and it's never hidden.

    Edit:
    That didn't work the second time I did it. This did work, however:
    Uncheck Autohide
    Add the Window Rule
    Recheck Autohide

    If you don't want to do this for every panel, "Grab" the Window Title of the panel using the tool in compiz. Use that rather than "class=Gnome-panel". It'll look something like "title=Top Expanded Edge Panel".
    hey that works perfectly fine, thanks a lot!!!!!!!

  4. #4
    Join Date
    Mar 2010
    Beans
    4
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: gnome-panel always on top

    Thanks for your response
    I have Ubuntu 4.10.
    In this way my system works great but the top panel to bottom panel does not work if there is another way to solve
    Help please and thank you for your attention

  5. #5
    Join Date
    May 2005
    Location
    Canada
    Beans
    80

    Re: gnome-panel always on top

    re: compiz-settings "Window Rules"

    Quote Originally Posted by umanzor View Post
    hey that works perfectly fine, thanks a lot!!!!!!!
    Well, it works -- and thanks for that!

    But it needs a bit of extra sauce. Add this rule as well:

    Above title=Panel Properties

    That fixes the "Properties" pop-up for the panel.

    But I also have another panel, normally hidden, and now when it unhides it is still covered by everything else.. I need that one to stay on top. How ?

    I suppose the answer is probably in the "grab the Window Title" suggestion above.. but I haven't a clue how to do that ???

    EDIT: Oh, found it.

    Click on the PLUS SIGN to the right of the "Match-->Below" line.

    An "Edit Match" pop-up should appear. Change the "Type" field to "Window Title", click on "Grab", and then (finally) click on the panel who's title you want to discover. The "title" will appear in the "Value" field of the "Edit Match" pop-up.

    In my case, with the panel at the top of the screen, the "Window Title" for it was discovered to be "Top Expanded Edge Panel". So I now use this rule to force it below other windows:

    Below title=Top Expanded Edge Panel

    And my other auto-hide panels still stay on top when un-hidden. Woot!

    Cheers
    Last edited by mlord; September 19th, 2010 at 04:15 PM.

  6. #6
    Join Date
    May 2005
    Location
    Canada
    Beans
    80

    Re: gnome-panel always on top

    Oh bother.. all of the above stuff works.. until I log out and log in again. At which point, gnome-panel is invisible.. buried under the desktop, I suspect.

    So.. I've abandoned that entire approach, and just written a little script that uses the fantasic "wmctrl" app instead.

    So.. first, install wmctrl from synaptic, and then put this script somewhere useful, and add it to your GNOME "Startup Applications". Works like a charm, for me at least.
    Code:
    #!/bin/bash
    ##
    ## Script to fix the top gnome-panel, so that it can be covered by other apps.
    ## Stick this into GNOME System->Preferences->Startup_Applications.
    ##
    ## Written by Mark Lord <mlord@pobox.com>, free for all redistribution/uses.
    ##
    (
            ## If we change the property too soon,
            ## gnome-panel will start up buried under the desktop.
            ## Not sure how to know "how soon is too soon" (~6 seconds here),
            ## so we will wait for a good known app to start up first.
            ##
            WAITFOR="gnome-screensaver"
            ##
            for i in {0..40} ; do   ## 20sec max wait time
                    killall -0 $WAITFOR && break
                    sleep 0.5
            done
            ## logger -- "$0: waited $((i / 2)).$(((i % 2) * 5)) secs"
            wmctrl -r "Top Expanded Edge Panel" -b remove,above -b add,below
            exit 0
    ) &>/dev/null &
    exit 0
    Last edited by mlord; September 20th, 2010 at 01:20 PM.

  7. #7
    Join Date
    May 2005
    Location
    Canada
    Beans
    80

    Re: gnome-panel always on top

    I should add that this works much better when "Constrain Y" is unchecked, in CompizConfig Settings Manager, under the "Move Window" plugin settings.

    -ml

  8. #8
    Join Date
    Nov 2010
    Beans
    3

    Re: gnome-panel always on top

    @mlord

    I tried to add the rule from compiz but then the "always on top" function of other windows break. But when I tried wmctrl, all worked perfectly . Thanks !

  9. #9
    Join Date
    May 2010
    Beans
    3

    Re: gnome-panel always on top

    Didn't always work for me... My guess is that it tried to do the wmctrl command too soon. I modified the script a lot to fix it. Perhaps it's possible in mlords script aswell by adding another sleep 5 before the wmctrl command... I'm not very good - at all - at bash scripting but I've modified it to:
    #!/bin/bash
    process_found=false
    while [ $process_found == false ] ;
    do
    sleep 1
    pid=`ps -eo pid,args | grep 'gnome-screensaver' | grep -v grep | cut -c1-6`
    if [ "$pid" != "" ] ; then
    process_found=true
    fi
    done
    sleep 5
    wmctrl -r "Top Expanded Edge Panel" -b remove,above -b add,below
    exit 0

    It uses the process id of gnome-screensaver. I found the command while googling, but I don't know where anymore. Added a lot of extra commands I think, but I didn't know how the pkill command works and if it returns a value or not...
    By adding the sleeps in there I suppose it's roughly 5 seconds max before the wmctrl kicks in after login. Ample time before you can put any screens over it...
    I'm also not sure if the ps -e was such a good idea, but I suppose if it doesn't work you can always modify it to ps -u <username> -o pid,args as it only lists the processes of your user. The script now works on all of my systems.

    Anyway thanks a lot Mark, this issue was really starting to irritate me about gnome

  10. #10
    Join Date
    Jul 2009
    Beans
    38
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: gnome-panel always on top

    mlord,
    I've added the script to my startup, and unchecked "constrain y" in compiz, but instead of having the panel appear below the windows, the windows just slide under the panel when I move them. Do you know why this might be happening or how I could fix it please? I would love to get this to work.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •