Page 5 of 6 FirstFirst ... 3456 LastLast
Results 41 to 50 of 52

Thread: Low Resolution with Ubuntu 9.10

  1. #41
    Join Date
    Nov 2009
    Beans
    20

    Re: Low Resolution with Ubuntu 9.10

    I had the same problem with a LCD television have found a work around with the following steps.

    1. use xrandr to return your adaptor

    xrandr
    Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 8192 x 8192
    VGA1 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
    800x600 60.3
    640x480 59.9
    1920x1200_60.00 59.9*
    DVI1 disconnected (normal left inverted right x axis y axis)

    2. get your mode with cvt

    cvt 1920 1200 60
    Modeline "1920x1200_60.00" 193.25 1920 2056 2256 2592 1200 1203 1209 1245 -hsync +vsync

    3. using xrandr add this mode.
    xrandr --newmode "1920x1200_60.00" 193.25 1920 2056 2256 2592 1200 1203 1209 1245 -hsync +vsync
    xrandr --addmode VGA1 "1920x1200_60.00"

    4. change to this mode using System>Preferences>Display


    5.Once you are happy then start Terminal and logon with

    sudo bash (then your password)

    cd /

    cd /etc/gdm/Init

    gedit Default

    Insert line the xrandr lines before initctl

    xrandr --newmode "1920x1200_60.00" 193.25 1920 2056 2256 2592 1200 1203 1209 1245 -hsync +vsync
    xrandr --addmode VGA1 "1920x1200_60.00"


    here are some generic modes for LCD televisions that could be added (use with care!!!)


    #modes for VGA/HDMI Televisions/ Generic
    # VGA modes
    xrandr --newmode "1024x768_60.00" 63.50 1024 1072 1176 1328 768 771 775 798 -hsync +vsync
    xrandr --newmode "1280x720_60.00" 74.50 1280 1344 1472 1664 720 723 728 748 -hsync +vsync
    xrandr --newmode "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync
    xrandr --newmode "1600x1200_60.00" 161.00 1600 1712 1880 2160 1200 1203 1207 1245 -hsync +vsync
    # 1920x1200 16x10 will display as 1600x1200 on many LCD panels
    xrandr --newmode "1920x1200_60.00" 193.25 1920 2056 2256 2592 1200 1203 1209 1245 -hsync +vsync

    # DVI1 modes
    xrandr --newmode "1280x720_60.00" 74.50 1280 1344 1472 1664 720 723 728 748 -hsync +vsync
    xrandr --newmode "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync


    #VGA1 Out
    xrandr --addmode VGA1 "1024x768_60.00"
    xrandr --addmode VGA1 "1280x1024_60.00"
    xrandr --addmode VGA1 "1600x1200_60.00"
    xrandr --addmode VGA1 "1920x1200_60.00"
    #DVI1 out 720p and 1080p
    xrandr --addmode DVI1 "1280x720_60.00"
    xrandr --addmode DVI1 "1920x1080_60.00"
    Last edited by Cheltspy; November 8th, 2009 at 05:20 PM.

  2. #42
    Join Date
    Nov 2009
    Beans
    1

    Re: Low Resolution with Ubuntu 9.10

    Ok, so I tried everything recommended by gabak and the other users here. I tried one version where Xorg created my xorg.conf file and another where nvidia created the xorg.conf file. Both times I made the appropriate edits and nothing is working out.

    I have an LG-W3000H monitor (2560x1600 native res) and I'm currently stuck at 1280x800. If anyone has any suggestions please let me know. I'll post my current xorg.conf file below in case there's a seriously stupid error I made and it's easily correctable.

    One final note, I am running the video through a KVM switch but it is a DVI port. The other computer (running windows vista) recognizes the 2560x1600, but I didn't have the KVM switch installed when I installed windows. Think it's a problem with the detection? i.e. plug the monitor directly into the computer, create the xorg.conf file then hook the KVM switch up? I didn't think it would matter but it might.

    [xorg.conf]

    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Fri Aug 14 17:54:58 PDT 2009
    
    Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
        ModulePath      "/usr/lib/xorg/modules"
        FontPath        "/usr/share/fonts/X11/misc"
        FontPath        "/usr/share/fonts/X11/cyrillic"
        FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath        "/usr/share/fonts/X11/Type1"
        FontPath        "/usr/share/fonts/X11/100dpi"
        FontPath        "/usr/share/fonts/X11/75dpi"
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        FontPath        "built-ins"
    EndSection
    
    Section "Module"
        Load           "glx"
        Load           "dbe"
        Load           "extmod"
        Load           "record"
        Load           "dri2"
    EndSection
    
    Section "InputDevice"
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "InputDevice"
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/input/mice"
        Option         "ZAxisMapping" "4 5 6 7"
    EndSection
    
    Section "Monitor"    
        Identifier "Monitor0"
        VendorName "Monitor Vendor"
        ModelName "Monitor Model"
        HorizSync 30-63
        VertRefresh 56-71
        #UseModes "Modes0" #monitor0usemodes
        Option "PreferredMode" "2560x1600"
    EndSection
    
    Section "Device"
    
            ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
            ### [arg]: arg optional
            #Option     "SWcursor"               # [<bool>]
            #Option     "HWcursor"               # [<bool>]
            #Option     "NoAccel"                # [<bool>]
            #Option     "ShadowFB"               # [<bool>]
            #Option     "UseFBDev"               # [<bool>]
            #Option     "Rotate"                 # [<str>]
            #Option     "VideoKey"               # <i>
            #Option     "FlatPanel"              # [<bool>]
            #Option     "FPDither"               # [<bool>]
            #Option     "CrtcNumber"             # <i>
            #Option     "FPScale"                # [<bool>]
            #Option     "FPTweak"                # <i>
            #Option     "DualHead"               # [<bool>]
        Identifier     "Card0"
        Driver         "nvidia"
        VendorName     "nVidia Corporation"
        BoardName      "NV40 [GeForce 6800 Ultra]"
    EndSection
    
    Section "Screen"
        Identifier "Screen0"
        Device "Card0"
        Monitor "Monitor0"
        DefaultDepth 24
        Subsection "Display"
            Depth 24
            Modes "2560x1600"
        EndSubsection
    EndSection

  3. #43
    Join Date
    Aug 2009
    Beans
    2

    Re: Low Resolution with Ubuntu 9.10

    Hello Sebastian

    I have same problem with you, and same machine, mine toshiba dynabook satellite 1800

    i used to ubuntu 8.04 and with some trick i have 1024x768 resolution but when i switch to karmic, i have same problem with u

    here try this :

    1. use and run ubuntu livecd that your machine can display 1024x768 mode (mine 8.04 with some tricks)

    2. copy xorg.conf file from /etc/X11 to flashdisk

    3. shutdown livecd and run ubuntu 9.10

    4. copy xorg.conf from flashdisk to /etc/X11

    5. restart GDM sudo /etc/init.d/gdm restart

    6. and try to set system>preference>display and change to 1024x768 mode


    it work for me .... try yours .......

  4. #44
    Join Date
    Dec 2009
    Beans
    1

    Re: Low Resolution with Ubuntu 9.10

    Quote Originally Posted by gabak View Post
    follow this instruction

    sudo gedit /etc/X11/xorg.conf


    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Monitor Vendor"
    ModelName "Monitor Model"
    HorizSync 30-63
    VertRefresh 56-71
    #UseModes "Modes0" #monitor0usemodes
    Option "PreferredMode" "1024x768"
    EndSection

    Section "Modes"
    Identifier "Modes0"
    #modes0modeline0
    EndSection

    Section "Device"
    ### Available Driver options are:-
    ### Values: i: integer, f: float, bool: "True"/"False",
    ### string: "String", freq: "f Hz/kHz/MHz"
    ### [arg]: arg optional
    #Option "NoAccel" # [bool]
    #Option "SWcursor" # [bool]
    #Option "ColorKey" # i
    #Option "CacheLines" # i
    #Option "Dac6Bit" # [bool]
    #Option "DRI" # [bool]
    #Option "NoDDC" # [bool]
    #Option "ShowCache" # [bool]
    #Option "XvMCSurfaces" # i
    #Option "PageFlip" # [bool]
    Identifier "Card0"
    Driver "intel" #card0driver
    VendorName "Intel Corporation"
    BoardName "82865G Integrated Graphics Controller"
    BusID "PCI:0:2:0"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Card0"
    Monitor "Monitor0"
    DefaultDepth 24
    Subsection "Display"
    Depth 24
    Modes "1024x768"
    EndSubsection
    EndSection

    Hi Gapak.
    Thanx alot Dear..
    It Works for me. now i have my fav resolution.
    advise to all newbies, try mentioned above trick and thy will find every thing right then
    Once again thanks

  5. #45
    Join Date
    Dec 2009
    Beans
    4

    Re: Low Resolution with Ubuntu 9.10

    I have the same problem here as well with the max res. I can get is 800x600

    I have tried following the steps below
    1) cvt 1280 800
    # 1280x800 59.81 Hz (CVT 1.02MA) hsync: 49.70 kHz; pclk: 83.50 MHz
    Modeline "1280x800_60.00" 83.50 1280 1352 1480 1680 800 803 809 831 -hsync +vsync

    2) xrandr --newmode "1280x800_60.00" 83.50 1280 1352 1480 1680 800 803 809 831 -hsync +vsync
    2) xrandr --addmode default 1280x800_60.00
    3) xrandr -s 1280x800
    Failed to change the screen configuration

    I also have tried Gabak's method, which I have seen couple reply here it worked for them. But I could not get them to work too.

    I checked the log file, it shows
    Fatal server error:
    no screens found

    My video card is
    lspic | grep VGA
    01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)

    I have tried finding the SIS driver, I found one here in this forum, but was not working as well.

    EDIT:
    the driver I found is in this thread, http://ubuntuforums.org/showthread.php?t=1135091

    problem SOLVED:
    http://ncc-1701a.homelinux.net/~linu...page=Downloads
    choose this one, xorg-driver-sisimedia_0.9-1_i386.deb
    install, then everything is OK.
    Last edited by omgurindanger; December 20th, 2009 at 04:03 AM. Reason: Add more info

  6. #46
    Join Date
    Jun 2005
    Location
    Coimbatore, India
    Beans
    182
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Re: Low Resolution with Ubuntu 9.10

    Thank you, Cheltspy, for your post at http://ubuntuforums.org/showpost.php...2&postcount=41

    I am running Kubuntu 9.10 with a GeForce4 MX 440 card and a Philips 190 S7 LCD monitor.

    The monitor has a preferred mode of 1280 by 1024 at 60 Hz.

    I have had to use the line

    xrandr --addmode default "1280x1024_60.00"

    to get the vertical refresh rate to 59.5 Hz on the KDE RandR tool.

    My difficulty is that I do not have an Init file like you do in GNOME as stated below.

    Quote Originally Posted by Cheltspy View Post
    5.Once you are happy then start Terminal and logon with

    sudo bash (then your password)

    cd /

    cd /etc/gdm/Init

    gedit Default

    Insert line the xrandr lines before initctl

    xrandr --newmode "1920x1200_60.00" 193.25 1920 2056 2256 2592 1200 1203 1209 1245 -hsync +vsync
    xrandr --addmode VGA1 "1920x1200_60.00"
    How may I do the equivalent in KDE 4.3.2 on Kubuntu so tht my system wakes up with a vertical refresh rate of 60 Hz rather than 50 Hz as at present.

    As an aside, I might add that X and the nvidia driver seem to think it is a CRT rather than an LCD monitor. Any hints on how to set this correctly are most appreciated as well.

    Many thanks for your help.

  7. #47
    Join Date
    Apr 2009
    Beans
    153

    Re: Low Resolution with Ubuntu 9.10

    Quote Originally Posted by rizalbrandan View Post
    Hello Sebastian

    I have same problem with you, and same machine, mine toshiba dynabook satellite 1800

    i used to ubuntu 8.04 and with some trick i have 1024x768 resolution but when i switch to karmic, i have same problem with u

    here try this :

    1. use and run ubuntu livecd that your machine can display 1024x768 mode (mine 8.04 with some tricks)

    2. copy xorg.conf file from /etc/X11 to flashdisk

    3. shutdown livecd and run ubuntu 9.10

    4. copy xorg.conf from flashdisk to /etc/X11

    5. restart GDM sudo /etc/init.d/gdm restart

    6. and try to set system>preference>display and change to 1024x768 mode


    it work for me .... try yours .......
    Does anybody have a read out for xorg.conf file from 8.04 to save doing all the above?? Then I could just work from point 4. onwards. Cheers.

  8. #48
    Join Date
    Apr 2009
    Beans
    153

    Re: Low Resolution with Ubuntu 9.10

    I've downloaded 8.04 & can see several folders titled X11 but which one will have the appropriate file in?

  9. #49
    Join Date
    Apr 2009
    Beans
    153

    Re: Low Resolution with Ubuntu 9.10

    Does anyone know if the latest ubuntu will solve this low resolution problem?

  10. #50
    Join Date
    Jun 2007
    Location
    Sillycon Valley
    Beans
    34
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Low Resolution with Ubuntu 9.10

    These steps worked perfectly on 10.10.
    • Sceptre X24WG, 1920 x 1200
    • Intel 82865G



    Quote Originally Posted by Cheltspy View Post
    I had the same problem with a LCD television have found a work around with the following steps.

    1. use xrandr to return your adaptor

    xrandr
    Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 8192 x 8192
    VGA1 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
    800x600 60.3
    640x480 59.9
    1920x1200_60.00 59.9*
    DVI1 disconnected (normal left inverted right x axis y axis)

    2. get your mode with cvt

    cvt 1920 1200 60
    Modeline "1920x1200_60.00" 193.25 1920 2056 2256 2592 1200 1203 1209 1245 -hsync +vsync

    3. using xrandr add this mode.
    xrandr --newmode "1920x1200_60.00" 193.25 1920 2056 2256 2592 1200 1203 1209 1245 -hsync +vsync
    xrandr --addmode VGA1 "1920x1200_60.00"

    4. change to this mode using System>Preferences>Display

    5.Once you are happy then start Terminal and logon with

    sudo bash (then your password)
    cd /
    cd /etc/gdm/Init
    gedit Default

    Insert line the xrandr lines before initctl

    xrandr --newmode "1920x1200_60.00" 193.25 1920 2056 2256 2592 1200 1203 1209 1245 -hsync +vsync
    xrandr --addmode VGA1 "1920x1200_60.00"

    ... stuff deleted ...

Page 5 of 6 FirstFirst ... 3456 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •