Page 4 of 6 FirstFirst ... 23456 LastLast
Results 31 to 40 of 52

Thread: printer sharing worked in 9.04 but not 9.10

  1. #31
    Join Date
    Jul 2007
    Ubuntu 9.10 Karmic Koala

    Re: printer sharing worked in 9.04 but not 9.10


    So these are the steps that I was just able to get to work. They are similar to the ones from WhyIsThisOpen but maybe the fields are different. Note: I'm running Snow Leopard on the Mac, and Ubuntu Karmic on the Ubuntu system. Both are on the same network.
    1. On Ubuntu, go to http://localhost:631 in your browser. Click “Printers” and make sure you have the proper name of the printer that is connected to Ubuntu. Click on it, and in the http://localhost:631/printers/PRINTERNAME screen, you can click Set As Server Default. I’m not entirely sure if this is a required step, but I did it.
    2. On the Mac, go to http://localhost:631 in your browser. Go to Administration > Add Printer. Let it finish looking. Choose the “Internet Printing Protocol (ipp)” option, and click Continue.
    3. In the Connection field, type http://SERVERNAME:631/printers/PRINTERNAME where SERVERNAME is the name of your Ubuntu server, and PRINTERNAME is the name by which the server knows the printer, as you saw in step 1. Click Continue.
    4. Note: In my previous setup, I was able to use http://SERVERNAME.local/, but in the current setup it doesn't work with .local. I just use http://SERVERNAME/.
    5. The Name, Description, Location, etc. fields can be whatever you like. Same for the settings on the following page.
    Last edited by flamingsole; November 29th, 2009 at 05:51 AM.

  2. #32
    Join Date
    Nov 2007

    Re: printer sharing worked in 9.04 but not 9.10

    flamingsole, that did the trick. nice find. for the server name, i had to use my IP address.

  3. #33
    Join Date
    Oct 2006
    Ubuntu 13.10 Saucy Salamander

    Re: printer sharing worked in 9.04 but not 9.10

    So... they are never gonna fix the bonjuor+cups issue?

    It used to work great!

  4. #34
    Join Date
    Dec 2008
    Ottawa, Canada
    Ubuntu 10.04 Lucid Lynx

    Smile Re: printer sharing worked in 9.04 but not 9.10

    I had this problem as well. Here's the workaround until CUPS gets updated...

    This problem is documented in bug 482836. It affects Windows Vista 64 and Windows 7 64-bit clients trying to connect to a Ubuntu 9.10 CUPS-networked printer. Error messages in Windows are vague and uninformative; I received error code 0x0000000d.

    The solution is to bind a network printer to LPT1 using this command from Windows. ie:
    net use lpt1 \\UbuntuHost\MyPrinter /persistent:yes
    You may have to run command prompt (cmd.exe) with administrator privileges. The persistent switch will allow this setting to be retained after reboot.

    Then map a local printer from Windows to LPT1. Voila!

    Thanks to the Ubuntu community for support over the years.

    Last edited by KiDQUiCK; January 17th, 2010 at 08:20 PM. Reason: oops

  5. #35
    Join Date
    Jan 2010

    Re: printer sharing worked in 9.04 but not 9.10

    Quote Originally Posted by lbodrozic View Post
    flamingsole, that did the trick. nice find. for the server name, i had to use my IP address.
    It should work at servername.local if you add the line:
    ServerAlias *
    to your cups config (at http://localhost:631/admin/ on the server, click 'edit configuration file').
    CUPS by default will name itself 'servername' and will view requests to 'servername.local' as invalid (you should see '...using invalid Host: field "server.local" ' in the error log). Of course, normal zeroconf means that clients won't see the server at 'servername', rather 'servername.local', so neither way works in the default setup.

    It really is completely ridiculous that something as basic as Bonjour printer sharing not only doesn't work, but stopped working when it worked just fine before. I can now print via both IPP and SMB (from OSX 10.6.2 and 10.5.4) with the fixes listed here, but Bonjour really is the norm these days and 9.10 should definitely not have been released with this not working, let alone kept broken for these 3 months since release.

  6. #36
    Join Date
    Oct 2008

    Re: printer sharing worked in 9.04 but not 9.10

    Quote Originally Posted by Gazneth View Post
    I worked around this problem by adding a line to /etc/rc.local
    Thanks Gazneth!

  7. #37
    Join Date
    Nov 2009

    Re: printer sharing worked in 9.04 but not 9.10

    Quote Originally Posted by Nausser View Post
    Same issue here. Upgraded from 9.04 to 9.10 and now none of my printing works. I had local network printing and IPP working perfectly. I even tried installing the printer and then sharing it on another computer with a fresh 9.10 install. No prevail.

    This is sort of a big one guys... how can these problems slip through every time? So many things were fixed with 9.10 and then this is allowed to happen.

    I sure hope this is figured out soon!
    Here’s how to do a basic shared printer setup using Samba in Ubuntu 9.10 Karmic Koala. This is the easiest way to do it, since with guest access and no authentication, anyone who can access the computer over a network connection will be able to print to the shared printer. However, this involves minimal security, so I would not recommend using this configuration on a machine with any actual file shares. Overall, I think this setup would be best for home users, or small offices. Enterprise users, or home users with more rigorous security needs, should use a more secure configuration. All that said, here’s how to set it up.
    First, you will need a printer of some sort connected to your Ubuntu machine. Either a USB printer or a networked printer (one with its own IP address) will work, so long as it’s properly set up on your Ubuntu computer.
    Next, open up a Terminal window, and install Samba using the following command:

    sudo apt-get install samba

    We’ll need to edit Samba’s configuration file, smb.conf, with the following command (make certain to create a backup copy of the smb.conf file first, in case anything goes wrong):

    sudo gedit /etc/samba/smb.conf

    (Note that you can replace gedit with your editor of choice, but if you’re in the GUI, you might as well use gedit.)
    Once inside the smb.conf file, you’ll need to change a number of lines. Some of the lines will be commented out with a semicolon ( or a crosshatch (#) in front of them. Note that any lines we change here will need to have the ; or the # removed to activate them.
    Because we’re going to enable guest access in Samba (which is inherently less secure than user-based authentication), we’ll configure Samba by setting it so that only the local area network can access it. Add these lines to the [global] section of your smb.conf file:

    interfaces = lo eth0
    bind interfaces only = true

    Edit this line in the [global] section to enable guest access in Samba (if the line isn’t there, add it):

    security = share

    Finally, change the [printers] share definition so that it looks like this:
    comment = All Printers
    browseable = no
    path = /var/spool/samba
    printable = yes
    guest ok = yes
    read only = yes
    create mask = 0700

    Save your changes to the smb.conf file, and restart Samba with the following command:

    sudo /etc/init.d/samba restart

    You can test your Samba definitions with the use of the testparm command. If your definitions come up OK, you should be ready to connect to the printer
    To use your shared printer, access your Ubuntu box from another machine. On a Windows PC, go to Start, Run, and type \\hostname (or the IP address, \\, and click OK. If you typed everything correctly, you should see a window with your printer icon. Double-click the printer icon to install it (make sure you have the correct driver for your model of printer on hand; check your manufacturer’s website) and you should be set to print.
    Note that Windows may claim that access is denied to the printer, but if you typed everything correctly, you should be able to print anyway.

  8. #38
    Join Date
    Oct 2006
    Stamford, UK
    Ubuntu 9.10 Karmic Koala

    Re: printer sharing worked in 9.04 but not 9.10

    Quote Originally Posted by jletze View Post
    Same here. I can see the discovered printers but can't print to them.
    Exactly the same problem here. My previous (9.04) set-up had a Canon USB printer connected to my desktop, which was shared by another machine on the network, also running 9.04. This worked fine. I recently upgraded the desktop to 9.10 and found that whilst the second machine could see the shared printer, it could no longer print to it. I don't have SAMBA installed and would like to see a fix for the CUPS problem fairly soon. Is anyone working on the problem? Looking at all the posts here, there seems to be no indication that this issue has been picked up by the developers.
    Never stop learning.

  9. #39
    Join Date
    Jan 2007
    Ubuntu 10.10 Maverick Meerkat

    Re: printer sharing worked in 9.04 but not 9.10

    I spent probably three hours today trying to get a PowerBook running Snow Leopard to print to a cups-shared printer connected via USB to my Ubuntu Desktop.

    I finally figured out that I needed to open my firewall on the Ubuntu Desktop to allow requests to port 631.

    Then, on the PowerBook I went into the Cups administration tab (http://localhost:631), found the network printer, then clicked "modify printer," and selected "Http".

    After that, in another Safari tab on the PowerBook I went to http://IP-ADDRESS-of-UBUNTU-DESKTOP:631 and clicked on "Manage Printers," and then I clicked on the printer name I wanted to print to, and copied the full http address for the printer from the address bar of firefox. (It looked like this: http://IP-ADDRESS-UBUNTU:631/printer...t-D2300-series)

    Then, all I had to do was paste that http address into the localhost:631 http location and click "modify printer."

    It was a totally dumb solution, but it worked and I'm just happy not to mess with it anymore.
    Last edited by eraker; February 8th, 2010 at 04:52 AM. Reason: not clear

  10. #40
    Join Date
    Dec 2007

    Unhappy Re: printer sharing worked in 9.04 but not 9.10

    OK, I've tried every solution suggested in this thread, and I have no joy. I have Karmic Koala on both machines, all updates installed. I have shared and published the printer ( HPLaserjet 1018 ) on my 'server' machine, but the client is not 'seeing it' I am amazed that there is not a global solution to this problem yet. This should be a piece of cake!

Page 4 of 6 FirstFirst ... 23456 LastLast

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts