Page 3 of 71 FirstFirst 123451353 ... LastLast
Results 21 to 30 of 702

Thread: How To: Install Xgl/compiz with Dapper, ATI, Gnome

  1. #21
    Join Date
    Jul 2005
    Location
    France
    Beans
    133

    Re: How To: Install Xgl/compiz with Dapper, ATI, Gnome

    Bou, locate Xgl please, confirm us it's really in /usr/bin... It could be in /usr/local/bin.

  2. #22
    Join Date
    Dec 2005
    Location
    Finland
    Beans
    339
    Distro
    Ubuntu Development Release

    Re: How To: Install Xgl/compiz with Dapper, ATI, Gnome

    And Bou, the screencap on your post seems to indicate that you have the :1 there twice i.e. /usr/bin/Xgl :1 :1. Get rid of the other :1. Good luck! Xgl really rocks.

  3. #23
    Join Date
    Feb 2006
    Beans
    2

    Re: How To: Install Xgl/compiz with Dapper, ATI, Gnome

    Hi all,
    since yesterday, i manage to get thouse famouses Xgl and compiz working on my setup but with no luck...

    here is the setup:
    Ati X700 with fglrx module rebuilt from latest ati driver :
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: MOBILITY RADEON X700 Generic
    OpenGL version string: 2.0.5642 (8.22.5)


    xgl-server , compiz and libs from repos.

    when i try to launch xgl , either with gdm stuff or with scripts, it fails loading...
    and each time xgl is loaded, fglrxinfo reports mesa drivers instead of Ati one...

    here is my xorg Modules and device section:

    Code:
    Section "Device"
        Identifier                          "ATIX700"
        Driver                              "fglrx"
        BusID "PCI:1:0:0"    # vendor=1002, device=5652
    EndSection
    
    Section "Module"
        #Load   "GLcore"
        Load    "bitmap"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "type1"
        Load    "vbe"
    EndSection

    And here is the gdm stuff used to launch :

    /etc/gdm/gdm.conf is modified with 1=Standard
    Code:
    [servers]
    # Override display 0 to use Xgl.
    1=Xgl
    
    [server-Xgl]
    name=Xgl server
    command=/usr/local/bin/Xgl :1 -fullscreen -ac -accel glx:pbuffer -accel xv:pbuffer
    flexible=true
    If anybody can give me a reason why Mesa is used when Xgl launched ...

    Thanks in advance
    Spotk

  4. #24
    Join Date
    Nov 2005
    Location
    Valencia, Spain
    Beans
    622
    Distro
    Hardy Heron (Ubuntu Development)

    Re: How To: Install Xgl/compiz with Dapper, ATI, Gnome

    Quote Originally Posted by risbac
    Bou, locate Xgl please, confirm us it's really in /usr/bin... It could be in /usr/local/bin.
    I'm so dumb. I was sure I had installed xserver-xgl, but I hadn't.

    The thing is, now that the packaged is installed -I double-checked the other ones- Gnome seems to start, but the screen is all screwed up and I can only see lots of colors and the mouse cursor.

    Is that supposed to happen? Do I have to add "gnome-window-decorator" and "compiz --replace gconf decoration wobbly fade minimize cube rotate zoom scale move resize place menu switcher" for this not to happen, or have they nothing to do?

    Thanks and sorry.

    EDIT: aamukahvi, you can see my gdm.conf-custom above, there's no repeated :1 (I looked for it too)

  5. #25
    Join Date
    Dec 2005
    Location
    Finland
    Beans
    339
    Distro
    Ubuntu Development Release

    Re: How To: Install Xgl/compiz with Dapper, ATI, Gnome

    Quote Originally Posted by Bou
    I'm so dumb. I was sure I had installed xserver-xgl, but I hadn't.

    The thing is, now that the packaged is installed -I double-checked the other ones- Gnome seems to start, but the screen is all screwed up and I can only see lots of colors and the mouse cursor.

    Is that supposed to happen? Do I have to add "gnome-window-decorator" and "compiz --replace gconf decoration wobbly fade minimize cube rotate zoom scale move resize place menu switcher" for this not to happen, or have they nothing to do?

    Thanks and sorry.

    EDIT: aamukahvi, you can see my gdm.conf-custom above, there's no repeated :1 (I looked for it too)
    Ok, I noticed that, too, but figured that maybe you copied that from a FAQ or something As for the garbled up screen, that shouldn't happen. Once Xgl is installed and configured, everything should be pretty normal. Then starting gnome-window-decorator and compiz just add the icing on the cake, so to say

  6. #26
    Join Date
    Jul 2005
    Location
    France
    Beans
    133

    Re: How To: Install Xgl/compiz with Dapper, ATI, Gnome

    Is that supposed to happen?
    I don't think so... You can run Xgl without running Compiz. I think it's better to go step by step, run Xgl first, then run Compiz. Apparently your Xgl is not running so fine... Do you have a specific configuration? Like dual monitor?

  7. #27
    Join Date
    Nov 2005
    Location
    Valencia, Spain
    Beans
    622
    Distro
    Hardy Heron (Ubuntu Development)

    Re: How To: Install Xgl/compiz with Dapper, ATI, Gnome

    Quote Originally Posted by risbac
    I don't think so... You can run Xgl without running Compiz. I think it's better to go step by step, run Xgl first, then run Compiz. Apparently your Xgl is not running so fine... Do you have a specific configuration? Like dual monitor?
    Nope. Fresh install, nothing special. No dual monitors, no nothing.

  8. #28
    Join Date
    Dec 2005
    Location
    Italy
    Beans
    216
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How To: Install Xgl/compiz with Dapper, ATI, Gnome

    I personally discourage running Xgl as primary xserver, since not stable at all. Morevore it's good to test it "the consolle way", see my howto http://battlehorse.homelinux.net/w/W...ge=HowToXglATI.

  9. #29
    Join Date
    Feb 2005
    Location
    Italy
    Beans
    34
    Distro
    Dapper Drake Testing/

    Re: How To: Install Xgl/compiz with Dapper, ATI, Gnome

    here we are!

    I got Xgl running after installing the latest ATI drivers.

    Xgl starts fine, the problem is compiz:

    compiz.real: GLX_EXT_texture_from_pixmap is missing
    compiz.real: Failed to manage screen: 0
    compiz.real: No managable screens found on display :1.0

    I own a 9200 Pro

    solutions?

  10. #30
    Join Date
    Oct 2005
    Location
    Viersen, Germany
    Beans
    100
    Distro
    Gutsy Gibbon Testing

    Re: How To: Install Xgl/compiz with Dapper, ATI, Gnome

    @Mr. Roboto

    You could try to recompile glitz from cvs.
    The newest update contains some fixes for this bug


    regards Dennis

Page 3 of 71 FirstFirst 123451353 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •