Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 37

Thread: UNR 9.10 - classic desktop mode

  1. #21
    Join Date
    Dec 2009
    Beans
    121
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: UNR 9.10 - classic desktop mode

    Quote Originally Posted by lett View Post
    As far as I know the only difference between regular Ubuntu version and Netbook Remix is that user interface change. No special drivers for netbooks hardware, no optimization - nothing. I have resigned from UNR and right now I install regular version.
    Is this not true? :

    "What have you done with Intel to optimize the new platform for Atom?

    -- Canonical has been working closely with Intel for more than a year on support for the Intel Atom processors. The optimizations mostly center around taking advantage of the power-saving extensions afforded by the Intel Atom processors, as well at some boot optimizations."

    from:
    http://blog.laptopmag.com/ubuntu-net...with-canonical

  2. #22
    Join Date
    Dec 2009
    Beans
    121
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: UNR 9.10 - classic desktop mode

    Quote Originally Posted by macachis View Post
    when I switch on the computer, sometimes the UNR desktop appears again. In that case, I can make two things: restart the computer (sometimes works, sometimes not) or repeat the steps to enable show_desktop. Has anyone an idea about how to solve it?
    I had exactly the same problem (bought Dell mini 10v on Monday and decided to give UNR a try, but didn't like its desktop).

    After some frustration, I determined that the beast is called netbook-launcher "A Clutter-based desktop launcher". Unchecking it's box in System -> Preferences -> Startup Applications solves the problem.

    P.S. I think the applet to add for the classic menu look is "menu bar", not "main menu"

  3. #23
    Join Date
    May 2008
    Beans
    6

    Re: UNR 9.10 - classic desktop mode

    Quote Originally Posted by phoenix55 View Post
    Here's what I did.

    Step 1: Uncheck Maximus

    - Go to: System > Preferences
    - Uncheck 'Maximus Windows Management'
    - Restart the system
    New applications will not open maximized to the netbook's full screen

    Step 2: Enable show_desktop

    - Open a terminal window (Accessories > Terminal)
    - Enter: gconf-editor. That opens the configuration editor GUI
    - Go to the node: / apps > nautilus > preferences (click preferences)
    - On the right window (showing the parameters associated with
    preferences) scroll down to 'show_desktop' and enable (click) it.
    This will get rid of the default desktop. No need to restart.

    Step 3: Add the 'Main Menu' Applet to the panel

    - Right-click on the panel (mine is at the top edge)
    - Select the 'Main Menu' applet
    This will put the same menu structure as the original desktop but in a
    drop-down menu as the good old classical desktop.

    I still need to fine tune things a bit further (eg make minimized apps go to a panel at the bottom of the screen rather than the top panel) but in the meantime I've got what I want the most.

    Enjoy the classical desktop look.
    I can do all that, but right click on the menu only allows me to remove menu items from the top panel, not add them. Do you know how to turn them on?

    GlennJ
    Last edited by GlennJ; January 28th, 2010 at 05:15 AM. Reason: Typo

  4. #24
    Join Date
    Aug 2009
    Location
    Montreal, Quebec, CANADA
    Beans
    275

    Arrow Re: UNR 9.10 - classic desktop mode

    Quote Originally Posted by lett View Post
    As far as I know the only difference between regular Ubuntu version and Netbook Remix is that user interface change. No special drivers for netbooks hardware, no optimization - nothing. I have resigned from UNR and right now I install regular version.
    "All of the initial Ubuntu Netbook remixes combine optimisations from the Moblin project for Intel® Atom™ processors and it is specially designed for netbooks." Quoted from:http://www.canonical.com/projects/ubuntu/unr ... so one can gather that NBR is not just 'cosmetics'!

    cheers,
    Last edited by eltonw; January 29th, 2010 at 02:54 AM. Reason: addendum
    "You only live once: let's make life better for each other."
    Lenovo G-50 / AMD 2.0 GHz. Mint 17.2
    Registered Linux User #193975

  5. #25
    Join Date
    Aug 2009
    Location
    Montreal, Quebec, CANADA
    Beans
    275

    Arrow Re: UNR 9.10 - classic desktop mode

    Quote Originally Posted by GlennJ View Post
    I can do all that, but right click on the menu only allows me to remove menu items from the top panel, not add them. Do you know how to turn them on?

    GlennJ
    Go to System ==> Main Menu, this should bring up the menu editor and you then select + New Item.

    HTH,
    "You only live once: let's make life better for each other."
    Lenovo G-50 / AMD 2.0 GHz. Mint 17.2
    Registered Linux User #193975

  6. #26
    Join Date
    Nov 2008
    Location
    Valatie, NY USA
    Beans
    29
    Distro
    Ubuntu

    Re: UNR 9.10 - classic desktop mode

    Really no reason to mess with changing the maximus settings.
    If you double click the top bar of the window you are working with it will un-maximize it and you can move it around any way you like.
    Or you can right click it and choose from the drop-down menu to unmaximize or minimize.

    At first I was not sure if I liked the netbook interface either but in playing around with it more I am finding it just as easy, if not more so, to use then the classic one. It is just "new" and takes a little getting used too.

    Overall I think it does make the small netbook screen easier to use.

  7. #27
    Join Date
    Oct 2007
    Beans
    160

    Re: UNR 9.10 - classic desktop mode

    I agree that you don't need to change the maximus settings. I was perfectly happy using Remix, but the menus became slow/unresponsive so I was using keyboard shortcuts anyway. But if my wife wanted to use it, she couldn't get things to work properly so I added a menu to the top panel and went to a normal desktop. I'm happy because my top panel now works just like it did with remix, but I have a Main Menu app in place of the Go Home app placed in the upper left corner.
    Screenshot.jpg

  8. #28
    Join Date
    Nov 2008
    Location
    Valatie, NY USA
    Beans
    29
    Distro
    Ubuntu

    Re: UNR 9.10 - classic desktop mode

    Quote Originally Posted by ohiomoto View Post
    ...so I added a menu to the top panel and went to a normal desktop. I'm happy because my top panel now works just like it did with remix, but I have a Main Menu app in place of the Go Home app placed in the upper left corner.
    Screenshot.jpg
    Looks great!,
    I have to admit since I started out using Ubuntu Linux as my first Linux ( I have tired a number of distros since and always come back). I do in some ways miss that original gnome "look" with the remix now on my netbook and I am thinking about switching to the full look again too. Although I agree with the others the kernel in the remix is custom built for netbooks and it is not only the user interface that makes remix different, so I would go with the modifications to remix suggested in this forum to get the regular desktop,
    Incidentally they just announced the new look for Ubuntu that I think will be released in the beta 10.04 and I am liking it and will probably go the regular desk top at that time.
    Here are a couple links to the new artwork;

    https://wiki.ubuntu.com/Brand

    http://fridge.ubuntu.com/node/1991

  9. #29
    Join Date
    Aug 2009
    Location
    Montreal, Quebec, CANADA
    Beans
    275

    Question Re: UNR 9.10 - classic desktop mode

    I must confess that I have not been following this thread as closely as I would have liked. Is there any indication that in the upcoming version, we (the users) will get back the option to enable the classic desktop either during installation or from the system menu?

    My preference is for the classic desktop on my 10" inch netbook since I do not have the problem with settings or options dialogs as with the netbook interface: viz: not being able to access the "OK" button at the bottom of some program dialogs. (Hitting TAB, TAB... does not always work, so to enable some preferences in various apps. sometimes winds up as a gamble...

    If this question had already been posed, and / or answered, kindly pardon my ignorance.

    Given that the next iteration of ubuntu NBR is shortly to arrive, I guess I will live with the netbook interface till then.
    "You only live once: let's make life better for each other."
    Lenovo G-50 / AMD 2.0 GHz. Mint 17.2
    Registered Linux User #193975

  10. #30
    Join Date
    Nov 2008
    Location
    Valatie, NY USA
    Beans
    29
    Distro
    Ubuntu

    Re: UNR 9.10 - classic desktop mode

    Well after discovering another "glitch" in the UNR desktop;
    That if you install more then 30 games the icons in the middle of the game menu get huge and push off the bottom icons so you no longer have access to them. (this is a known problem with no known fix that I have found on another forum after it happened to me and I searched).

    I have gone back through this thread and gleaning tips from everyone and went to the "classic desktop".

    My steps;

    1. Open "startup applications" in preferences.
    Un-checked "Maximus windows management" and "Netbook launcher". Log out and back in.

    2. Removed "go home" applet from upper left corner by right clicking it and selecting "remove from panel".
    (as noted by others if you click on the "go Home" applet the UNR desktop comes back on.)

    3. Remove the "window picker" applet from the top panel the same way.
    (You cant "see it" without an open window but it is in the middle of the top panel just right click anywhere and the menu is there to remove it)

    4. Right click the middle of the top panel and add the "Menu Bar" applet and move it to the left top corner and lock it to the panel.
    (Don't confuse this with the "Main Menu" applet. The "Menu Bar" is the familiar Ubuntu drop down menu that includes the; "Applications", "Places" and "System" drop down menus. "Main Menu" is the generic Gnome menu that wont give you access to Places and System.)

    5. Right click the middle of the top panel again and click "new panel" it should put it at the bottom of the desktop.

    6. Right click the middle of the new bottom panel and add the "show desktop" applet and move it to the bottom left corner and lock it to the panel.

    7. Right click the bottom panel again and add the "window list" applet and move it to the left lower corner next to the "show desktop" icon and lock it to the panel.
    (The "windows list" applet is the familiar way that open windows are shown on the panel. This is not the same as the "window picker" removed from the top panel. The "Window picker" Applet is the one some people think is part of the way maximus displays windows and they don't like it)

    8. Right click the middle of bottom panel again and add the "trash applet" and move it to the bottom right corner and lock it to the panel.

    9. Right click the middle of the bottom panel one last time and add the "screen switcher" applet, and once it is activated right click it go to preferences and change it to show 2 columns, then move it to the bottom right next to the "trash applet" and lock it to the panel.

    I don't think I missed anything this should be the "classic desktop" arrangement.

    Edit;
    I just figured out a trick to get the UNR desktop to display and then turn off again if you want to switch it on or off.
    After setting up the classic desktop add the "Go Home" and the "force quit" applets to one of your panels where ever you like. If you click the "Go Home" applet the UNR desktop starts. Then if you click the "Force quit" applet and click on an empty place on the UNR desktop and then confirm you want to "force quit" this application the UNR desktop goes off and you are back to the Classic desktop.
    Between the two applets you have a switch to turn on or off the UNR desktop.
    Last edited by tom4jean; March 8th, 2010 at 02:51 AM.

Page 3 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •