Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 42

Thread: FireFox Slow in 9.10 Koala

  1. #21
    Join Date
    Aug 2007
    Location
    Olympia, Washington - US
    Beans
    33
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: FireFox Slow in 9.10 Koala

    This is only happening in a subset of machines whose internet connections at some point go through legacy equipment that is not IPv6 aware at all. I get donations of computers, refurb them with Ubuntu and then give them away as part of my Non-Profit's charter. I've installed 9.10 on 10 machines/laptops so far and network issues are nowhere among the few hickups I have seen so far. At least here in Olympia, Washington with comcast as my ISP.
    Mankind is my religion, of course I use GNU/Linux!

  2. #22
    Join Date
    Mar 2008
    Location
    Venice IT
    Beans
    26

    Re: FireFox Slow in 9.10 Koala

    Took me a little to figure out, anyway the open dns solution did not work for me for some reasons, but then I noticed there is a ipv6 tag on the network manager configuration for auto eth0 (in my case) òust next to the ipv4 one, and there there is the cascade menu with the chice to ignore ipv6, this just fixed the issue right away.

  3. #23
    Join Date
    Nov 2009
    Location
    Croatia/Hrvatska
    Beans
    492
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: FireFox Slow in 9.10 Koala

    THANKS for the opendns solution!!!

    all of my browsers took too long to load a web page, but downloaded at full speed, and when i changed my connection settings to opendns i was reborn
    i tried firefox, chrome and opera and all the same... i also installed new flash player and JRE, but no result...

  4. #24
    Join Date
    Oct 2007
    Location
    Scottsbluff, Nebraska
    Beans
    27
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: FireFox Slow in 9.10 Koala

    This didn't seem to do much for me (new DNS). I really notice this issue at the Verizon wireless site. It's ridiculously slow! I know it isn't my connection because when I go to a windows PC downstairs, it comes up immediately. I don't get it. I also have IPv6 disabled.
    I'm running 9.10.

    Any more suggestions?

  5. #25
    Join Date
    May 2008
    Beans
    10
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: FireFox Slow in 9.10 Koala

    I was having the same problem so this is what I did just now and it really improved my speed. (Keep note of what you do in case you need to go back)

    1. Type about:config in the address bar and press Enter
    2. Then right click on the preferences table and select New->Integer
    3. Type preference name as: Network.dnsCacheExpiration and Integer value 3600 (This will increase the DNS expiration cache time to 1 hour---you may decide the time you want)
    4. Right click on the preferences table and select New.>Integer
    5. Type preference name as: network.dnsCacheEntries and set its value between 100 to 1000 (By Default firefox has 20 entries I set mine at 400)
    6. Type in the search and find each of the following and set their values as indicated below (Toggle will change the value like from false to true)

    network.prefetch-next = true
    network.http.pipelining = true
    network.http.pipelining.maxrequests = 8
    network.http.proxy.pipelining = true
    network.dns.disableIPv6 = true


    7. Also right click and add another: preference name as: nglayout.initialpaint.delay and set its value to 0.

    8. Plus I added the OpenDNS just as this thread mentions.


    Close the browser and restart. You are done.
    I hope this helps
    Last edited by uboss; November 22nd, 2009 at 12:55 PM.

  6. #26
    Join Date
    Nov 2008
    Location
    Slough, UK
    Beans
    78
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: FireFox Slow in 9.10 Koala

    The slowness I'm seeing is Firefox itself. When the mouse goes over something, a link, or the srcoll bar, it takes about 10 seconds for the link or scroll bar to be highlighted and become available to use.

    Browser windows take ages to close too.

    Also I get pauses in the response to the keyboard of the same order.

    Anyone else see these?

    Craig
    Last edited by craig100; November 22nd, 2009 at 01:12 PM. Reason: Missed a bit

  7. #27
    Join Date
    May 2008
    Beans
    10
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: FireFox Slow in 9.10 Karmic Koala

    What extensions are you using? disable all of them and and than re enable them one by one and see. Plus add these settings and see it might help. I was facing the similar problem but not that much. With me it was taking ages to just load a page or scroll through a page or clicking other tab would take a lot of time to change to that tab. It's been about 1 hour now I made these changes and it did improve. I think the most important is to disable the IPV6 Thing
    network.dns.disableIPv6 = true

  8. #28
    Join Date
    Dec 2008
    Location
    /dev/null
    Beans
    115
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: FireFox Slow in 9.10 Koala

    Thanks a million. Works like a charm! Opendns from now on!
    You are a very redundant person, that's what kind of person you are.

  9. #29
    Join Date
    Nov 2008
    Beans
    36

    Unhappy Re: FireFox Slow in 9.10 Koala

    After upgrading to Ubuntu 9.10 (64 bit) I also have experienced slow browsing with Firefox. I changed the ipv6 settings as advised but to no avail.

    Then I tested Opera. That browser works fast. The difference is huge, and can be seen also when monitoring the performance of the network with the help of the Ubuntu performance monitor.

    When using Opera in parallel with Firefox, the problem reappears. When closing Firefox, the problem disappears.

    To my mind it seems that there is something wrong with Firefox or extensions (I use Xmarks.)

    I like Firefox very much because of the extensions, so I hope the problem will be solved soon.

    - Gef

  10. #30
    Join Date
    Nov 2009
    Location
    Croatia/Hrvatska
    Beans
    492
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: FireFox Slow in 9.10 Koala

    you dont have to add opendns servers...

    you can find your dns server with "dig" command and edit your connection, this also works for me... using karmic with firefox 3.5.5...
    if i dont type my dns servers then ubuntu chooses addresses of my wireless router(192.168.2.1) and my modem(192.168.1.1) (browsing the web takes ages)...

Page 3 of 5 FirstFirst 12345 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •