Results 1 to 6 of 6

Thread: 9.10 random freeze on installation.

  1. #1
    Join Date
    Oct 2009
    Beans
    4

    9.10 random freeze on installation.

    Hello all

    Here is the story

    I am trying to upgrade from winxp pro to ubuntu 9.10 on my laptop. my primary methods of installation have been through booting through a flash drive, and wubi (the cd drive has a bad laser). both have roughly the same result. at some point between the part where i tell it to Install Ubuntu, and generally the end of the ubiquity installer, the system does a full freeze, not even the mouse pointer moving. its not gradual, the freeze comes all at once, and at seemingly random points during the installation. I have tried both the i386 version, as well as the amd64 version, both with the same results. On one occasion, after several freezes, i was able to get wubi to reach 100%, at this point, it said it would restart the system, ubiquity finished up its cleanup, and a list of operations were conducted with the last one stating, "system will restart NOW" or something like that. but it did not restart. after i rebooted it, and chose ubuntu from the boot selection screen, GRUB loaded, and told me that no kernal was loaded. exactly this persons situation:

    http://ubuntuforums.org/showthread.p...ght=stuck+grub

    I have not yet tried the ubuntu recovery method that he used with the alternate install disk.


    some noteworthy information

    my computer is a gateway ML3109 from 2007
    Celeron M 520 (this is a 64 bit cpu)
    2gb ram
    ABIT RADEON 9600XT-VIO

    this long and somewhat dated post documents some issues with the ATI drivers. i believe most of the other issues mentioned here have been resolved in recent distributions, and otherwise, do not apply to my problem.
    http://ubuntuforums.org/showthread.php?t=511876


    The computer uses a notorious Phoenix Technologies BIOS
    there are two versions of it: 8305 for vista and 8310 for XP. i am running 8310
    more information on this BIOS can be found here

    http://www.linuxquestions.org/questi....-bios-544779/

    here is a copy of my computer profile from device manager in XP

    Resource Summary Report - Page: 1 ******************** SYSTEM SUMMARY ******************** Windows Version: Windows 5.1 Service Pack 2 (Build 2600) Name: UNIMATRIX007 Machine Type: AT/AT COMPATIBLE System BIOS Version: GATEWA - 6040000 System BIOS Date: 07/03/07 Processor Type: x86 Family 6 Model 22 Stepping 1 Processor Vendor: GenuineIntel Number of Processors: 1 Physical Memory: 1983 MB ******************** DISK DRIVE INFO ******************** Drive C: Type: Fixed disk drive Total Space: 80,015,491,072 bytes Free Space: 18,165,047,296 bytes Heads: 255 Cylinders: 9729 Sectors Per Track: 63 Bytes Per Sector: 512 ******************** IRQ SUMMARY ******************** IRQ Usage Summary: (ISA) 0 System timer (ISA) 1 Standard 101/102-Key or Microsoft Natural PS/2 Keyboard (ISA) 8 System CMOS/real time clock (ISA) 12 PS/2 Compatible Mouse (ISA) 13 Numeric data processor (ISA) 14 Primary IDE Channel (PCI) 16 Microsoft UAA Bus Driver for High Definition Audio (PCI) 17 ABIT RADEON 9600XT-VIO (PCI) 19 Standard OpenHCD USB Host Controller (PCI) 19 Standard OpenHCD USB Host Controller (PCI) 19 Standard Enhanced PCI to USB Host Controller (ISA) 21 Microsoft ACPI-Compliant System (PCI) 22 Realtek RTL8185 54M Wireless LAN Network Adapter ******************** DMA USAGE SUMMARY ******************** DMA Usage Summary: 4 Direct memory access controller ******************** MEMORY SUMMARY ******************** Memory Usage Summary: [00000000 - 00000FFF] System board [000A0000 - 000BFFFF] PCI bus [000A0000 - 000BFFFF] PCI standard PCI-to-PCI bridge [000A0000 - 000BFFFF] ABIT RADEON 9600XT-VIO [000D0000 - 000D3FFF] PCI bus [000D4000 - 000D7FFF] PCI bus




    Things i have not tried:
    Installing from the Alternate Installer version of 9.10, or using the recovery method from the Alternate Installer mentioned in one of the previous posts, on the wubi installation that did make it to 100%

    Installing a previous version of ubuntu (or any linux distro for that matter).

    Changing the BIOS to the supposed "vista BIOS", because i have read more than once that people have pretty much bricked my particular model of laptop by doing that.

    I have copies of 9.10 i386 and amd64 on hand, and if needed, i can download the alternate installer.

    Windows XP is still running fine on this computer, and has never experienced a freeze.

    The computer only has 1 partition.



    any indication of things to try, or where to go from here would be greatly appreciated.

    I am certainly willing to settle for 9.04 if it comes down to a distro specific problem that can not be resolved, but if i can get 9.10 to work, that would be great.


    I owe at least one beer to any and all people who can help send me on my way. thanks a bunch. awaiting further instructions...

  2. #2
    Join Date
    Apr 2008
    Beans
    14

    Re: 9.10 random freeze on installation.

    Unfortunately, I don't have high hopes for the ML3109. I have the same laptop, and I can't even get Kubuntu 9.10 booted without a lot of tinkering around, and once I got it installed, it won't even get to the login screen. I think it has something to do with the video card no longer being supported. I also tried Suse 11.2, and that doesn't even boot up to either the install or the live session, so I don't think its just Ubuntu that is the problem, its any new distro.

    So while you can at least get to the install screen, I think once it is installed, you will have a tough time getting it up and running. But hey, I'm in the same boat, and if anyone has any ideas as well, it would be a great help, I'm just not getting my hopes up.

  3. #3
    Join Date
    Oct 2009
    Beans
    4

    Re: 9.10 random freeze on installation.

    well i havent gotten much further than the conclusion you have already drawn, but if you dont mind 6 month old tech, try 9.04

    i loaded jaunty up on this thing from a flash drive and it loaded up without a hitch. the wireless driver seems to be slightly inferior to the one it uses running windows xp, but it gets the job done, and it rarely drops connection. it just seems to lag a little more on opening up web pages.

    at the moment im still running dual boot xp/jaunty, but im about to format this sucker and go straight jaunty. i waited a bit just to check for stability and such, and to make sure that wireless driver would cut it, but at this point im convinced its good. oh btw im running the i386 version, but from what ive read you really should be running the amd64 version, cuz believe it or not, this old thing actually does have a 64 bit proc in it. good luck and keep me updated on any new findings

  4. #4
    Join Date
    Apr 2008
    Beans
    14

    Re: 9.10 random freeze on installation.

    Yea, its kinda a bummer that the new linux distros don't really support this laptop which is "only" 2-3 years old. Wish they would not regress like this, but what are you going to do. I really don't want to go back to 9.04, because I had a lot of problems with some changes they made and always like being on the cutting edge. I'll let you know if I can get any linux up and running, whether ubuntu or otherwise. Might wait for Fedora 12 and give that a shot.

  5. #5
    Join Date
    Oct 2009
    Beans
    4

    Re: 9.10 random freeze on installation.

    thanks a lot. i really appreciate it. please do let me know if you are able to get any particular distro running really well on this laptop. im out here in west africa and downloading large files is super expensive, but ill be back home in the states for christmas, so that way i will mark it on my list of things to download while home. for now ill stick to dual boot. good luck

  6. #6
    Join Date
    Mar 2007
    Beans
    37

    Re: 9.10 random freeze on installation.

    I also have an ML3109 and have had very similar experiences. Look at my reply in http://ubuntuforums.org/showthread.p...62#post9150762. I don't think it's as much that Linux or Ubuntu don't support the hardware as that the hardware or BIOS is broken and newer versions of Linux bring that out more. Although I've been using Jaunty for a while on this machine, it frequently fails to boot properly. I'm hoping that the right combination of hardware workaround parameters on the Linux command line will make the system more reliable and stable.

    When I first got the laptop, it had Vista on it, which was unusable. I tried to install both Ubuntu and XP on it, as I needed Windows for some work tasks. I never got an XP CD to boot on it at all, though a Windows server 2003 disc would. So, Ubuntu is not the only OS to have trouble on this machine. Also, since the Linux command line parameters I've found make it more stable are not specific to Ubuntu, I suspect other current distributions will have similar problems and may be improved by the same parameters.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •