Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: No wireless in 9.10 with Broadcom BCM4312

  1. #11
    Join Date
    Jun 2009

    Re: No wireless in 9.10 with Broadcom BCM4312

    Combination of above Worked for me ... However, I had a wired connection to download.

    1) Connect wired connection using NIC ethernet

    2) do update and upgrade:
    sudo apt-get install update
    3) System>>Administrator >>Hardware Drivers
    select Broadcom STA and BoadCom fwcutter and activate and restart


  2. #12
    Join Date
    Nov 2006

    Re: No wireless in 9.10 with Broadcom BCM4312

    Try works with the BCM4306(rev2) card.

    It's worth the try, however, I haven't tried it with any other Broadcom cards.

  3. #13
    Join Date
    Nov 2009

    Re: No wireless in 9.10 with Broadcom BCM4312

    It is still not working for me. I cant even see the driver under hardware drivers.
    It worked perfectly on 9.04 but not in 9.10 ive tried a fresh reinstall twice and ending up with same problem.

  4. #14
    Join Date
    May 2008

    Re: No wireless in 9.10 with Broadcom BCM4312

    don't go for me also (hp 700 el)

  5. #15
    Join Date
    Oct 2009
    HU, UK, TW
    Ubuntu 10.04 Lucid Lynx

    Re: No wireless in 9.10 with Broadcom BCM4312

    (If it`s still not working) After a clean install, I followed this(the first post):
    4 me it`s fine now.
    "If your picture isn't good enough, you're not close enough." Robert Capa

  6. #16
    Join Date
    Oct 2009

    Re: No wireless in 9.10 with Broadcom BCM4312

    I got HP nx6325 with Broadcom BCM4312. I installed a Ubuntu 9.10 on one partition. After booting up, OS didnt give me option to chouse restricted wifi drivers, like in 9.04. I tried:

    sudo apt-get install --reinstall bcmwl-kernel-source

    but after that, Wireless Networks form that small wifi logo next to clock disappeared. After I made again new install with format that 9.10 partition. I looked under Synaptic, what bcmwl packages are installed and I found this: bcmwl-modaliases. Then I removed it:

    sudo apt-get remove bcmwl-modaliases

    And installed bcmwl-kernel-source again:

    sudo apt-get install --reinstall bcmwl-kernel-source

    And after restart wifi works.

  7. #17

    Angry Re: No wireless in 9.10 with Broadcom BCM4312

    I don't know if I'm reading this thread wrong, but I don't understand how this is solved when nothing I try works.

    I've tried all of the suggestions, and the only thing that seems to even allow my wifi to detect networks is if I make sure the broadcomm STA driver is uninstalled and that the fwcutter driver is installed (which disappears entirely from time to time if I have had the SAT installed before it or if the bcmwl-kernel-source is installed).

    Also, I'm having problems with the bcmwl-kernel-source itself... I had only the fwcutter driver installed through the hardware drives program and the bcmwl-kernel-source uninstalled, but the bcmwl-modaliases installed. This configuration made it possible for me to access the drop down wireless menu and choose my wireless network, though it wasn't asking for a password at all and just dropping it after trying to connect for a minute or so. I went into Network Connections and put the password in there under the security tab, and it would try to connect again, but would fail after a minute and not try to reconnect.

    My system is fully up to date with Ubuntu updates, and I can't think of anything else that's wrong. I've tried Wicd, it didn't work either. Even though this is the newest version of Ubuntu, it's the toughest to get the stupid wireless working. It used to be super simple, as long as I could find a wired internet connection.

    There used to be awesome step by step instructions on how to get wireless working, but those are for older versions and I think it stopped working for me on the last version (9.04). Again, I'm probably just not reading this thread correctly, but if someone could point me in the right direction with a clear roadmap of what I need to do, I'd be most grateful. The only foolproof "solution" I can find is the "sudo apt-get upgrade
    sudo aptitude reinstall bcmwl-kernel-source" solution, which does not work at all in my case.
    "lspc -v" outputs:
    0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)
    Subsystem: Dell Device 000c
    Flags: bus master, fast devsel, latency 0, IRQ 10
    Memory at f6cfc000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel modules: ssb, wl

    My output is a little bit different from the OP, so I don't know if it's what's causing the problem or not.

    Thanks in advance if you're able to help!

  8. #18
    Join Date
    Oct 2008
    Kubuntu 8.04 Hardy Heron

    Talking Re: No wireless in 9.10 with Broadcom BCM4312

    I managed to fix my wifi problem. I am not sure what exactly what helped. However I want to share what I did in hopes it may help someone.

    I did this:

    I finished all the steps from this site:
    I downloaded archive and read README file on site.

    I allso did this:
    sudo apt-get upgrade
    sudo aptitude reinstall bcmwl-kernel-source

    After each step i restarted system but it did not help, my device did not show in ifconfig.

    In the end I opened Hardware Drivers and enabled STA wireless driver. System froze but after restart i had my WiFi working

    For the record I am using Lenovo G550 with Kubuntu 9.10 Karmic.

  9. #19
    Join Date
    Aug 2006

    Smile Solved: No wireless in 9.10 with Broadcom BCM4312

    Quote Originally Posted by gypsybee View Post

    I was having exactly the same issues. I tried handling it on my own at first using the drivers the 64bit 9.10 located, obviously that failed. Gubbi's ideas did not work for me either. I am running a Dell XPS M1530 with the BCM4312 wireless card. The link above did work for me however. The important thing about using the broadcom link is to ensure you read the wonderful notepad that you can download too. Especially if like me you are still pretty new at Ubuntu/linux.
    Stay Safe!
    Confirmed. This worked for me also, but only AFTER reading and following the README.txt file that is available on the same page from which the driver is downloaded. There are a few things in there I didn't catch the first time I tried this. The second time worked flawlessly.

  10. #20
    Join Date
    Apr 2009
    Brugge (Be)
    Ubuntu 10.10 Maverick Meerkat

    Re: No wireless in 9.10 with Broadcom BCM4312


    As I own a HP nx6325 I thank you very much for having posted your solution here.

    Alain J. Baudrez ( My blog )
    Laptop 1 : Ubuntu 10.10/32 bit
    Laptop 2 : Ubuntu 10.04/64 bit
    Nebook : Ubuntu Natty Beta 1 32-bit

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts