Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Karmic dual monitors now assigns second monitor as primary

  1. #11
    Join Date
    Nov 2005
    Location
    Manitoba, Canada
    Beans
    457
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Karmic dual monitors now assigns second monitor as primary

    Quote Originally Posted by GT-Force View Post
    How can one make this permanent. After I execute this, it works, but after logging out and back in, it's back to how it was.

    Until Ubuntu coders pull their heads out of their, ummm, ASCII terminals and see that at least 98% of computer users use GUI and put this into the monitor setup, we'll have to do it the hard way.
    just notice this post

    make the script run on boot using startup applications

  2. #12
    Join Date
    Jul 2010
    Beans
    19
    Distro
    Ubuntu

    Re: Karmic dual monitors now assigns second monitor as primary

    Quote Originally Posted by adduds View Post
    just notice this post

    make the script run on boot using startup applications
    Thanks! Exactly what I was looking for.


    System->Prefs->Startup Applications

    Then Click Add

    Name: Whatever
    Command: xrandr --output NAMEOFTHEMONITOR --primary
    Comment: Whatever

    Click Add

    DONE!

    I guess I could set the same thing to run the python script I wrote to control the VGA fan speed.

  3. #13
    Join Date
    Sep 2007
    Beans
    14
    Distro
    Ubuntu

    Re: Karmic dual monitors now assigns second monitor as primary

    set up your monitors using the monitors app and save. then edit the file it creates at ~/.settings/monitors.xml and change

    Code:
    <primary>no</primary>
    for the monitor branch that you wish to be primary.

    The system-wide file that this overrides is at /etc/gnome-settings-daemon/xrandr/monitors.xml. That file is created when you save as default in the monitors app.

  4. #14
    Join Date
    Apr 2011
    Beans
    56
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Karmic dual monitors now assigns second monitor as primary

    Quote Originally Posted by diddledan View Post
    set up your monitors using the monitors app and save. then edit the file it creates at ~/.settings/monitors.xml and change

    Code:
    <primary>no</primary>
    for the monitor branch that you wish to be primary.

    The system-wide file that this overrides is at /etc/gnome-settings-daemon/xrandr/monitors.xml. That file is created when you save as default in the monitors app.
    File ~/.settings/monitors.xml does not exist.
    ________________________
    Quote Originally Posted by frozenfyer View Post
    I had a similar problem with my dual monitor setup that I solved. One screen was connected to DVI and the other to VGA. Use the following to figure out what each screen is called:

    Code:
    xrandr --prop
    You should see something like VGA-1 or DVI-D-1. Do the following to set the primary screen:

    Code:
    xrandr --output DVI-D-1 --primary
    Replacing DVI-D-1 with whichever screen you want as the primary.
    Quote Originally Posted by petsoukos View Post
    Thanks! Exactly what I was looking for.


    System->Prefs->Startup Applications

    Then Click Add

    Name: Whatever
    Command: xrandr --output NAMEOFTHEMONITOR --primary
    Comment: Whatever

    Click Add

    DONE!

    I guess I could set the same thing to run the python script I wrote to control the VGA fan speed.
    I've got ATI card. Had problems setting primary monitor.
    This works perfectly but you may have to swap the position of your monitors in the monitors app for unity menu to work properly.

    My VGA monitors name was CRT1 just use xrandr --prop to find what your displays are called.

    I'm surprised this problem still exists in 11.04
    Last edited by SushiAddiction; September 1st, 2011 at 01:27 AM.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •