Results 1 to 10 of 13

Thread: HOWTO: FIX touchpad issues on karmic upgrade

Hybrid View

  1. #1
    Join Date
    Dec 2005
    Location
    Austin
    Beans
    108

    HOWTO: FIX touchpad issues on karmic upgrade

    I am just starting this thread to let y'all know of the fix I used.

    Problem: touchpad working fine in jaunty, not working at all after karmic upgrade. My laptop is a sony vaio, but the problem could be in all laptops.

    Symptoms:
    1. Check what kernel you are booting into
    Code:
    $uname -a: 
    Linux xxxx 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:05:01 UTC 2009 x86_64 GNU/Linux
    If this is not your output, then you are using an older version (most probably from jaunty). You'll need to change the kernel you are booting into. This can be done by editing the default value in /boot/grub/menu.lst file.
    2. Search your 'dmesg' output for this:
    Code:
    $dmesg | grep mouse
    [ 13.603905] psmouse: Unknown parameter `synaptics_resume_reset'
    3. Check if the 'psmouse' module is loaded at all:
    Code:
    $lsmod | grep psmouse
    If there is no output of the above command, that means the touchpad module (psmouse) is not loaded.
    4. Look if there is a file called /etc/modprobe.d/psmouse.conf
    If this line exists in the file, you have the same problem as me.
    Code:
    options psmouse synaptics_resume_reset=N
    Solution:
    1. Comment out the line in (step 3) /etc/modprobe.d/psmouse.conf, i.e. add "#" at the start of the line.
    2. Reboot.

    The 'psmouse' module should be loaded successfully, and you should see a 'touchpad' tab in System->Preferences->Mouse

    Please let me know if this fixes your problems. I'll try to help as much as I can.
    Last edited by balak; November 2nd, 2009 at 01:47 AM. Reason: Added information about booting into wrong kernels
    Laptop 1: Averatec 2150 running Karmic Laptop 2: HP dv4z running Lucid
    Laptop 3: Sony Vaio SR220J running Lucid (amd64) Desktop: AMD Athlon X2 4000+ ABIT AN-M2 nVidia GeForce 7025-630a running Lucid (amd64)

  2. #2
    Join Date
    Jun 2009
    Beans
    16

    Re: HOWTO: FIX touchpad issues on karmic upgrade

    Thanks Balak.

    I got output for :
    dmes | grep psmouse and
    lsmod | grep psmouse

    However, there is no psmouse.conf file in /etc/modprobe.d/ to modify.

  3. #3
    Join Date
    Nov 2009
    Beans
    7

    Re: HOWTO: FIX touchpad issues on karmic upgrade

    Quote Originally Posted by samasat View Post
    Thanks Balak.

    I got output for :
    dmes | grep psmouse and
    lsmod | grep psmouse

    However, there is no psmouse.conf file in /etc/modprobe.d/ to modify.
    Second.

    Code:
    milosz@milosz-laptop:~$ dmesg | grep psmouse
    milosz@milosz-laptop:~$ dmesg | grep mouse
    [    2.111311] input: Macintosh mouse button emulation as /devices/virtual/input/input3
    [    4.456053] mice: PS/2 mouse device common for all mice
    milosz@milosz-laptop:~$ dmesg | grep synaptics
    [   16.497483] synaptics was reset on resume, see synaptics_resume_reset if you have trouble on resume
    milosz@milosz-laptop:~$ lsmod | grep psmouse
    psmouse                64028  0
    Not sure what to do here. This guy solved the problem by reverting to the previous kernel. I don't want to do that, but that solution identifies modules as a culprit. I'm using a USB mouse for now (works fine).

  4. #4
    Join Date
    Nov 2009
    Beans
    7

    Re: HOWTO: FIX touchpad issues on karmic upgrade

    Edit: the other thread has a proper solution. I misread the kernel version numbers. He was not reverting, but rather updating the configuration file.

  5. #5
    Join Date
    Dec 2005
    Location
    Austin
    Beans
    108

    Re: HOWTO: FIX touchpad issues on karmic upgrade

    Yeah, it looks like the 'default' kernel version was the older kernel in /boot/grub/menu.lst. Changing it to new kernels has helped some people; thanks for letting me know about this. I have updated the first post with this information.

    Quote Originally Posted by MiloszK View Post
    Edit: the other thread has a proper solution. I misread the kernel version numbers. He was not reverting, but rather updating the configuration file.
    Laptop 1: Averatec 2150 running Karmic Laptop 2: HP dv4z running Lucid
    Laptop 3: Sony Vaio SR220J running Lucid (amd64) Desktop: AMD Athlon X2 4000+ ABIT AN-M2 nVidia GeForce 7025-630a running Lucid (amd64)

  6. #6
    Join Date
    Jun 2009
    Beans
    16

    Re: HOWTO: FIX touchpad issues on karmic upgrade

    Thanks Balak !!

    After following the instruction 1 in your edited post I got it straight ...

    just for information...some detailed info about it for other NewB's like me looking for help :
    1) cd /boot/grub/menu.lst (change directory)

    2) sudo cp menu.lst ~/menu_bkup.lst (create bkup)

    3) sudo vim menu.lst (it will open file for edit ... i) goto to the last portion of it using arrow key or mouse ...you will find all OS listed there if you have dual boot set .... ii) each block of about 4 lines for each boot option. Copy -paste the previous kernel lines block and change all kernel number (e.g. 2.6.28.11) to 2.6.31-14. iii) save file by Esc >> press ":wq" >> ENTER

    4) reboot by typing Cmd sudo reboot

    5) Select newly added boot option.

    NOTE : This worked for me. I have UPGRADED from Ubuntu 9.04 to 9.10 and all upgrade (download , install) process was successful in one go.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •