Page 1 of 9 123 ... LastLast
Results 1 to 10 of 83

Thread: Mouse clicks not working properly after upgrade to 9.10 / Karmic

  1. #1
    Join Date
    May 2008
    Location
    USA
    Beans
    16

    Mouse clicks not working properly after upgrade to 9.10 / Karmic

    It only started happening right after I upgraded to 9.10 (I upgraded from the previous release to the latest using Update Manager.)

    Basically, whenever I click something, say, a link on a web page, a program running in the gnome-panel, the "Applications", etc menus.. doesn't matter where or what I click.. it seems the mouse click usually doesn't register. Sometimes it works the first click, sometimes it takes 3 clicks. This problem only started after I upgraded, and the mouse works fine with other operating systems, and other computers completely.

    Any help would be great

  2. #2
    Join Date
    Feb 2009
    Beans
    2

    Re: Mouse clicks not working properly after upgrade to 9.10 / Karmic

    Im getting the exact same problem!

  3. #3
    Join Date
    Nov 2009
    Beans
    7

    Re: Mouse clicks not working properly after upgrade to 9.10 / Karmic

    My mouse does not even work at all. It stays frozen in one place on my screen. Any help on that?

  4. #4
    Join Date
    Jun 2006
    Beans
    1

    Re: Mouse clicks not working properly after upgrade to 9.10 / Karmic

    I'm seeing the exact same thing. It seems to register the "down" part of the click, but then the button doesn't get clicked.

    Sometimes hitting enter or Alt+<letter> works, but sometimes that doesn't work either.

  5. #5
    Join Date
    Nov 2009
    Beans
    206
    Distro
    Ubuntu Development Release

    Re: Mouse clicks not working properly after upgrade to 9.10 / Karmic

    Since upgrading to 9.10 Karmic final release I lost the side button providing the "back page" in Firefox and Nautilus. Problem had not been noticed on 9.10 alpha and RC.

  6. #6
    Join Date
    Nov 2009
    Beans
    2

    Re: Mouse clicks not working properly after upgrade to 9.10 / Karmic

    I'm also seeing failed mouse clicks. This seems to occur on many aspects of the system. Eclipse, firefox, flash, thunderbird, titlebars, system menus, etc. Also, I'm occasionally gettign a drag event for a single click for which I haven't moved the mouse. I've read lots of stuff about gtk and flash / eclipse. But I'm seeing this behavior all over the place. Any help?

  7. #7
    Join Date
    Apr 2006
    Beans
    4

    Re: Mouse clicks not working properly after upgrade to 9.10 / Karmic

    The same for me. I was thinking my batteries were dying. Everything works fine if I use the spacebar to "click", but the mouse button not working is getting annoying.

  8. #8
    Join Date
    Nov 2009
    Location
    Los Angeles
    Beans
    1

    Re: Mouse clicks not working properly after upgrade to 9.10 / Karmic

    I have the same problem. Mouse clicks on buttons in certain applications ( I believe only those using qt) do not work. For me Eclipse and Spyder. Any ideas how to find the cause of this problem.

  9. #9
    Join Date
    Oct 2008
    Beans
    6

    Re: Mouse clicks not working properly after upgrade to 9.10 / Karmic

    I was having the same problems, at first I tried playing with acpi settings msi and all those other menu.lst options with no luck. I could move the mouse cursor and click but the clicks would randomly stop working and sometimes I could click on one window but not another, etc. My machine would also freeze up after too much time with many windows open. Finally I looked up my mouse (Logitech MX1000) and Ubuntu. I found the xorg.conf settings that work for my type of mouse and my problems seem to be gone! I thought my whole USB controller was the problem or perhaps my IRQ settings, but it was actually quite simple.

    Here is what I added to the bottom of my xorg.conf file (in /etc/X11/xorg.conf):

    Section "InputDevice"

    Identifier "Logitech MX1000"

    Driver "evdev"

    Option "Name" "Logitech USB Receiver"

    Option "HWHEELRelativeAxisButtons" "7 6"

    EndSection

    Note that this only seemed to work with MY mouse. You must find a solution for your OWN type of mouse. Just goes to show that even just having the wrong mouse settings can crash your whole machine in really funky ways.

  10. #10
    Join Date
    Oct 2008
    Beans
    6

    Re: Mouse clicks not working properly after upgrade to 9.10 / Karmic

    One extra note for the solution listed above is that you need to have evdev on your machine. To install enter the following in your console:

    sudo apt-get install xserver-xorg-input-evdev

Page 1 of 9 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •