Results 1 to 7 of 7

Thread: Problems with Intel video in Karmic

  1. #1
    Join Date
    Jun 2009
    Location
    Brazil
    Beans
    44
    Distro
    Ubuntu 9.10 Karmic Koala

    Problems with Intel video in Karmic [SOLVED]

    I've an Intel 82945G/GZ, that works perfectly in Jaunty. In Karmic, the only resolutions avaiable are 800x600 and 640x480. My xorg.conf is empty (just the default sections, nothing especial). How can I enable 1024x768?
    Last edited by trx64; November 14th, 2009 at 12:12 AM.

  2. #2
    Join Date
    Apr 2005
    Location
    Canada
    Beans
    245
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Problems with Intel video in Karmic

    Could you post your xorg.conf ?
    You could also try
    Code:
    sudo dpkg-reconfigure -phigh xserver-xorg
    to regenerate the xorg.conf file

  3. #3
    Join Date
    Oct 2009
    Beans
    11

    Re: Problems with Intel video in Karmic

    dpkg-reconfigure is not working on Karmic anymore, I'm very surprised this is not mentioned in the release note;

    Xorg -configure does the work, however in your case, you may still not be able to get 1024x768, I suspect this is a Intel specific driver bug - I'm having the same issue as you!

    I've raised a bug report and hopefully this can be fixed soon.

  4. #4
    Join Date
    Jun 2009
    Location
    Brazil
    Beans
    44
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Problems with Intel video in Karmic

    The Xorg.conf is empty, just the default. Someone has an working Xorg.conf for Intel video?

  5. #5
    Join Date
    Jun 2009
    Location
    Brazil
    Beans
    44
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Problems with Intel video in Karmic

    I've solved the problem by disabling KMS (Kernel Mode Setting) in Intel driver, leaving the detection of my screen resolution just with X. There is no need to change xorg.conf, just leave it at default values.

    Edit the file /boot/grub/menu.lst (if you have GRUB 2, use Startup Manager). In the end of the "kernel" line of the OS entry, add "nomodesetting":

    Code:
    title           Ubuntu 9.10, kernel 2.6.31-14-generic
    root            (hd0,4)                              
    kernel          /boot/vmlinuz-2.6.31-14-generic root=UUID=92583a31-1693-438c-ae3f-61ab9b8ca13a ro quiet splash locale=pt_BR nomodesetting                                       
    initrd          /boot/initrd.img-2.6.31-14-generic                                   
    quiet

  6. #6
    Join Date
    Aug 2007
    Location
    Canada
    Beans
    55
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Problems with Intel video in Karmic

    Adding the line nomodesetting did nothing for me.

    I have the 82845G Brookdale intel chipset.


    TY

  7. #7
    Join Date
    Apr 2005
    Location
    Astoria, Oregon
    Beans
    197
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Problems with Intel video in Karmic

    I have the 82845G Brookdale intel chipset, on my HP Pavillion 754v and no AGP or PCIx slot, and man it's been a headache trying all sorts of "fixes" for this problem of being stuck in 800x600 in 10.04. I spent an evening, and this was literally the last try I was going to allow myself. There are other things to do in my life.
    IT WORKED! One thing though - I do have GRUB 2 and startupmanager did not offer any options for adding kernel boot options so I looked it up.
    What I ended up doing is this:
    Code:
    sudo gedit /etc/default/grub
    I added nomodesetting to the GRUB_CMDLINE_LINUX_DEFAULT line so that the line looks like this:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodesetting"
    And then DON'T FORGET TO RUN
    Code:
    sudo update-grub
    Reboot and voila! It works! Higher resolutions!
    Last edited by Terry of Astoria; March 4th, 2011 at 02:38 AM. Reason: Clarify release was 10.04

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •