Results 1 to 2 of 2

Thread: eee PC 1015PE - eth0 disappears when Fn keys fix enabled

  1. #1
    Join Date
    Jul 2010

    eee PC 1015PE - eth0 disappears when Fn keys fix enabled

    Ok, strange problem after using the fix for function keys here


    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash  acpi_osi=Linux"
    But, my eth0 totally disappeared (as in, not listed for lspci).

    So, was recommended to change the value to:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash  acpi_osi='!Windows 2009'"
    eth0 came back, but function keys turned off again.

    Now, when you use acpi_osi=Linux it will set the wlan off within the BIOS, but it still works within lucid.

    The only thing I really care about is having the switch to toggle the FRIGGEN touch pad on/off.

    Any help would be appreciated; I can hardly type with this thing enabled.

    Thank you.

  2. #2
    Join Date
    Jul 2010

    Re: eee PC 1015PE - eth0 disappears when Fn keys fix enabled

    A bit more info.

    Right now I have acpi_osi=Linux enabled. The eth0 doesn't register within lspci, but all of the Fn keys respond properly; WLAN was disabled within BIOS, but it works without hitting the hotkeys.

    Now the only strange thing is when I hit fn+f3 (to disable touchpad) it produces this error:

    "Unable to enable touchpad; ensure xorg.conf is properly configured."

    But, the touchpad still works....

    Restarted, and switch wlan back on within bios; eth0 came back, but wlan gets disabled again after every reboot.

    ** I apologize for any typing errors as I am simply trying to get the touchpad to toggle on/off.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts