Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: KWin unstable after update from 9.04 to 9.10

  1. #1
    Join Date
    Oct 2009
    Location
    HU, Dombóvár
    Beans
    6
    Distro
    Kubuntu 9.10 Karmic Koala

    Question KWin unstable after update from 9.04 to 9.10

    Hello!
    Could someone help me with my problem? I haven't found any solutions.... >_>
    Also my problem:
    I have upgraded my Kubuntu 9.04 to 9.10, everything was fine, but after restart (using kernel 2.6.31-14, the newest one) and the login, I see a window, that tells me that KWin is unstable, it has frozen often, and I should chose another windowing system... what I, of course don't have. ^^"
    I'm now using kernel 2.6.28-16, and it works...... although I don't have any sound....
    My system is completely updated, I'm using my laptop, with ATI Mobility Radeon HD 3470 video card, and the Catalyst driver (9.10).
    Any help please?

  2. #2
    Join Date
    Feb 2007
    Beans
    55

    Re: KWin unstable after update from 9.04 to 9.10

    I'm having the same problem with older 2.6.28.

    kwin: ../../src/xcb_io.c:542: _XRead: Assertion 'dpy->xcb->reply_data != ((void *)0)' failed.

  3. #3
    Join Date
    Oct 2009
    Location
    HU, Dombóvár
    Beans
    6
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: KWin unstable after update from 9.04 to 9.10

    Yeah. I have the same thing, except that I have some Hungarian in it. ^^
    / "kijelentés meghiúsult" == "failed" /
    It was quite hard to get this output without having keyboard input on my terminal.

    tomarctus@Stray-Wolf:~$ kwin
    kwin: ../../src/xcb_io.c:542: _XRead: A(z) „dpy->xcb->reply_data != ((void *)0)” kijelentés meghiúsult.
    Application::crashHandler() called with signal 6; recent crashes: 1
    KCrash: Application 'kwin' crashing...
    Félbeszakítva (memória kiírás)
    tomarctus@Stray-Wolf:~$ kwin: ../../src/xcb_io.c:542: _XRead: A(z) „dpy->xcb->reply_data != ((void *)0)” kijelentés meghiúsult.
    Application::crashHandler() called with signal 6; recent crashes: 2
    KCrash: Application 'kwin' crashing...
    kwin: ../../src/xcb_io.c:542: _XRead: A(z) „dpy->xcb->reply_data != ((void *)0)” kijelentés meghiúsult.
    Application::crashHandler() called with signal 6; recent crashes: 3
    KCrash: Application 'kwin' crashing...
    kwin: ../../src/xcb_io.c:542: _XRead: A(z) „dpy->xcb->reply_data != ((void *)0)” kijelentés meghiúsult.
    Application::crashHandler() called with signal 6; recent crashes: 4
    KCrash: Application 'kwin' crashing...
    Any ideas how I could change this? >.>

  4. #4
    Join Date
    Feb 2007
    Beans
    55

    Re: KWin unstable after update from 9.04 to 9.10

    Hey I got it! Erase your Ati drivers (sudo sh /usr/share/ati/fglrx-uninstall.sh) then reinstall with sudo sh ati-driver-installer-9-10-x86.x86_64.run --buildpkg Ubuntu/karmic. Then install all deb packages and do /usr/bin/aticonfig --initial. Reboot.

    Let me know.

  5. #5
    Join Date
    Oct 2009
    Location
    HU, Dombóvár
    Beans
    6
    Distro
    Kubuntu 9.10 Karmic Koala

    Lightbulb Re: KWin unstable after update from 9.04 to 9.10

    Wooww......
    I don't know how... but it's working.....
    10/10.
    Thanks. =D> It was a great help.

  6. #6
    Join Date
    Jul 2009
    Location
    India
    Beans
    11
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: KWin unstable after update from 9.04 to 9.10

    w
    Last edited by sgk111; November 13th, 2009 at 07:33 PM.

  7. #7
    Join Date
    Feb 2007
    Beans
    55

    Re: KWin unstable after update from 9.04 to 9.10

    You're welcome tomarctus. It's been a pain in the *** for me too, but luckily a little tweaking has helped.

  8. #8
    Join Date
    Nov 2009
    Beans
    2

    Re: KWin unstable after update from 9.04 to 9.10

    Same here on a Thinkpad T42p with ATI FireGL T2
    I went trhough all betas of Karmic Koala 9.10 without major problems (except for the Wireless not working).
    Graphics performance was poor, so I decided to install the fglrx - ATI drivers via the KPackageKit.

    On reboot, KWin was reported to be unstable.
    The KDE crash report did not accecpt the available backtrace data.
    I could not remove the fglrx-packages via KPackagekit or via
    Konsole-Terminal because the keyboard would not function anymore. The whole system is rendered unsuable now, because in crucial places keyboard input is not working and the title bar of al GUI windows has disappeard.

    I managed to install the debug symbols for KDELibs5-dbg (did not find any for KWin), but
    even then I could not get sufficient backtracing information for
    the KDE crash handler.


  9. #9
    Join Date
    Nov 2009
    Beans
    2

    Re: KWin unstable after update from 9.04 to 9.10

    Hi, I think this could solve my issue with Ubuntu 9.10 becuase I have issues with screen in my ATI Radeon. But I don't understand completely your third step. When you say ..."Then install all deb packages ..." Where I have to do that? Could you provide me more details.

    Sorry but I am very new with Linux.

    Thanks in advance!!


    Quote Originally Posted by MarcoPau View Post
    Hey I got it! Erase your Ati drivers (sudo sh /usr/share/ati/fglrx-uninstall.sh) then reinstall with sudo sh ati-driver-installer-9-10-x86.x86_64.run --buildpkg Ubuntu/karmic. Then install all deb packages and do /usr/bin/aticonfig --initial. Reboot.

    Let me know.

  10. #10
    Join Date
    Jan 2009
    Beans
    5
    Distro
    Kubuntu 9.10 Karmic Koala

    Exclamation Re: KWin unstable after update from 9.04 to 9.10

    OK so I waited a bit to install the FGLRX driver because of issues in the past and it seems I've missed the boat. If you have an older ATI card specifically the ATI Radeon Series you MUST use a legacy driver from ATI.

    From the ATI site: http://support.amd.com/us/gpudownloa...4&lang=English
    The Linux ATI Catalyst™ driver will only be supported in Linux distributions prior to February 2009 for the legacy products listed above.

    Any customers using a combination of a ATI Radeon™ HD 2000 Series, ATI Radeon™ HD 3000 Series, or ATI Radeon™ HD 4000 Series product with any of the legacy products listed above in a single PC system must use the ATI Catalyst 9.3 or earlier driver. All future ATI Catalyst™ releases made available past the ATI Catalyst™ 9.3 release will not include support for the legacy products listed above or any of the features associated with those legacy products.
    This means that the version currently in the Karmic Repository is NG no good for folks like myself and a few of the other posters. My only inclination is to try compiling with Jaunty and seeing if it will work.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •