Page 3 of 7 FirstFirst 12345 ... LastLast
Results 21 to 30 of 66

Thread: Need to disable gdm

  1. #21
    Join Date
    Jun 2009
    Location
    0000:0400
    Beans
    Hidden!

    Re: Need to disable gdm

    Quote Originally Posted by sisco311 View Post
    To disable gdm, you have to edit the /etc/init/gdm.conf file. For details see my post above.
    Not true. As stated above, it can be removed from the init sequence as follows:
    Code:
    sudo update-rc.d -f gdm
    I was just playing with this last night. Discovered this which is definitely a bug.

  2. #22
    Join Date
    Feb 2007
    Location
    Romania
    Beans
    Hidden!

    Re: Need to disable gdm

    Quote Originally Posted by falconindy View Post
    Not true. As stated above, it can be removed from the init sequence as follows:
    Code:
    sudo update-rc.d -f gdm
    I was just playing with this last night. Discovered this which is definitely a bug.
    It will not work in 9.10 since there are no system startup links for /etc/init.d/gdm.


    from man update-rc.d:
    update-rc.d - install and remove System-V style init script links.
    gdm (in 9.10) is controlled by an Upstart job and NOT by a System-V style init script.

  3. #23
    Join Date
    Nov 2009
    Location
    Boston, MA
    Beans
    Hidden!
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Need to disable gdm

    Sisco311,

    Thank you for your clarification with regards to sysv vs upstart. Your advice for preventing gdm by editing /etc/init/gdm.conf has worked for me.

    However, it has introduced a new problem in that I no longer have audio when I start X with the startx command. There doesn't seem to be any indication of a problem in any of the /var/log files. This appears to be a 'silent' failure, if you will. I suppose I should open a new thread for this?

  4. #24
    Join Date
    Feb 2007
    Location
    Romania
    Beans
    Hidden!

    Re: Need to disable gdm

    Quote Originally Posted by Argyled View Post
    Sisco311,

    Thank you for your clarification with regards to sysv vs upstart. Your advice for preventing gdm by editing /etc/init/gdm.conf has worked for me.

    However, it has introduced a new problem in that I no longer have audio when I start X with the startx command. There doesn't seem to be any indication of a problem in any of the /var/log files. This appears to be a 'silent' failure, if you will. I suppose I should open a new thread for this?
    Is the sound muted or you get permission errors?

    Do you get sound if you start gdm?
    Code:
    sudo service gdm start
    Last edited by sisco311; November 9th, 2009 at 01:49 PM.

  5. #25
    Join Date
    Nov 2009
    Location
    Boston, MA
    Beans
    Hidden!
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Need to disable gdm

    Quote Originally Posted by sisco311 View Post
    Is the sound muted or you get permission errors?

    Do you get sound if you start gdm?
    Code:
    sudo service gdm start
    The sound isn't muted and I don't appear to be getting permission errors anywhere that I've been able to find. I do get sound if I start gdm, but the X session I'm in when I start it is either closed by gdm or crashes.

    I started a new thread for this here: http://ubuntuforums.org/showthread.php?t=1320661

    Thanks!

  6. #26
    Join Date
    Mar 2008
    Beans
    5

    Re: Need to disable gdm

    The problem is also weak "conversion" from sysv stuff.

    I was already on 9.10 with everything working, meaning SLIM _NOT_ GDM was enabled in the sysv stuff.

    Then today's update TURNED ON GDM in UPSTART, but LEFT SLIM trying to start, which BROKE EVERYTHING.

    If GDM was disabled (no links in rc.? directories), then UPSTART CONVERSION SHOULD HAVE DETECTED THAT AND LEFT IT DISABLED.

    Just wasted hours with a broken display to fix this and re-disable GDM. Long live SLIM, down with GDM, who needs to waste the memory for a login manager?

  7. #27
    Join Date
    Feb 2007
    Location
    Romania
    Beans
    Hidden!

    Re: Need to disable gdm

    Quote Originally Posted by toehser View Post
    The problem is also weak "conversion" from sysv stuff.

    I was already on 9.10 with everything working, meaning SLIM _NOT_ GDM was enabled in the sysv stuff.

    Then today's update TURNED ON GDM in UPSTART, but LEFT SLIM trying to start, which BROKE EVERYTHING.

    If GDM was disabled (no links in rc.? directories), then UPSTART CONVERSION SHOULD HAVE DETECTED THAT AND LEFT IT DISABLED.

    Just wasted hours with a broken display to fix this and re-disable GDM. Long live SLIM, down with GDM, who needs to waste the memory for a login manager?

    How did you disabled GDM?

    Slim is not in the Karmic repositories, it has some serious security issues.


    http://osdir.com/ml/ubuntu-devel-dis.../msg00097.html
    The reason it is not in karmic (and can't be now) is presumably because it was not in Debian when we synced from Debian earlier in the release cycle. Ubuntu has not modified it in any way - we've just taken it from Debian. If it gets back in Debian it will get back in Ubuntu.

    Looking at packages.debian.org I find slim in lenny and sid. It has some terrible bugs though including one that says you can login as root without a password! It sounds like it is good that it is not in karmic!
    How did you installed SLIM?

  8. #28
    Join Date
    Mar 2008
    Beans
    5

    Re: Need to disable gdm

    It is a virtual machine with memory use by far the most highest importance. Slim / LXDE is great. Sorry to hear it has bugs, maybe I'll look into and try to fix. Don't care about the bugs, though, really, the host machine is secure enough that it doesn't matter if the login manager on the guest is buggy.

    Not sure whether GDM was disabled with no links in rc.? or with DEFAULT_DISPLAY_MANAGER stuff or what. Bottom line: GDM didn't start. My business if something else did. Ran aptitude full-upgrade. Suddenly GDM did start, and started broken.

    Not sure how I installed slim, either, but probably back around the time of Hardy, and ever since, it "just worked", and the Intrepid update I don't think re-turned-on GDM, and the Karmic update didn't, either, it was fine with Karmic/Slim _after_ Karmic install, then a recent update broke it. Which is worse.

  9. #29
    Join Date
    Oct 2005
    Beans
    2
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Need to disable gdm

    So, Sisco

    From reading this thread I can see that you are very good at telling people what doesn't work anymore, and that it's not a bug that it doesn't work like it used to.

    Still though, no answer to the initial question.

    How do one permanently disable gdm (or any upstart job, for that matter), preferably without having to edit a script that might be updated and by that restored?

    (i.e. what we used to do using 'update-rc.d -f gdm remove')

    /Jonas
    Last edited by jbygden; December 11th, 2009 at 11:55 AM. Reason: typo

  10. #30
    Join Date
    Dec 2009
    Beans
    3
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Need to disable gdm

    well, this disables sound, as a previous post pointed out, but here goes:

    in /etc/default/grub, comment out

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

    add

    GRUB_CMDLINE_LINUX_DEFAULT="text"

    then

    sudo update-grub

    this will pass "text" on the kernel line, disabling gdm.

Page 3 of 7 FirstFirst 12345 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •