Page 2 of 35 FirstFirst 123412 ... LastLast
Results 11 to 20 of 341

Thread: ATI & Nvidia: no X, just blinking on 2.6.31 (Karmic 9.10)

  1. #11
    Join Date
    May 2007
    Location
    Duisburg / Germany
    Beans
    4
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Ubuntu will not boot successfully with 2.6.31 kernel, but fine with 2.6.28 kernel

    It works now, I did the following steps:

    • Boot from the install disk into recovery mode
    • download from nvidia.com the NVIDIA-Linux-*.run for your hardware and copy it to your PC (I did it with a second PC and transfered via scp)
    • run the NVIDIA-Linux-*.run
    • Follow the instructions
    • reboot
    Last edited by y.t; October 30th, 2009 at 11:06 AM.

  2. #12
    Join Date
    Feb 2008
    Beans
    97

    Re: Ubuntu will not boot successfully with 2.6.31 kernel, but fine with 2.6.28 kernel

    nvidia is not the problem because i have an ati card.

    i too can not login. num lock flickers too if i switch it on.

    the 9.10 live cd works fine, im posting here with it.

    i used the alternate install with no internet connection.

    booting with 2.6.28 does not help!

    i tried startx but got an error.

    where are the logs which may help to help me?

  3. #13
    Join Date
    Oct 2009
    Location
    York, UK
    Beans
    5
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Ubuntu will not boot successfully with 2.6.31 kernel, but fine with 2.6.28 kernel

    I got the same updating from Jaunty. Used the alternate CD downloaded from a torrent. I wouldn't recommend doing that to anyone - the install wasn't complete - I had numerous errors during the upgrade, mostly relating to nvidia drivers and flashplugin-installer. Once completed I noticed I was only booting into the .28 kernel and the boot menu showed Ubuntu 9.04. Used update manager which found a further 200+ updates. Once updated I was still using the .28 kernel, grub still claimed I was on 9.04 and to make matters worse had no sound and wine wouldn't work (supposedly not installed).

    My 'resolution' - edited /boot/grub/menu.lst, copied the sections for .28.15 generic and recovery and renamed the appropriate files to the .31.14 versions that I could see in /boot/grub/. Put the .31 sections second in the list and restarted, chosing the .31 kernel. At this point I got the tty flickers mentioned above and the boot sequence went no further. Restarted into the recovery option for .31. Chose the fix broken packages option - none needed to be fixed. Then chose to continue with the normal boot. At this point there was further mention of the nvidia drivers and a few seconds later boot continued successfully. Now running 9.10 with the .31 kernel.

    That was how things were around 1am this morning (having started the upgrade at about 8pm). Oh and though you might think everything's now peachy I get a crash report every time I boot - see this bug.

    Wish I'd done a clean install.

    Appreciate that as an existing and generally content Ubuntu user I'm not Joe Public but if I were I'd have dropped Ubuntu at about 9.30 last night and toddled off to find a copy of Windows 7.
    Last edited by graydo64; October 30th, 2009 at 10:31 AM.

  4. #14
    Join Date
    Oct 2009
    Beans
    2

    Re: Ubuntu will not boot successfully with 2.6.31 kernel, but fine with 2.6.28 kernel

    I did a fresh install on my laptop, a Lenovo ThinkPad, and i have the same problem. Login is impossible due to the flickering.
    My laptop has ATI graphics card, so it can't be the Nvidia issues causing this.

    Anyone?

  5. #15
    Join Date
    Jul 2007
    Beans
    1

    Re: Ubuntu will not boot successfully with 2.6.31 kernel, but fine with 2.6.28 kernel

    Quote Originally Posted by y.t View Post
    It works now, it did the following steps:

    • Boot from the install disk into recovery mode
    • download from nvidia.com the NVIDIA-Linux-*.run for your hardware and copy it to your PC (I did it with a second PC and transfered via scp)
    • run the NVIDIA-Linux-*.run
    • Follow the instructions
    • reboot
    This method worked for me. Thanks.

  6. #16
    Join Date
    Feb 2008
    Beans
    97

    Re: Ubuntu will not boot successfully with 2.6.31 kernel, but fine with 2.6.28 kernel

    ubuntu did not fix a critical show stopper bug!

    X.Org X Server 1.6.4
    Release Date: 2009-9-27
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 2.6.24-23-server i686 Ubuntu
    Current Operating System: Linux dust 2.6.28-16-generic #55-Ubuntu SMP Tue Oct 20 19:48:24 UTC 2009 i686
    Kernel command line: root=UUID=bdc35c88-41e7-40b7-8474-41fd4aa55a06 ro single
    Build Date: 26 October 2009 05:15:02PM
    xorg-server 2:1.6.4-2ubuntu4 (buildd@)
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Fri Oct 30 10:37:07 2009
    (==) Using config file: "/etc/X11/xorg.conf"
    (==) No Layout section. Using the first Screen section.
    (**) |-->Screen "Default Screen" (0)
    (**) | |-->Monitor "Configured Monitor"
    (**) | |-->Device "Configured Video Device"
    (==) Automatically adding devices
    (==) Automatically enabling devices
    (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    Entry deleted from font path.
    (==) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/100dpi/:unscaled,
    /usr/share/fonts/X11/75dpi/:unscaled,
    /usr/share/fonts/X11/Type1,
    /usr/share/fonts/X11/100dpi,
    /usr/share/fonts/X11/75dpi,
    /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
    built-ins
    (==) ModulePath set to "/usr/lib/xorg/modules"
    (II) Cannot locate a core pointer device.
    (II) Cannot locate a core keyboard device.
    (II) The server relies on HAL to provide the list of input devices.
    If no devices become available, reconfigure HAL or disable AllowEmptyInput.
    (II) Loader magic: 0x3bc0
    (II) Module ABI versions:
    X.Org ANSI C Emulation: 0.4
    X.Org Video Driver: 5.0
    X.Org XInput driver : 4.0
    X.Org Server Extension : 2.0
    (II) Loader running on linux
    (--) using VT number 7

    (--) PCI:*(0:1:0:0) 1002:475a:1002:0084 ATI Technologies Inc 3D Rage IIC AGP rev 122, Mem @ 0xde000000/16777216, 0xdfeff000/4096, I/O @ 0x0000c800/256, BIOS @ 0x????????/131072
    (II) Open ACPI successful (/var/run/acpid.socket)
    (II) System resource ranges:
    [0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
    [1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
    [2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
    [3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
    [4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
    [5] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
    (II) LoadModule: "extmod"
    (II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
    (II) Module extmod: vendor="X.Org Foundation"
    compiled for 1.6.4, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension MIT-SCREEN-SAVER
    (II) Loading extension XFree86-VidModeExtension
    (II) Loading extension XFree86-DGA
    (II) Loading extension DPMS
    (II) Loading extension XVideo
    (II) Loading extension XVideo-MotionCompensation
    (II) Loading extension X-Resource
    (II) LoadModule: "dbe"
    (II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
    (II) Module dbe: vendor="X.Org Foundation"
    compiled for 1.6.4, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension DOUBLE-BUFFER
    (II) LoadModule: "glx"
    (II) Loading /usr/lib/xorg/modules/extensions//libglx.so
    (II) Module glx: vendor="X.Org Foundation"
    compiled for 1.6.4, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
    (==) AIGLX enabled
    (II) Loading extension GLX
    (II) LoadModule: "record"
    (II) Loading /usr/lib/xorg/modules/extensions//librecord.so
    (II) Module record: vendor="X.Org Foundation"
    compiled for 1.6.4, module version = 1.13.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension RECORD
    (II) LoadModule: "dri"
    (II) Loading /usr/lib/xorg/modules/extensions//libdri.so
    (II) Module dri: vendor="X.Org Foundation"
    compiled for 1.6.4, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension XFree86-DRI
    (II) LoadModule: "dri2"
    (II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
    (II) Module dri2: vendor="X.Org Foundation"
    compiled for 1.6.4, module version = 1.1.0
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension DRI2
    (==) Matched ati for the autoconfigured driver
    (==) Assigned the driver to the xf86ConfigLayout
    (II) LoadModule: "ati"
    (WW) Warning, couldn't open module ati
    (II) UnloadModule: "ati"
    (EE) Failed to load module "ati" (module does not exist, 0)
    (EE) No drivers available.

    Fatal server error:
    no screens found

    Please consult the The X.Org Foundation support
    at http://wiki.x.org
    for help.
    Please also check the log file at "/var/log/Xorg.0.log" for additional information.

    ddxSigGiveUp: Closing log
    so what now?

  7. #17
    Join Date
    Oct 2009
    Beans
    3

    Cool Re: Ubuntu will not boot successfully with 2.6.31 kernel, but fine with 2.6.28 kernel

    Hello guys.

    I'm facing various weird problems after upgrading from 9.04 to 9.10 (32bit), and the most important one is the one described in this thread.

    My system does not boot with 2.6.31 Kernel, due to 2 of my hard drives not being "seeing" by the OS. Those 2 HDs are identical (80Gb SATA Hitachi, don't remember the model) and the one contains my Ubuntu installation.

    I always got stuck in BusyBox right after Grub tried to find my boot HD unsuccessfully. "Gave up waiting for root device". Increasing the rootdelay time as it's usually suggested, didn't helped.

    blkid -c /dev/null was showing me all other HDs, but the 2 Hitachi ones. For those I was getting: /dev/sdb: TYPE="isw_raud_member".
    And no, I am not using any RAID configuration.

    I tried switching SATA controllers between the Hitach HDs and my other working HDs, but the result was the same. HDs in question were still disappeared, but other HDs were fine.

    Starting with 9.10 Live CD, although I could see those drives doing an fdisk -l, I couldn't mount them though. Trying to do so resulted into error msg: "mount: unknown filesystem typ "lsw_raid_member"

    When I tried starting off a 9.04 LiveCD, there was no problem at all.

    Eventually I booted my system using 2.6.28 Kernel. It booted "normally". Screen was scrambled at the beginning. In TTY1, 2 etc, screen was totally messed up too, but when switched back to TTY7 it was all ok. So I can partially use my PC for now.

    I still have many other problems though (eg. no audio, no proper VGA card support, etc), but those are of lower priority at the moment, which might be solved after managing to use the latest Kernel...I hope.

    I find my problem really weird, as if the specific hardware (HDs) are not supported by the latest Kernel (?). I don't see another logical explanation for this problem. Definitely it wasn't a controller's issue.

    Hopefully a proper solution for this problem will come soon. Any suggestions will be highly appreciated.

    Thanks.


    Some additional hardware info:
    MoBo: Asus P5W Deluxe (intel 975x chipset)
    CPU: Intel Q8200
    VGA: ATI Radeon X1900 XT


    ***UPDATE: My problem was due to having 2 identical HDs no matter that they were on different SATA controllers! For some reason the new Kernel acts funny in such cases. After removing one of the 2 HDs (who needs Windows anyway ), my PC booted normally with the latest Kernel and Video & Audio worked flawlessly too! Little bug, huge frustration! I hope this will help others facing similar problems.
    Last edited by FrankCy; October 31st, 2009 at 12:52 AM.

  8. #18
    Join Date
    Feb 2008
    Beans
    97

    Re: Ubuntu will not boot successfully with 2.6.31 kernel, but fine with 2.6.28 kernel

    *bump*

    https://bugs.launchpad.net/ubuntu/+bug/464591

    i did a bugreport here!

  9. #19
    Join Date
    Dec 2008
    Beans
    5

    Re: Ubuntu will not boot successfully with 2.6.31 kernel, but fine with 2.6.28 kernel

    Quote Originally Posted by y.t View Post
    It works now, I did the following steps:

    • Boot from the install disk into recovery mode
    • download from nvidia.com the NVIDIA-Linux-*.run for your hardware and copy it to your PC (I did it with a second PC and transfered via scp)
    • run the NVIDIA-Linux-*.run
    • Follow the instructions
    • reboot
    I was not on a network, so I had some trouble doing exactly what you said above, but your method did work, thanks! This is what I did:

    1. Use a different computer to download the NVIDIA-Linux-*.run for my new laptop
    2. Copy that new driver to a USB drive
    3. Boot to recovery mode on the new laptop (had to look this up):
      Hit ESC just after your Bios loads when (in theory) you see the "Grub loading blah blah" (it was WAY too fast to see it on my machine)
      A menu will come up with boot options, select the one that ends in (recovery mode)
      You are dropped at the root@yournmachine:~# prompt
    4. Plug my USB drive into the laptop (after a few seconds I saw some stuff scroll by the screen)
    5. Mount the USB drive (had to look this one up):
      Find the drive with the command: sudo fdisk -l (mine was /dev/sdb1)
      Create a directory to mount it as: sudo mkdir /media/external
      Mount the drive: sudo mount -t vfat /dev/sdb1 /media/external -o uid=1000,gid=100,utf8,dmask-027/fmask=137
      NOTE: if your USB is not FAT## you need a different -t option
    6. Copied the new driver to my home directory (may not have been necessary)
    7. execute the NVIDIA-Linux-*.run file
      I had to change permissions on the file before I could run it: chmod 777 NVIDIA*
      Ran the file with: ./NVIDIA*.run
    8. Follow the instructions
    9. Reboot


    This made the flickering login problem go away and allowed me to get in and start using Ubuntu on my new machine.

  10. #20
    Join Date
    Jul 2007
    Beans
    1

    Re: Ubuntu will not boot successfully with 2.6.31 kernel, but fine with 2.6.28 kernel

    Quote Originally Posted by DustofDust View Post
    ubuntu did not fix a critical show stopper bug!



    so what now?
    I managed to get round this by removing fglrx and doing
    sudo apt-get install xserver-xorg-video-ati
    sudo dpkg-reconfigure -phigh xserver-xorg

Page 2 of 35 FirstFirst 123412 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •