Page 23 of 33 FirstFirst ... 132122232425 ... LastLast
Results 221 to 230 of 328

Thread: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

  1. #221
    Join Date
    Feb 2010
    Beans
    18

    Re: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

    My mplayer was working I had already updated it to the svn version, but I was having sound issues on my hdmi connection so I went through the how-to on upgrading alsa ([SOLVED] (all varients) fixing scratching/poping noise on ubuntu 9.10 - Ubuntu Forums)
    Now all I get from Mplayer is : "Mplayer has finished expectantly. exit code 1"

    I 'apt-get purge'ed Mplayer and followed you how-to again to no avail.

    LOG:
    p, li { white-space: pre-wrap; } mplayer -noquiet -nofs -nomouseinput -afm hwac3 -lavdopts skiploopfilter=all -sub-fuzziness 1 -identify -slave -vo xv -ao alsa:device=hw=0.1 -nokeepaspect -framedrop -autosync 100 -nodr -double -input nodefault-bindings:conf=/dev/null -stop-xscreensaver -wid 62914575 -monitorpixelaspect 1 -subcp ISO-8859-1 -vid 0 -aid 0 -subpos 100 -volume 50 -nocache -ss 6417 -osdlevel 0 -vf-add screenshot -slices -channels 2 -softvol -softvol-max 120 /home/yorgie/Downloads/Movies/The.Hangover.2009.UNRATED.BluRay.1080p.DTS.x264-CHD/The.Hangover.2009.UNRATED.BluRay.1080p.DTS.x264-CHD.mkv

    MPlayer SVN-r30886-4.3.4 (C) 2000-2010 MPlayer Team
    Terminal type `unknown' is not defined.

    Playing /home/yorgie/Downloads/Movies/The.Hangover.2009.UNRATED.BluRay.1080p.DTS.x264-CHD/The.Hangover.2009.UNRATED.BluRay.1080p.DTS.x264-CHD.mkv.
    ID_VIDEO_ID=0
    ID_VID_0_NAME=The.Hangover.2009.Extended.Cut
    [mkv] Track ID 1: video (V_MPEG4/ISO/AVC) "The.Hangover.2009.Extended.Cut", -vid 0
    ID_AUDIO_ID=0
    ID_AID_0_NAME=DTS-5.1CH 1536K
    ID_AID_0_LANG=eng
    [mkv] Track ID 2: audio (A_DTS) "DTS-5.1CH 1536K", -aid 0, -alang eng
    [mkv] Will play video track 1.
    Matroska file format detected.
    VIDEO: [avc1] 1920x800 24bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
    ID_FILENAME=/home/yorgie/Downloads/Movies/The.Hangover.2009.UNRATED.BluRay.1080p.DTS.x264-CHD/The.Hangover.2009.UNRATED.BluRay.1080p.DTS.x264-CHD.mkv
    ID_DEMUXER=mkv
    ID_VIDEO_FORMAT=avc1
    ID_VIDEO_BITRATE=0
    ID_VIDEO_WIDTH=1920
    ID_VIDEO_HEIGHT=800
    ID_VIDEO_FPS=23.976
    ID_VIDEO_ASPECT=2.4000
    ID_AUDIO_FORMAT=8193
    ID_AUDIO_BITRATE=0
    ID_AUDIO_RATE=48000
    ID_AUDIO_NCH=6
    ID_LENGTH=6473.49
    ID_SEEKABLE=1
    ID_CHAPTERS=0
    Opening video filter: [screenshot]
    ================================================== ========================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
    ================================================== ========================
    ID_VIDEO_CODEC=ffh264
    ================================================== ========================
    Trying to force audio codec driver family hwac3...
    Opening audio decoder: [hwac3] AC3/DTS pass-through S/PDIF
    hwac3: switched to DTS, 1536000 bps, 48000 Hz
    AUDIO: 48000 Hz, 2 ch, ac3le, 1536.0 kbit/100.00% (ratio: 192000->192000)
    ID_AUDIO_BITRATE=1536000
    ID_AUDIO_RATE=48000
    ID_AUDIO_NCH=2
    Selected audio codec: [hwdts] afm: hwac3 (DTS through S/PDIF)
    ================================================== ========================
    [AO_ALSA] alsa-lib: conf.c:3843parse_args) Unknown parameter AES0
    [AO_ALSA] alsa-lib: conf.c:3969snd_config_expand) Parse arguments error: No such file or directory
    [AO_ALSA] alsa-lib: pcm.c:2211snd_pcm_open_noupdate) Unknown PCM hw:0,1,AES0=6
    AO: [alsa] 48000Hz 2ch ac3le (2 bytes per sample)
    ID_AUDIO_CODEC=hwdts
    [Mixer] No hardware mixing, inserting volume filter.
    [format] Sample format little-endian AC3 not yet supported
    Starting playback...


    MPlayer interrupted by signal 11 in module: decode_audio
    ID_SIGNAL=11
    - MPlayer crashed by bad usage of CPU/FPU/RAM.
    Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
    disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
    - MPlayer crashed. This shouldn't happen.
    It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
    gcc version. If you think it's MPlayer's fault, please read
    DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
    won't help unless you provide this information when reporting a possible bug.
    Last edited by yorgmeister; March 13th, 2010 at 08:50 PM.

  2. #222
    Join Date
    Dec 2006
    Beans
    7,305

    Re: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

    Hi yorgmeister,

    Certainly there are some audio errors there. Have a look at:

    Code:
    andrew@skamandros~$ mplayer -ao help
    MPlayer SVN-r30886-4.3.3 (C) 2000-2010 MPlayer Team
    Available audio output drivers:
    	oss	OSS/ioctl audio output
    	alsa	ALSA-0.9.x-1.x audio output
    	esd	EsounD audio output
    	sdl	SDLlib audio output
    	mpegpes	DVB audio output
    	v4l2	V4L2 MPEG Audio Decoder output
    	null	Null audio output
    	pcm	RAW PCM/WAVE file writer audio output
    and see if you have some alternatives to experiment with. If so you can launch your file from the commandline in the following fashion:

    Code:
    mplayer -ao oss <my_file>
    where of course my_file is the real name and path to your own file.

    Andrew
    You think that's air you're breathing now?

  3. #223
    Join Date
    Dec 2009
    Location
    I.R.IRAN
    Beans
    50
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

    I use Gnome mplayer but it freeze random when playing video or audio files and just show a black screen without sound and if i simply press backward or forward button to send it 10 sec forward or backward it will continue to play video until it freeze again.(in audio files i should kill gnome-mplayer process)
    sometimes it takes seconds to freeze and sometimes half an hour or more.

  4. #224
    Join Date
    Dec 2006
    Beans
    7,305

    Re: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

    Hi margemoosh,

    Can I ask which version of MPlayer you are using? This can be seen in the following fashion:
    Code:
    andrew@skamandros~$ mplayer | head -n 1
    MPlayer SVN-r30931-4.3.3 (C) 2000-2010 MPlayer Team
    Some confusion sometimes exists between the Totem Movie Player, which is the default player for GNOME, and MPlayer which is a 3rd party offering. Could you have a look at the results of Help --> About for the player that is giving you trouble and confirm which version and which player?

    All the best,

    Andrew
    You think that's air you're breathing now?

  5. #225
    Join Date
    Dec 2009
    Location
    I.R.IRAN
    Beans
    50
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

    Quote Originally Posted by andrew.46 View Post
    Hi margemoosh,

    Can I ask which version of MPlayer you are using? This can be seen in the following fashion:
    Code:
    andrew@skamandros~$ mplayer | head -n 1
    MPlayer SVN-r30931-4.3.3 (C) 2000-2010 MPlayer Team
    Some confusion sometimes exists between the Totem Movie Player, which is the default player for GNOME, and MPlayer which is a 3rd party offering. Could you have a look at the results of Help --> About for the player that is giving you trouble and confirm which version and which player?

    All the best,

    Andrew
    Code:
    margemoosh@Sisto:~$ mplayer | head -n 1
    MPlayer SVN-r30858-4.3.4 (C) 2000-2010 MPlayer Team
    and in help-> about: gnome-mplayer 0.9.9

    i think problem is audio because when audio playing and mplayer freeze you sholud quit it and reopen it but in video you should just press backward button to send it a few seconds back or forward and it will continue playing!

  6. #226
    Join Date
    Dec 2006
    Beans
    7,305

    Re: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

    Hi margemoosh,

    Quote Originally Posted by margemoosh View Post
    i think problem is audio because when audio playing and mplayer freeze you sholud quit it and reopen it but in video you should just press backward button to send it a few seconds back or forward and it will continue playing!
    You could possibly be having a problem with either video or audio out devices and if you are keen I would suggest a little experimentation with both. Perhaps to start with run all of your audio as -ao pulse and this perhaps might be enough, if not try something like -vo gl to test video output problems. A bit of trial and error?

    Andrew
    You think that's air you're breathing now?

  7. #227
    Join Date
    Dec 2009
    Location
    I.R.IRAN
    Beans
    50
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

    Quote Originally Posted by andrew.46 View Post
    Hi margemoosh,



    You could possibly be having a problem with either video or audio out devices and if you are keen I would suggest a little experimentation with both. Perhaps to start with run all of your audio as -ao pulse and this perhaps might be enough, if not try something like -vo gl to test video output problems. A bit of trial and error?

    Andrew
    how i can do this?
    in gnome-mplayer in terminal i dont see any -ao option.

  8. #228
    Join Date
    Dec 2006
    Beans
    7,305

    Re: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

    Hi margemoosh,

    Quote Originally Posted by margemoosh View Post
    how i can do this?
    in gnome-mplayer in terminal i dont see any -ao option.
    I was referring to MPlayer, sorry I was less than clear .

    Andrew
    You think that's air you're breathing now?

  9. #229
    Join Date
    Feb 2010
    Beans
    18

    Re: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

    Thanks andrew

    I tried your suggestion 'mplayer -ao oss' and mplayer works great from the command line, so my problem must be with smplayer, as it still outputs the same 'exit code 1' error. I tried mplayer with several different sound options, they all worked, but I am still left with my original problem of the sound cutting in and out on my hdmi output to my tv. sound works great on my computer speakers. any ideas?

    george

  10. #230
    Join Date
    Dec 2006
    Beans
    7,305

    Re: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

    Hi George,

    Quote Originally Posted by yorgmeister View Post
    I tried your suggestion 'mplayer -ao oss' and mplayer works great from the command line, so my problem must be with smplayer, as it still outputs the same 'exit code 1' error.
    And of course SMPlayer has very easily configurable audio out options seen from Options --> Preferences --> General --> Audio --> Output Driver.

    I tried mplayer with several different sound options, they all worked, but I am still left with my original problem of the sound cutting in and out on my hdmi output to my tv. sound works great on my computer speakers. any ideas?
    I am afraid that my experience with sound output from MPlayer is my computer speakers and headphones when I feel like getting a little fancy . Hopefully somebody with some experience in this area can help out on this thread...

    All the best,

    Andrew
    You think that's air you're breathing now?

Page 23 of 33 FirstFirst ... 132122232425 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •