Results 1 to 10 of 22

Thread: USB and external HD not mounting

Hybrid View

  1. #1
    Join Date
    Jun 2008
    Beans
    7

    USB and external HD not mounting

    I have a western Digital USB HD that when connected the light comes on the drive and the drive makes a repeated dull clicking noise and never lets me view the drive. I connect the same drive and USB cable to another PC running 9.04 that works perfect on. I can connect my Black berry to the very same USB port and cable it works fine. I also put a new USB card in the PC and still same issue.

    Any suggestions?

  2. #2
    Join Date
    Jan 2009
    Location
    The Great White North
    Beans
    41
    Distro
    Ubuntu

    Re: USB and external HD not mounting

    The clicking is a good sign your drive is failing. Will work sometimes on some OS but not always. Use HD tools (ie. smartmontools) to check the health of the drive. Might not be fully gone yet but will likely be soon. Backup asap before you loose your data. Same happened to me few years ago...
    "When life only tosses you lemons, get some salt & tequila...& get ready for a long night!"

  3. #3
    Join Date
    Jun 2008
    Beans
    7

    Re: USB and external HD not mounting

    I don't suspect it's failing. It's done this since new (two months now) and has always worked very well on any PC but MINE???

    Just booted the PC with a live cd of Kubuntu and same thing, blackberry plugged in and I can access it, memory stick plugged in and I can access it. I'v tried many different BIOS settings but no luck with the damn drive.

  4. #4
    Join Date
    Aug 2009
    Beans
    7

    Re: USB and external HD not mounting

    Have you tried the mount terminal command and/or did your hard drive come with an install CD?
    By the way, are your friends/other peoples windows or mac? Try accessing it on another Ubuntu computer.

  5. #5
    Join Date
    Jun 2008
    Beans
    7

    Re: USB and external HD not mounting

    I mounted it a few months back with similar results. I since have reinstalled ubuntu. The other PC's have been same version ubuntu and two other Win PC's.

    Is there a specific IRQ USB is suppose to use on ubuntu?

  6. #6

    Re: USB and external HD not mounting

    Yodal,
    I have the similar sign in my all sd cards after update to 9.10.
    I wish: It's incident with new Karmic.
    My cards are mount with smartmontools, but in one minute or two it isn't enable for use.

  7. #7
    Join Date
    Feb 2008
    Location
    Lancashire, UK
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: USB and external HD not mounting

    Quote Originally Posted by yodal View Post
    I have a western Digital USB HD
    Is it bus powered? Some USB ports don't supply enough power for some portable hard drives and produce symptoms just like those you describe. Self powered devices like your Blackberry are unaffected, as are external hard disks with their own power supplies.

  8. #8
    Join Date
    Jun 2008
    Beans
    7

    Re: USB and external HD not mounting

    Quote Originally Posted by John Bean View Post
    Is it bus powered? Some USB ports don't supply enough power for some portable hard drives and produce symptoms just like those you describe. Self powered devices like your Blackberry are unaffected, as are external hard disks with their own power supplies.
    That was it John, I got a powered USB hub and things took care of them selfs!

    Thanks

  9. #9
    Join Date
    Feb 2008
    Location
    Lancashire, UK
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: USB and external HD not mounting

    Glad to help. Been there once, used the same fix

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •