Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: metacity doesn't start automatically

  1. #11
    Join Date
    Sep 2005
    Beans
    143
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: metacity doesn't start automatically

    when I start it from the console, I don't get any errors - it just starts

  2. #12
    Join Date
    Oct 2007
    Beans
    2

    Re: metacity doesn't start automatically

    I have exactly the same problem. After upgrading to 9.10 the window manager just does not start on login. If I run metacity from the command line it works fine. X and gnome desktop seem to work fine. Where is metacity normally started from?

  3. #13
    Join Date
    Sep 2005
    Beans
    143
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: metacity doesn't start automatically

    unfortunately, I don't know where metacity normally starts from. It used to be configured in the file ~/.gnome2/session. I'm not sure where they moved it to.

  4. #14
    Join Date
    Jan 2006
    Beans
    187
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: metacity doesn't start automatically

    Quote Originally Posted by jworr View Post
    unfortunately, I don't know where metacity normally starts from. It used to be configured in the file ~/.gnome2/session. I'm not sure where they moved it to.
    Well Metacity is just window decorator, not a window manager... most likely you won't be able to find it in session files. Are you completly sure you are not running Compiz...

    What is the result of:
    Code:
    ps -A | grep compiz
    Just a note: If you have desktop effects enabled you are running Compiz...
    RCF Group | http://rcf-group.com
    Sunflower file manager | http://code.google.com/p/sunflower-fm

  5. #15
    Join Date
    Nov 2009
    Beans
    3

    Re: metacity doesn't start automatically

    Hi! I'm new around here, but I have been Ubuntu / Linux user for a while. I recently upgraded from 8.04 to 9.10.

    Looks like I'm having this same problem, when I log in there's no metacity or compiz running. I can open the terminal (panels are visible and working) and run either of them and things are working - until the next login of course. I have Ati Radeon 4870 and use the automatically offered closed drivers if that matters.

    Now, to actually contribute at least something: I think I know where the window manager / decorator is specified in settings. Just start gconf-editor (via terminal, you probably won't find it in menus) and browse to /desktop/gnome/session. There is a configuration key required_components_list, which contains a list of values. For me they are [windowmanager,panel,filemanager].

    Those values seem to refer to the required_components, which is another "folder" under the session "folder". There are some values, and the important one is windowmanager. Its value is metacity if you have no desktop effects on, and compiz if they are enabled. In my case it doesn't seem to do anything, but checking that value might help figure things out.

    Edit: Okay, I took a little chance and added some extra values to those places and the program (firefox to be specific) did run, so I am pretty sure that that place really is the one that is supposed to run metacity or compiz.
    Last edited by iRauta; November 11th, 2009 at 09:54 PM.

  6. #16
    Join Date
    Sep 2005
    Beans
    143
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: metacity doesn't start automatically

    for /desktop/gnome/session/required_components/windowmanager I have metacity

  7. #17
    Join Date
    Nov 2009
    Beans
    3

    Re: metacity doesn't start automatically

    Yesterday, I tried deleting the entire .gconf directory, and the .gnome2 directory too. (Actually, I just renamed them.) Did not help. I think it can be ruled out that the problem lies in those places. The file .xsession-errors contains several error messages, but nothing seems to be related to metacity - or compiz if I try to enable desktop effects.

    Now I just created a new user, and for it metacity...sorry, compiz started up fine. So even if the reason for metacity (or compiz) not starting is not in those two obvious-looking directories it still seems to be something in the home directory.
    Last edited by iRauta; November 14th, 2009 at 12:11 PM.

  8. #18
    Join Date
    Nov 2009
    Beans
    3

    Re: metacity doesn't start automatically

    I think I found out the files that caused this. Took some time to narrow the problem to a specific directory but it's nice to have a desktop that works again!

    Go to directory .local/share/applications - .local resides in your home directory. (Ctrl-H shows dot-files and directories in file manager.) I moved these files from there to a backup folder:

    compiz.desktop
    gnome-wm.desktop (gnome-wm apparently is a script that runs the actual window manager and seems to be the default value for the windowmanager gconf key)
    metacity.desktop

    I have no idea why those files would cause problems - maybe it is a bad thing to have launchers with some specific names, or maybe the files are in a old format and some update broke compatibility or maybe they are somehow corrupted.

  9. #19
    Join Date
    Sep 2005
    Beans
    143
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: metacity doesn't start automatically

    Renaming the files gnome-wm.desktop metacity.desktop in the .local/share/applications directory fixed it! Good job figuring this out!

  10. #20
    Join Date
    Jun 2009
    Beans
    1

    Re: metacity doesn't start automatically

    Moving the files gnome-wm.desktop metacity.desktop in the .local/share/applications directory fixed it for me as well!
    Thanks a lot!

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •