Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: Desktop Effects Could not be enabled

  1. #1
    Join Date
    Apr 2009
    Beans
    6

    (Solved)Desktop Effects Could not be enabled

    Hi all,
    I just installed Ubuntu 9.04 and everything is working fine. Except when i try to enable Desktop Effects a pop up appears saying "searching for drivers" then the screen starts to blink as if it were to work, but in the end it says "desktop effects could not be enabled". I am running an Intel 82865G Integrated Graphics. I been looking for a solution such as installing xserver-xgl. However, everytime I run the command

    apt-get install xserver-xgl

    I get this error:

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Couldn't find package xserver-xgl

    I hope somebody could help me.
    By the way this is my graphics card

    00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
    00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)
    00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
    00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
    00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
    00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
    00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
    00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
    00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
    00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
    00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
    01:01.0 Modem: Intel Corporation FA82537EP 56K V.92 Data/Fax Modem PCI (rev 04)
    01:08.0 Ethernet controller: Intel Corporation 82562EZ 10/100 Ethernet Controller (rev 02)

    Hope somebody can help me.
    Thanks in advance!
    Last edited by legendaryred; April 27th, 2009 at 06:10 AM.

  2. #2
    Join Date
    Feb 2009
    Beans
    50
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Desktop Effects Could not be enabled

    For desktop effects to be enabled you need a driver for your graphics chipset.
    Go to System>Administration>Hardware Drivers
    I dont have an intel chipset, so im not sure exactly what you'll see.
    But if you do see a driver, then go ahead and enable it, restart, and it should all be good

  3. #3
    Join Date
    Apr 2008
    Location
    Louisiana, US
    Beans
    Hidden!
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Desktop Effects Could not be enabled

    I found a real easy fix. It happens with intel cards.
    Go to the terminal, and copy and paste the code below.

    Code:
    mkdir -p ~/.config/compiz/ && echo SKIP_CHECKS=yes >> ~/.config/compiz/compiz-manager
    And you have effects now!
    Toshiba Satellite Notebook L305D - 3GB DDR2 RAM - 320GB HD - DUAL BOOT: Windows 7 and Ubuntu 10.10

  4. #4
    Join Date
    Apr 2009
    Beans
    6

    Re: Desktop Effects Could not be enabled

    Quote Originally Posted by SpitfireSMS View Post
    For desktop effects to be enabled you need a driver for your graphics chipset.
    Go to System>Administration>Hardware Drivers
    I dont have an intel chipset, so im not sure exactly what you'll see.
    But if you do see a driver, then go ahead and enable it, restart, and it should all be good
    I tried that and it says" No propietrary drivers could be found" and everything else is just empty.

  5. #5
    Join Date
    Apr 2009
    Beans
    6

    Re: Desktop Effects Could not be enabled

    Quote Originally Posted by gymophett View Post
    I found a real easy fix. It happens with intel cards.
    Go to the terminal, and copy and paste the code below.

    Code:
    mkdir -p ~/.config/compiz/ && echo SKIP_CHECKS=yes >> ~/.config/compiz/compiz-manager
    And you have effects now!
    I tried it and it sends me this:

    seoane@seoane-desktop:~$ mkdir -p ~/.config/compiz/ && echo SKIP_CHECKS=yes >> ~/.config/compiz/compiz-manager
    seoane@seoane-desktop:~$ seoane
    bash: seoane: command not found

    Did i do something wrong?

  6. #6
    Join Date
    Apr 2008
    Location
    Louisiana, US
    Beans
    Hidden!
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Desktop Effects Could not be enabled

    Quote Originally Posted by legendaryred View Post
    I tried it and it sends me this:

    seoane@seoane-desktop:~$ mkdir -p ~/.config/compiz/ && echo SKIP_CHECKS=yes >> ~/.config/compiz/compiz-manager
    seoane@seoane-desktop:~$ seoane
    bash: seoane: command not found

    Did i do something wrong?
    No, you entered seoane after the code for some reason, and seoane is your computer name, not a command.

    Let me try again.

    Paste the code I gave you in your terminal and press enter.
    Then exit the terminal.
    Right click your desktop and click 'Change desktop background'.
    Click 'visual effects'
    Then click Normal or Extra, and it should work.
    Toshiba Satellite Notebook L305D - 3GB DDR2 RAM - 320GB HD - DUAL BOOT: Windows 7 and Ubuntu 10.10

  7. #7
    Join Date
    Apr 2009
    Beans
    6

    Re: Desktop Effects Could not be enabled

    Quote Originally Posted by gymophett View Post
    No, you entered seoane after the code for some reason, and seoane is your computer name, not a command.

    Let me try again.

    Paste the code I gave you in your terminal and press enter.
    Then exit the terminal.
    Right click your desktop and click 'Change desktop background'.
    Click 'visual effects'
    Then click Normal or Extra, and it should work.
    I'm sorry about that.
    Ok i did what you said and when i click "normal" the whole desktop went white and i could only see my cursor. After like 15 seconds it returns to normal with "none" selected. It didn't send an error of some kind. I think this has to do something with my graphics chip. Any ideas?

  8. #8
    Join Date
    Apr 2008
    Location
    Louisiana, US
    Beans
    Hidden!
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Desktop Effects Could not be enabled

    Quote Originally Posted by legendaryred View Post
    I'm sorry about that.
    Ok i did what you said and when i click "normal" the whole desktop went white and i could only see my cursor. After like 15 seconds it returns to normal with "none" selected. It didn't send an error of some kind. I think this has to do something with my graphics chip. Any ideas?
    Interesting. I'm new to Linux, so I might not be the best help, but I'll try as best as I can.
    Maybe all of the correct drivers aren't installed?

    Lets revert your driver back to 2.4 and it should work.

    Here we go:

    Add the following lines to your /etc/apt/sources.list:
    To get there:
    Go to Places>Home folder>File System>etc>apt
    When you are there, right click sources.list and open with text editor.
    Then copy and paste the lines below and save it.

    Code:
     deb http://ppa.launchpad.net/siretart/ppa/ubuntu jaunty main
     deb-src http://ppa.launchpad.net/siretart/ppa/ubuntu jaunty main
    Install the driver:
    Code:
    sudo apt-get update
    sudo apt-get install xserver-xorg-video-intel-2.4
    Now you should be set. Restart X and see if the graphics performance from intrepid is restored.
    Toshiba Satellite Notebook L305D - 3GB DDR2 RAM - 320GB HD - DUAL BOOT: Windows 7 and Ubuntu 10.10

  9. #9
    Join Date
    Apr 2009
    Beans
    6

    Re: Desktop Effects Could not be enabled

    Quote Originally Posted by gymophett View Post
    Interesting. I'm new to Linux, so I might not be the best help, but I'll try as best as I can.
    Maybe all of the correct drivers aren't installed?

    Lets revert your driver back to 2.4 and it should work.

    Here we go:

    Add the following lines to your /etc/apt/sources.list:
    To get there:
    Go to Places>Home folder>File System>etc>apt
    When you are there, right click sources.list and open with text editor.
    Then copy and paste the lines below and save it.

    Code:
     deb http://ppa.launchpad.net/siretart/ppa/ubuntu jaunty main
     deb-src http://ppa.launchpad.net/siretart/ppa/ubuntu jaunty main
    Install the driver:
    Code:
    sudo apt-get update
    sudo apt-get install xserver-xorg-video-intel-2.4
    Now you should be set. Restart X and see if the graphics performance from intrepid is restored.
    Wow, It worked!
    Thanks a lot for your help. I was getting frustrated with this. It worked magnificently.
    Hope this helps other people!
    Thanks again!

  10. #10
    Join Date
    Apr 2008
    Location
    Louisiana, US
    Beans
    Hidden!
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Desktop Effects Could not be enabled

    Quote Originally Posted by legendaryred View Post
    Wow, It worked!
    Thanks a lot for your help. I was getting frustrated with this. It worked magnificently.
    Hope this helps other people!
    Thanks again!
    You're very welcome! Any time.
    Toshiba Satellite Notebook L305D - 3GB DDR2 RAM - 320GB HD - DUAL BOOT: Windows 7 and Ubuntu 10.10

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •