Results 1 to 4 of 4

Thread: Curious Fullscreen Problem

  1. #1
    Join Date
    Nov 2012

    Question Curious Fullscreen Problem

    So it's been a number of years since I last dabbled in Ubuntu, having started on Hoary and last used Dapper when it was first released. Always had problems with nVidia drivers, but always got it working in the end.

    So I think to myself, why not try the latest version and see what's changed. Alot apparently, but I digress.

    Every time I seem to run a game, either native (Wesnoth) or running under WINE (Warcraft III) my resolution goes haywire and I have to shunt into tty1 and force a reboot. Killing and restarting the DM from there yields in less than satisfactory results.

    I assumed this was an nVidia driver issue when I first discovered it, so I went through the headache of trying each and every driver, latest and previous versions with no progress.

    I've tried various combinations of screen resolution and driver, all have which has caused me a headache and a major case of disgruntlement. All games run merrily in windowed mode, some naturally slower than others. I'm well aware that Ubuntu (or Linux for that matter) isn't a suitable gaming system, just to say before someone points it out.

    Anyway, any help would be appreciated. If you need any more information, please don't hesitate to ask.


    GPU: GeForce 7300 SE/7200 GS/PCIe/SSE2 
    CPU: Intel® Pentium(R) CPU G840 @ 2.80GHz × 2 
    RAM: 8GB
    OS: Ubuntu 12.10 32-bit
    Resolution: 1440x900
    Monitor: ViewSonic VA1912wSERIES
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 304.48  (  Sun Sep  9 21:31:39 PDT 2012
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 304.51  (buildd@aatxe)  Fri Oct 12 12:54:02 UTC 2012
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    Section "Files"
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "ViewSonic VA1912wSERIES"
        HorizSync       30.0 - 82.0
        VertRefresh     50.0 - 85.0
        Option         "DPMS"
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 7300 SE/7200 GS"
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
        Option         "nvidiaXineramaInfoOrder" "CRT-0"
        Option         "metamodes" "1440x900_60 +0+0"
        SubSection     "Display"
            Depth       24

  2. #2
    Join Date
    Nov 2012

    Re: Curious Fullscreen Problem

    Shameless bump and an update.

    Had quite a few views, but no replies. Alas.

    Anyway, I've decided to downgrade my system from 12.10 to 12.04 to see if there'd be any changes, or any possibility that'd it'd work. Still the same problem it seems. Gonna try limiting my screen resolution to 1280x1024 max and see if the problem still persists.

  3. #3
    Join Date
    Dec 2009

    Re: Curious Fullscreen Problem

    I've had nothing but trouble with 12.10, particularly in regards to 3D applications. I am now using 12.04 and things are much better.

    I don't know how to fix your problem entirely, but I may have a workaround. Try loading your winecfg and head over to the "graphics" tab and enable emulating a virtual desktop. You can then enter any resolution you like, and the apps that you launch will use that res (they will think it's the actual resolution of the screen).

    This will sort of give you a windowed mode, but will also allow you to access your other stuff on your computer at the same time as gaming (such as changing music tracks, etc).
    Holding a LAN party? Check out LAN Party Mania (detailed LAN information for games)

  4. #4
    Join Date
    Nov 2012

    Re: Curious Fullscreen Problem

    Thanks for the reply holastickboy!

    Glad to know I'm not the only one having issues with 12.10! Celestia knows what the Ubuntu team has done since Dapper, but it all seems to be going downhill, and simplifying everything till it's confusing. Ah well.

    I've been running wine under a emulated desktop since I discovered this whole fiasco as a work around already. Most games run perfectly fine in the emulated desktop size of 1400x900, but what gets me is if THAT works, (and it still takes up the whole screen) then why isn't it running WITHOUT the emulated desktop? It's just an error that's irritating me. Like a rolling pin with a large dent.

    Some chaps have suggested that it might actually be my insanely obscure monitor doesn't want to play ball with Ubuntu, so I'll dig out my old CRT and see where that gets me. I won't be able to have a nice, 1400x900 desktop, but c'est la vie.

    Cheers for the reply anyway!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts