Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Unable to mount USB,

  1. #1
    Join Date
    Nov 2007
    Beans
    66

    Unable to mount USB,

    A USB pen I have (named Bob) refuses to mount. I've tried reformatting it but nothing changed

    Here's the error message I receive:
    Unable to mount Bob
    Error mounting: mount exited with exit code 1: helper failed with:
    mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
    missing codepage or helper program, or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so
    Here is the result for fsck (if it can be useful):
    Code:
    calixte@Lucy:~$ sudo fsck -n /dev/sdb1
    fsck from util-linux-ng 2.16
    dosfsck 3.0.3, 18 May 2009, FAT32, LFN
    /dev/sdb1: 1 files, 1/978042 clusters
    Thanks
    -Calixte

  2. #2
    Join Date
    Oct 2007
    Beans
    Hidden!

    Re: Unable to mount USB,

    try running gparted and delete and recreate the partition?

  3. #3
    Join Date
    Apr 2006
    Beans
    Hidden!
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Unable to mount USB,

    Unable to mount Bob
    Error mounting: mount exited with exit code 1: helper failed with:
    mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
    missing codepage or helper program, or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so
    Can paste the output of
    Code:
    dmesg |tail -20
    That usually gives some indication of what's wrong.

  4. #4
    Join Date
    Nov 2007
    Beans
    66

    Re: Unable to mount USB,

    Yeah, I did that, but it just gives me the same old error

  5. #5
    Join Date
    Nov 2007
    Beans
    66

    Re: Unable to mount USB,

    Quote Originally Posted by Baelus View Post
    Can paste the output of
    Code:
    dmesg |tail -20
    That usually gives some indication of what's wrong.
    Code:
    calixte@Lucy:~$ dmesg |tail -20
    [ 2258.238419] wlan0: associated
    [ 2601.620100] usb 1-1: new high speed USB device using ehci_hcd and address 3
    [ 2601.754902] usb 1-1: configuration #1 chosen from 1 choice
    [ 2601.884274] Initializing USB Mass Storage driver...
    [ 2601.884829] scsi6 : SCSI emulation for USB Mass Storage devices
    [ 2601.887997] usbcore: registered new interface driver usb-storage
    [ 2601.889184] USB Mass Storage support registered.
    [ 2601.891698] usb-storage: device found at 3
    [ 2601.891712] usb-storage: waiting for device to settle before scanning
    [ 2606.888484] usb-storage: device scan complete
    [ 2606.889431] scsi 6:0:0:0: Direct-Access     JetFlash Transcend 4GB    8.07 PQ: 0 ANSI: 2
    [ 2606.893296] sd 6:0:0:0: Attached scsi generic sg1 type 0
    [ 2606.907030] sd 6:0:0:0: [sdb] 7843840 512-byte logical blocks: (4.01 GB/3.74 GiB)
    [ 2606.909647] sd 6:0:0:0: [sdb] Write Protect is off
    [ 2606.909660] sd 6:0:0:0: [sdb] Mode Sense: 03 00 00 00
    [ 2606.909667] sd 6:0:0:0: [sdb] Assuming drive cache: write through
    [ 2606.914957] sd 6:0:0:0: [sdb] Assuming drive cache: write through
    [ 2606.914976]  sdb: sdb1
    [ 2607.222722] sd 6:0:0:0: [sdb] Assuming drive cache: write through
    [ 2607.222744] sd 6:0:0:0: [sdb] Attached SCSI removable disk

  6. #6
    Join Date
    Apr 2006
    Beans
    Hidden!
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Unable to mount USB,

    That looks like everything's fine.

    I take it you're trying to mount it from the terminal. Did you use the "-t vfat" option when mounting it?

  7. #7
    Join Date
    Nov 2007
    Beans
    66

    Re: Unable to mount USB,

    Ok, I managed to mount it with
    Code:
    calixte@Lucy:~$ sudo mount -t vfat /dev/sdb1 /media/cdrom0
    Thanks a lot for the tip. I've got another question however. How can I ask the system to mount the device in a more orthodox way (i.e. not as cdrom0)
    If I specify any other location, it won't mount. It's not horribly problematic (The computer is a netbook, so I don't have an optical CD-ROM drive anyway), but kind of annoying nonetheless.

  8. #8
    Join Date
    Apr 2006
    Beans
    Hidden!
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Unable to mount USB,

    Glad you got it working.

    You should be able to create a folder and use it as a mount point. You can make a folder in /media called "jetflash" and mount it like this:

    Code:
    sudo mount -t vfat /dev/sdb1 /media/jetflash
    Give that a try.

    The mount command needs to know the filesystem of the partition being mounted. The -t option is used for that using vfat for FAT32/16, ext3 for ext3, ntfs-3g for NTFS etc. Otherwise the mount command is kinda stupid and gives an error.

  9. #9
    Join Date
    Jan 2009
    Beans
    1

    Cool Re: Unable to mount USB,

    Hello. Since Karmic I cannot automount any USB device ( I can mount it terminal, but I'd like to get the automount feature back.

    dmesg | tail -20
    [44273.300655] usb 1-8: configuration #1 chosen from 1 choice
    [44273.305729] scsi8 : SCSI emulation for USB Mass Storage devices
    [44273.305855] usb-storage: device found at 5
    [44273.305857] usb-storage: waiting for device to settle before scanning
    [44278.305918] usb-storage: device scan complete
    [44278.311011] scsi scan: INQUIRY result too short (5), using 36
    [44278.311018] scsi 8:0:0:0: Direct-Access USB 2.0 (HS) Flash Disk 1.00 PQ: 0 ANSI: 0 CCS
    [44278.311356] sd 8:0:0:0: Attached scsi generic sg3 type 0
    [44278.315141] sd 8:0:0:0: [sdc] 4008881 512-byte logical blocks: (2.05 GB/1.91 GiB)
    [44278.316025] sd 8:0:0:0: [sdc] Write Protect is off
    [44278.316028] sd 8:0:0:0: [sdc] Mode Sense: 00 c0 00 00
    [44278.316031] sd 8:0:0:0: [sdc] Assuming drive cache: write through
    [44278.321985] sd 8:0:0:0: [sdc] Assuming drive cache: write through
    [44278.321992] sdc: sdc1
    [44278.340067] sd 8:0:0:0: [sdc] Assuming drive cache: write through
    [44278.340073] sd 8:0:0:0: [sdc] Attached SCSI removable disk
    [44321.464588] FAT: IO charset ANSI_X3.4-1968 not found
    [44321.517477] FAT: IO charset ANSI_X3.4-1968 not found
    [44647.362745] FAT: invalid media value (0x06)
    [44647.362753] VFS: Can't find a valid FAT filesystem on dev sdc.

  10. #10
    Join Date
    Apr 2006
    Beans
    Hidden!
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Unable to mount USB,

    I'm not using Karmic, but try this thread:

    http://wwww.ubuntuforums.org/showthread.php?t=1309239

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •