I am having same problem. I cannot boot without a monitor. The PC completely freezes because when i hit caps lock or number lock no lights turn on and when i plug the monitor up after that i get nothing but a black screen. I have to shut it down hard (hold down the power button) and then power back up.

I think its after the grub selection. When I shut it down hard - the next time it boots it goes into this menu "kernel ... something or other" is the first choice. "kernel ... something + safe mode" is the second choice. The third and fourth choices are memory tests. (i can see this because i reattached the monitor).

So then i do another hard shutdown. Pull the monitor cable. Then I power back up. I see the hard drive flashing flashing ... and then stop. I'm (blindly) guessing that its at the Grub selection menu again. So I hit enter. Sure enough the hard drive light goes flashing flashing ... then stops. At that point I'm frozen again (no caps lock or number lock and black screen when i reconnect the monitor).

I tried the xorg.conf thing. Didn't work.

I'm trying to do this last suggestion by marleaux. Someone please help me.

I go "cd /etc/default/grub" it says "no such directory"
So I go "cd /etc/default/" apparently "grub" is a file.
I go "sudo pico grub" and i see a file open up.
i find the line that says "GRUB_CMDLINE_LINUX_DEFAULT".
The full line reads:
I put a # in front of that line.
Then i enter

tried reboot with no monitor - same thing. Frozen.

my computer is a IBM thinkcentre S50 8183-GNU and it has intel integrated video. I went to Lenovo website and obtained latest BIOS update. There is no option in the BIOS for "halt on" anything. I am running 9.10 Karmic.

Somebody please help?
And when providing a solution please be more specific. When marleaux wrote "And I added xrandr settings to /etc/X11/Xsession.d/45custom_xrandr-settings" i thought ... "i dont have a 45custom_xrandr-settings" file in that directory and even if i did i don't know how to "add xrandr settings".