Results 1 to 2 of 2

Thread: aspire 5520G

  1. #1
    Join Date
    Oct 2009

    aspire 5520G

    I'm having a challenging problem with my acer aspire 5520G, first It wasn't loading to windows then it started telling me to launch start up repair, but it switches off immediately when i press enter!!
    I tried to change the ram to check if it's a memory problem but it's still the same!

    So after many times of restarting i managed to go to repair by pressing F8 and I recovered the start up to fix the starting up problem, but it was still the same. Then i tried to do a hardware check but the battery went off and now all i see is a black screen. I'm not able to do anything
    I can only see that the laptop is on but with a black screen.
    Please I need help repairing it.
    Last edited by esadi; October 13th, 2009 at 03:57 PM.

  2. #2
    Join Date
    Oct 2009

    Exclamation Re: aspire 5520G

    so no one is smart enough to solve this problem? when i press power on it works for 5 seconds then it restarts and it keep on doing the same thing.....


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts