Results 1 to 10 of 874

Thread: New Wacom Bamboo not working

Threaded View

  1. #1
    Join Date
    Apr 2008

    Question New Wacom Bamboo not working

    Attention everyone! this post is outdated, if you don't want to read the whole thread go to post #541

    I know there are some other wacom posts but I have been unable to find a solution after trying out multiple installation guides. I am running ubuntu (with kde and ubuntu-studio packages installed, probably won't make a differnece) 9.04 64-bit. I may try upgrading to karmic to see if I can get it to work.

    I just got the new wacom bamboo pen & touch in the post this morning but I am unable to get it working.
    The site
    says it should be hot-pluggable, but it definately is not.
    I have looked at this guide:
    and changed the .fdi file as shown on:
    And I have followed the detailed instructions on:

    This is how far I have got:

    I have compiled and installed from linuxwacom-0.8.3-6 (dev version) after trying the stable version. Installation of the driver and tools worked fine.
    However, I have tried using wacdump on all the /dev/input/event* and none of them work when I touch the tablet with my finger or stylus or press any of the buttons. I also do not have a /dev/input/wacom file even though I have added the udev rules to /etc/udev/rules.d/ as shown on:

    This is the output from /var/log/messages after unloading and reloading the driver using rmmod wacom and modprobe wacom and then unplugging and replugging my tablet.

    Oct 13 15:08:04 shaun-PC kernel: [ 3026.486653] usbcore: deregistering interface driver wacom
    Oct 13 15:08:09 shaun-PC kernel: [ 3032.272906] usbcore: registered new interface driver wacom
    Oct 13 15:08:09 shaun-PC kernel: [ 3032.273506] wacom: v1.49-pc-1:USB Wacom Graphire and Wacom Intuos tablet driver
    Oct 13 15:08:17 shaun-PC kernel: [ 3040.113349] usb 2-2: USB disconnect, address 2
    Oct 13 15:08:23 shaun-PC kernel: [ 3046.316476] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
    Oct 13 15:08:24 shaun-PC kernel: [ 3046.736008] usb 2-2: new full speed USB device using ohci_hcd and address 5
    Oct 13 15:08:24 shaun-PC kernel: [ 3046.959822] usb 2-2: configuration #1 chosen from 1 choice
    This is what I get from running cat /proc/bus/input/devices

    I: Bus=0019 Vendor=0000 Product=0002 Version=0000
    N: Name="Power Button (FF)"
    P: Phys=LNXPWRBN/button/input0
    S: Sysfs=/devices/LNXSYSTM:00/LNXPWRBN:00/input/input0
    U: Uniq=
    H: Handlers=kbd event0 
    B: EV=3
    B: KEY=10000000000000 0
    I: Bus=0019 Vendor=0000 Product=0001 Version=0000
    N: Name="Power Button (CM)"
    P: Phys=PNP0C0C/button/input0
    S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input1
    U: Uniq=
    H: Handlers=kbd event1 
    B: EV=3
    B: KEY=10000000000000 0
    I: Bus=0017 Vendor=0001 Product=0001 Version=0100
    N: Name="Macintosh mouse button emulation"
    P: Phys=
    S: Sysfs=/devices/virtual/input/input2
    U: Uniq=
    H: Handlers=mouse0 event2 
    B: EV=7
    B: KEY=70000 0 0 0 0
    B: REL=3
    I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
    N: Name="AT Translated Set 2 keyboard"
    P: Phys=isa0060/serio0/input0
    S: Sysfs=/devices/platform/i8042/serio0/input/input3
    U: Uniq=
    H: Handlers=kbd event3 
    B: EV=120013
    B: KEY=402000000 3803078f800d001 feffffdfffefffff fffffffffffffffe
    B: MSC=10
    B: LED=7
    I: Bus=0010 Vendor=001f Product=0001 Version=0100
    N: Name="PC Speaker"
    P: Phys=isa0061/input0
    S: Sysfs=/devices/platform/pcspkr/input/input4
    U: Uniq=
    H: Handlers=kbd event4 
    B: EV=40001
    B: SND=6
    I: Bus=0011 Vendor=0002 Product=0006 Version=007f
    N: Name="ImExPS/2 Logitech Explorer Mouse"
    P: Phys=isa0060/serio1/input0
    S: Sysfs=/devices/platform/i8042/serio1/input/input5
    U: Uniq=
    H: Handlers=mouse1 event5 
    B: EV=7
    B: KEY=1f0000 0 0 0 0
    B: REL=143
    Output of lsusb:
    DBus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 005: ID 056a:00d1 Wacom Co., Ltd 
    Bus 002 Device 004: ID 093a:2601 Pixart Imaging, Inc. SPC 610NC Laptop Camera
    Bus 002 Device 003: ID 093a:2468 Pixart Imaging, Inc. Cammaestro 2.5DU/X-EYE/Orite SC-120/ICGear TravelCam/Easy Snap Snake Eye WebCam
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    I modified my xorg.conf, but after the xserver failing to start I reverted it to my backup.

    Thanks in advance to anyone who can help

    P.S the new wacom supports multi-touch so if anyone knows how to get this working as wall that would be great!
    Last edited by TheguywholikesLINUX; December 1st, 2009 at 11:08 AM. Reason: outdated!

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts