Results 1 to 5 of 5

Thread: Internal speaker help

  1. #1
    Join Date
    Jul 2008
    Beans
    25

    Internal speaker help

    I newly installed Ubuntu 9.04 (jaunty) on my Acer laptop- and my internal speakers (and external) don't work. I can't find any solutions to the problem, and I'm hesitant to try my noob ubuntu skills on this. Any suggestions?

    (who am I kidding? Of course you guys have suggestions..)

  2. #2
    Join Date
    Aug 2009
    Location
    Chengdu, China
    Beans
    104
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Internal speaker help

    Quote Originally Posted by vivaldibabe View Post
    I newly installed Ubuntu 9.04 (jaunty) on my Acer laptop- and my internal speakers (and external) don't work. I can't find any solutions to the problem, and I'm hesitant to try my noob ubuntu skills on this. Any suggestions?

    (who am I kidding? Of course you guys have suggestions..)
    Try this it may help. But first check to make sure the sound is not muted.

    Originally Posted by Broder
    Fix: The sound on Front was disabled as opposed to muted. A friend of mine found a solution by adding the following line of code:

    options snd-hda-intel model=laptop enable=1 index=0

    to /etc/modprobe.d/options file which forces enabling the speakers on start up.

    Thanks for the advice, hope the solution can be of help to others.


    worked for me to on Hp 6930P, thanks

    ps
    editing alsa-base.conf just open terminal and
    sudo -s
    sudo mousepad /etc/modprobe.d/alsa-base.conf
    Genesis is Now

    Laptop - Compaq Presario V3000, AMD Turion 64x2, 1.8Ghz,4GB Ram,GeForce Go 6150 with 384 MB Video Ram. UE 2.3 installed.

  3. #3
    Join Date
    Jul 2008
    Beans
    25

    Re: Internal speaker help

    Well thank you, but its a no-go.

    I can't even find /etc/modprobe.d/options...
    /etc/modprobe.d/, yes, but no further.

    Noob advise?

  4. #4
    Join Date
    Oct 2009
    Beans
    2

    Re: Internal speaker help

    Quote Originally Posted by vivaldibabe View Post
    Well thank you, but its a no-go.

    I can't even find /etc/modprobe.d/options...
    /etc/modprobe.d/, yes, but no further.

    Noob advise?

    Hi, try the following:

    1) Sudo -s

    "then enter root password"

    2) cd /etc/modprobe.d/

    3) pico alsa-base.conf

    "PICO" is text editor which is very simple to use. Hope you already have it.if not then follow these steps:

    from desktop main menu:

    System -> Administration -> Synaptic Package Manager

    Then from quick search type the word "nano". You should select the result and install it.

    You can also replace the word pico by the word nano in step#3.

    Hope this work

  5. #5
    Join Date
    Jul 2008
    Beans
    25

    Re: Internal speaker help

    I could not get nano to install, *however* when I rebooted this last time my internal sound came through.
    I have no idea what I did. =x
    As happy as I am with sound again, my headphone jack still won't work.
    I'll look around the forums and see what I can scare up.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •