Edit: I just realised that this post would be better suited for the development forum. Please feel free to move this, moderators. Thank you.
I installed the 9.10 netbook remix from alpha 4, upgraded all the way until alpha 6 at which point it just crashed, and crashed hard. It said there was nothing to boot on the hard disk, and when I tried to boot from live USB, it threw up a GRUB error, either 11 or 13 I believe.

This isn't a fluke thing, it happened to 2 or 3 of my other friends doing the same thing with their Mini's.

I Google'd the issue, and the solution I saw was to boot from a LiveCD rather than a LiveUSB. This worked, I installed, everything was ducky, until I rebooted and tried to boot from the disk. It said BOOTMGR not found, Ctrl-Atl-Del to restart.

You can hit those as many times as you like, it still throws the same error. Someone please help me, I'm begging you, me and my buddy need our netbooks for school and this is killing us academically. Thanks for any help in advance.