Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Installing Bugzilla

  1. #11
    Join Date
    May 2010
    Beans
    3

    Re: Installing Bugzilla

    Hello All,

    I was getting below error message while trying to upgrade Bugzilla 3.4.3 to Bugzilla 3.6 :

    Software error:Can't locate DateTime/Locale.pm in @INC (@INC contains: . lib/i486-linux-gnu-thread-multi lib /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl) at lib/DateTime.pm line 41.BEGIN failed--compilation aborted at lib/DateTime.pm line 41.Compilation failed in require at Bugzilla/Util.pm line 53.BEGIN failed--compilation aborted at Bugzilla/Util.pm line 53.Compilation failed in require at Bugzilla/Error.pm line 33.BEGIN failed--compilation aborted at Bugzilla/Error.pm line 33.Compilation failed in require at Bugzilla/Install/Filesystem.pm line 31.BEGIN failed--compilation aborted at Bugzilla/Install/Filesystem.pm line 31.Compilation failed in require at Bugzilla/Config.pm line 38.BEGIN failed--compilation aborted at Bugzilla/Config.pm line 38.Compilation failed in require at Bugzilla.pm line 38.BEGIN failed--compilation aborted at Bugzilla.pm line 38.Compilation failed in require at /var/www/bugzilla-3.4.3/index.cgi line 34.BEGIN failed--compilation aborted at /var/www/bugzilla-3.4.3/index.cgi line 34.For help, please send mail to the webmaster (webmaster@localhost), giving this error message and the time and date of the error.


    Thanks for your post. I had installed all required perl module but getting the same erroe message. Then I installed two perl module by running commands :
    : /usr/bin/perl install-module.pl List::MoreUtils
    : /usr/bin/perl install-module.pl DateTime::Locale

    It is working fine now. Please accept my warm thanks for posting such a nice message.

    Regards
    Shailesh

  2. #12
    Join Date
    Feb 2008
    Location
    Boston, MA
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Installing Bugzilla

    Quote Originally Posted by TUOggy View Post
    Okay, so I had to scour the web because it seems like nobody had any idea about what was going on...

    The actual issue had nothing to do with Postgres, or the Postgres module.

    The real problem was that List::MoreUtils was missing. I don't know if Bugzilla is supposed to check for this, or if this is something that I should have installed anyway, but I kept getting the weird TimeDate::Locale error.

    I tried and tried to reinstall the TimeDate::Locale module, but it kept telling me that I had the most recent.

    If you are getting this strange error, then try the following command:

    Code:
    /usr/bin/perl install-module.pl List::MoreUtils
    Hope this helps someone else =)
    TUOggy, I owe ya a beer!

    Thanks mate!

  3. #13
    Join Date
    Jul 2011
    Beans
    1

    Re: Installing Bugzilla

    Quote Originally Posted by skumar1 View Post
    Hello All,

    I was getting below error message while trying to upgrade Bugzilla 3.4.3 to Bugzilla 3.6 :

    Software error:Can't locate DateTime/Locale.pm in @INC (@INC contains: . lib/i486-linux-gnu-thread-multi lib /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl) at lib/DateTime.pm line 41.BEGIN failed--compilation aborted at lib/DateTime.pm line 41.Compilation failed in require at Bugzilla/Util.pm line 53.BEGIN failed--compilation aborted at Bugzilla/Util.pm line 53.Compilation failed in require at Bugzilla/Error.pm line 33.BEGIN failed--compilation aborted at Bugzilla/Error.pm line 33.Compilation failed in require at Bugzilla/Install/Filesystem.pm line 31.BEGIN failed--compilation aborted at Bugzilla/Install/Filesystem.pm line 31.Compilation failed in require at Bugzilla/Config.pm line 38.BEGIN failed--compilation aborted at Bugzilla/Config.pm line 38.Compilation failed in require at Bugzilla.pm line 38.BEGIN failed--compilation aborted at Bugzilla.pm line 38.Compilation failed in require at /var/www/bugzilla-3.4.3/index.cgi line 34.BEGIN failed--compilation aborted at /var/www/bugzilla-3.4.3/index.cgi line 34.For help, please send mail to the webmaster (webmaster@localhost), giving this error message and the time and date of the error.


    Thanks for your post. I had installed all required perl module but getting the same erroe message. Then I installed two perl module by running commands :
    : /usr/bin/perl install-module.pl List::MoreUtils
    : /usr/bin/perl install-module.pl DateTime::Locale

    It is working fine now. Please accept my warm thanks for posting such a nice message.

    Regards
    Shailesh
    I know this is an older thread, but I had this issue and none of the solutions solved it. While I was looking around I saw someone mention that it wanted the headers, which led me to the solution that fixed it for me:

    Code:
    sudo apt-get install libpq-dev
    To install the postgresql development headers. After that it worked. I had already installed the List::MoreUtils and DateTime::Locale so I'm not really sure if they were necessary or not, but I know they didn't fix it alone.

    Hopefully this helps someone in the future wandering through this thread.

    Thanks,
    \Peter

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •