Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Can't type acute accents anymore

  1. #1
    Join Date
    Aug 2009
    Beans
    27
    Distro
    Ubuntu 9.10 Karmic Koala

    Can't type acute accents anymore

    I recently posted a thread similar to this one in Absolute Beginner Talk as I thought this wasn't too hard to solve. I might have been wrong.

    The problem is that I can't type acute accents anymore. I'm from Iceland and thus this is a major problem for me. I used to be able to press two keys: the English apostrophe button and a vowel.
    However, when experimenting in Keyboard Preferences, pressing Reset to Defaults disabled that option. I've tried numerous things in Layout Options to fix it but nothing seems to work.

    I'm a Ubuntu 9.04 user and using a Logitech Cordless Desktop EX110 keyboard.

    I'll post my Keyboard settings here: http://i568.photobucket.com/albums/s...a/keyboard.jpg

    In Layout Options, the only things I've selected are 'Keys to change layout' (both shift keys together) and 'Key to choose 3rd level' (right ctrl).

    Are there any ideas to fix this? Or maybe I'll just have to wait for Ubuntu 9.10?

    Thanks in advance.

    Added: I've tried compose keys too without luck. The icelandic keyboard has dead keys but they don't work for me anymore.
    Last edited by rannuG; September 28th, 2009 at 07:39 PM.

  2. #2
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    5,686
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Can't type acute accents anymore

    Quote Originally Posted by rannuG View Post
    I used to be able to press two keys: the English apostrophe button and a vowel.
    That sounds like you were using "dead keys" before. If you want it to behave like that you'll need to pick a layout that uses dead keys.

    The other option is to set a Compose key. Then you can press Compose → accent → letter. For example, Compose → ' → a gives you á. It's slightly more flexible than dead keys in that you can generate non-letter characters too; Compose → o → c gives you the copyright symbol ©, and so on.
    None but ourselves can free our minds

  3. #3
    Join Date
    Aug 2009
    Beans
    27
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Can't type acute accents anymore

    The Icelandic default keyboard supports acute accents.
    I tried compose keys, but didn't work.

    This is really strange...
    Last edited by rannuG; September 27th, 2009 at 01:37 PM. Reason: i wanted to

  4. #4
    Join Date
    Aug 2009
    Beans
    27
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Can't type acute accents anymore

    Maybe it might help mentioning that an Icelandic friend of mine uses Ubuntu 9.04 too and has the same keyboard options as me, except he has nothing selected in layout options (I tried deselecting mine but didn't work).

  5. #5
    Join Date
    Aug 2009
    Beans
    27
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Can't type acute accents anymore

    Any ideas?

  6. #6
    Join Date
    Aug 2009
    Beans
    27
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Can't type acute accents anymore

    Can anybody help me on this?

  7. #7
    Join Date
    Apr 2009
    Beans
    1,173

    Re: Can't type acute accents anymore

    Quote Originally Posted by rannuG View Post
    Can anybody help me on this?
    You should try the same version of the Iceland keyboard as the one that worked - try print preview of the various Iceland layouts to find where the dead keys are.

    The compose key works by selecting, for example, the right-control key as compose and then pressing compose, accent, character instead of accent, character with dead keys.

    In another thread someone said options work for new users (i.e. create another user account) that simply do not function on the primary account.

  8. #8
    Join Date
    Aug 2009
    Beans
    27
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Can't type acute accents anymore

    I created a new account and that solved the problem. Thanks!

    Pretty annoying to move all the files though and grant permissions, but I've wanted to change a username for a while anyway...

  9. #9
    Join Date
    Apr 2009
    Beans
    1,173

    Re: Can't type acute accents anymore

    Quote Originally Posted by rannuG View Post
    I created a new account and that solved the problem.
    I wish I knew what setting is buried somewhere in the installation-time administration user that disables keyboard functionality. No matter what settings I can think of, they have all been correct.

  10. #10
    Join Date
    Oct 2004
    Beans
    4

    Re: Can't type acute accents anymore

    Same here. New user and diacritics work again. I select Icelandic keyboard and I do not need a Compose-key. Just press diacritic and vowel.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •