Results 1 to 3 of 3

Thread: Enabling Linux framebuffer

  1. #1
    Join Date
    Feb 2006
    Beans
    5

    Enabling Linux framebuffer

    How do I enable the Linux framebuffer device?

    I followed the steps at this site:
    http://doc.trolltech.com/qtopia1.6/h...amebuffer.html
    and ended up creating a customised kernel. But I'm unable to boot this kernel.Below are the last few lines that appear while booting and then, nothing happens.
    -------------------------------------------------------------------------
    .
    .
    Uncompressing Linux... OK, booting kernel
    .
    .
    [4294667.296000]BIOS provided physical RAM map:
    [4294667.296000]0MB HIGHMEM available
    [4294667.296000]223MB LOWMEM available
    [4294667.296000]found SMP MP-table at 00ff780
    [4294667.296000]DMI 2.3 present
    --------------------------------------------------------------------------

    I edited menu.lst in /boot/grub to boot this kernel. Is that causing problems? But I couldn't find grub.conf in Ubuntu.
    (in fact in RedHat, I had to edit grub.conf to enable the framebuffer device)

  2. #2
    Join Date
    Jan 2005
    Beans
    346

    Re: Enabling Linux framebuffer

    you have to append vga=0x123 to the end of the kernel line in grub. 123 are different for every monitor, my laptop uses 0x0317. there's also two different drivers that take different arguments there.

    maybe this will help, http://www.ubuntuforums.org/showthre...ht=framebuffer

  3. #3
    Join Date
    Feb 2006
    Beans
    5

    Re: Enabling Linux framebuffer

    Thank you, Framebuffer is working now!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •