Results 1 to 10 of 62

Thread: Gigabyte T1028M collective thread

Threaded View

  1. #1
    Join Date
    Feb 2005
    Beans
    30

    Question Gigabyte T1028M collective thread

    There are currently three different threads about the Gigabyte T1028M in the forum. I thought it might be useful to have a unifying thread.

    Please help with any and all comments!!!
    and
    WARNING: I am not an expert -- you follow any advice at your own risk!!! -- make backups!!!
    Nuff said.

    Tested Ubuntu Version:
    Ubuntu Netbook Remix 9.10

    Problems:
    • Problem: Touchpad not working.
      Solution:
      9.04 / grub: modify /boot/grub/menu.lst by adding 'i8042.noloop=1' at the end of the line(s) starting with "linux" (containing the uuid of the root partition)
      9.10 / grub2: modify /etc/defaults/grub and modify the "splash quiet" line by including 'i8042.noloop=1'. Afterwards run update-grub2.
      You can test this by adding 'i8042.noloop=1' in the grub menu at boot.
      (Thanks to http://0x42.org/blog/archives/62-Ubu...uchscreen.html and http://ubuntuforums.org/showthread.php?t=1230484 )
    • Problem: Touchscreen not working.
      Solution: Install xserver-xorg-input-evtouch.
      Some people (see comments) experience problems and/or severe stability issues especially with 9.04.
      Workarounds include:
      (Doktor.Wahnsinn) If your touchscreen still does not work, try activating the 'activate second mouse button on holding first' feature.
      (beke) If an application (like Xournal) uses Xinput, deactivate the use of Xinput.
      (ratiafak) Install the drivers from eGalax.
    • Problem: Touchscreen calibration unstable.
      Solution: Following https://bugs.launchpad.net/ubuntu/+s...35/comments/14 I use an fdi instead -- save it as a text file in /etc/hal/fdi/policy/SOMENAME.fdi

      Code:
      <?xml version="1.0" encoding="ISO-8859-1" ?>
      <deviceinfo version="0.2">
      <device>
        <match key="info.product" contains="eGalax Inc. USB TouchController">
       <merge key="input.x11_driver" type="string">evtouch</merge>
       <merge key="input.x11_options.ReportingMode" type="string">Raw</merge>
       <merge key="input.x11_options.Emulate3Buttons" type="string">false</merge>
       <merge key="input.x11_options.Emulate3Timeout" type="string">1</merge>
       <merge key="input.x11_options.SendCoreEvents" type="string">On</merge>
       <merge key="input.x11_options.MinX" type="string">0</merge>
       <merge key="input.x11_options.MinY" type="string">2</merge>
       <merge key="input.x11_options.MaxX" type="string">4096</merge>
       <merge key="input.x11_options.MaxY" type="string">4096</merge>
        </match>
      </device>
      </deviceinfo>
    • Problem: Webcam not working.
      Solution: Webcam works after reactivating the webcam using SmartManager in winXP.
    • Problem: Connecting the power plug triggers suspend mode.
      Solution: None. Could be a regular bug, but I haven't found anything similar. Does anybody else experience this?
    • Problem: Calibration is suddenly bad in the center (happens at random). Sometimes triggered by rotation (but not always), sometimes by simply using the touchpad (or so it seems...)
      Solution: None. Workaround: log off, restart X, reboot. Does anybody else experience this?

    • Problem: Wireless -- nm-applet crashes while connecting.
      Solution: Updating ubuntu using ethernet solved it for me.




    Installation/Karmic/software related

    • Netbook Launcher: The touchscreen click is unable to start programs that are not in the "favorite" section. The problem seems to be that instead of a click a drag is registered. Dragging everything important to favourites is a workaround. Any hint would be great.
    • Rotating: Works fine, but Netbook Launcher has problems in portrait orientation: In the section "system" the two subsections "preferences" and "administration" overlap.
    • SmartManager: A replacement for Gigabyte's "Smart Manager" for winXP would be nice. WattOSpm could be a replacement, but I couldn't try it so far.
    • Installation ran smoothly (except that (W)LAN connection did not work)
    • Post-Installation: the first boot ended at root console claiming that the last time of mounting was in the future. One run of fschk per partition solved the problem; could be realted to encryption.


    Well, that's all for now. I hope this helps anyone thinking about installing ubuntu! So much works out of the box
    Last edited by beke; November 1st, 2009 at 01:51 PM. Reason: update

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •