Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: How do I: Turn Off Desktop Effects Via Terminal

  1. #11
    Join Date
    Jul 2006
    Beans
    92
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How do I: Turn Off Desktop Effects Via Terminal

    Quote Originally Posted by koshari View Post
    nice workaround luke,

    alternatively you dont need 2 launchers you could use one with a little more code it can be a toggle effect , ie, click to on, click to off, ect.

    i used a similar script for my wifi and bluetooth toggles on my lappie, you basically have a hidden file that has a 1 or 0 value and depending on this the alternate commands are issued

    this should be the go,

    Code:
    #!/bin/bash
    compizon=`cat /home/user/bin/.compizstate`
    if [ $compizon = "0" ]; then
    echo compiz --replace
    echo 1 > /home/user/bin/.compizstate
    else
    echo metacity --replace
    echo 0 > /home/user/bin/.compizstate
    fi
    obviously edit your username to reflect your home dir destination
    When I switch back to Compiz all of my settings are reset to the default.

    For example, when I am using Compiz I have the Grid plugin switched on and the Decorations plugin switched off, but when I switch to Metacity then back to Compiz, I have window decorations on again and the Grid plugin switched off.

    Does anyone know how to make Compiz save settings between sessions?
    --
    Ubuntu 10.10 |
    AMD Phenom II X2 555 Black Edition Callisto 3.2GHz C3 | http://foxcub.net/

  2. #12
    Join Date
    Oct 2009
    Beans
    8

    Re: How do I: Turn Off Desktop Effects Via Terminal

    Hey that's a great idea koshari - it saves on shortcut real-estate.

    Is it just me, or did after upgrading to Ubuntu 9.10 did the "shortcut-solution" cease to work for other people too? Now when i try to turn off compiz via the shortcut over VNC the entire screen just goes to desktop background and Compiz doesn't disable like it used to. Man this sucks... now I have to spend time finding some other hack to fix the VNC-Compiz bug that was introduced in 9.04. The -noxdamage fix won't work for me because I don't have enough bandwidth. When is this going to be fixed??!! I don't get why Ubuntu even bothers to add VNC to the distro if it's broken for the majority of us who enable visual effects?

  3. #13
    Join Date
    Oct 2009
    Beans
    8

    Re: How do I: Turn Off Desktop Effects Via Terminal

    ubuntu 10.04 - still broken - awesome.

  4. #14
    Join Date
    Apr 2008
    Beans
    34

    Re: How do I: Turn Off Desktop Effects Via Terminal

    ...or just don't use vino - it's pretty ordinary

    I use x11vnc and it works just fine - no problem with desktop effects or compiz or anything...

    -and it's easier on the resources as well

  5. #15
    Join Date
    Jul 2008
    Beans
    3

    Talking Re: How do I: Turn Off Desktop Effects Via Terminal in Kubuntu

    Nobody asked, but since I was looking for it and took me a while to find...here is my "toggle":

    Code:
    qdbus org.kde.kwin /KWin org.kde.KWin.toggleCompositing
    if [ $(qdbus org.kde.kwin /KWin org.kde.KWin.compositingActive) == "true" ]; then
    	echo "Desktop compositing is ON"
    else
    	echo "Desktop Compositing is OFF"
    fi
    Enjoy!

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •