Page 35 of 35 FirstFirst ... 25333435
Results 341 to 342 of 342

Thread: Ipod Nano 5G with linux?

  1. #341
    Join Date
    Mar 2009

    Re: Ipod Nano 5G with linux?

    Quote Originally Posted by DL3wis View Post
    The patch provided by Okiura didn't work for me, it caused errors during compile. I did however get my iPod Nano 5g working after using some instructions from this forum and tinkering around. This is how I got it to work on Kubuntu 11.04:

    1. Make sure your iPod has been initialised on Windows to make the filesystem FAT32.

    2. Follow these instructions from stefanadelbert to re-compile and install lastest git source version of libgpod and gtkpod:

    3. Mount your iPod and open a terminal and type in: "sudo lsusb -v | grep -i Serial" without the quotes. Then you will see a 16-character-long hash. On your iPod navigate to the iPod_Control/Device folder and open or create a file named "SysInfo". Open this up in a text editor and type in: FirewireGuid: 0x... and paste that hash in (do not omit the 0x). For example - FirewireGuid: 0x000A27001301221F. Save the file.

    4. Get a HashInfo file for your device from here by typing in the FirewireGuid you got above. Place it in iPod_Control/Device folder.

    5. That should be all there is to it! If you fire up gtkpod you should be able to transfer songs to your iPod 5g. NOTE: It may be possible this works without recompiling libgpod and gtkpod in natty. I only noticed the HashInfo file requirement after I had recompiled.

    6. If you want to use Amarok to manage your iPod - you need to get Amarok to detect it as an iPod rather than a mass storage device (Apparently this used to work in KDE < 4.6).

    7. Type in a terminal:

    udevadm info --export-db | less
    There is a lot of output, your looking for any sections relating to your iPod. Particularly, the section that shows the data partition, in my case /dev/sdc1 (yours maybe /dev/sdb1, etc). Once you find this section, look for the line "ID_FS_UUID" and copy the ID that's with this.

    8. Open /lib/udev/rules.d/90_ligpod.rules with a text editor as root. Paste this line at the bottom:

    ENV{ID_FS_UUID}=="<ID_YOU_COPIED>", ENV{ID_FS_LABEL} ="iPod_<your_name>", ENV{ID_FS_LABEL_ENC} = "iPod_<your_name>"
    Replace <ID_YOU_COPIED> with the ID you got from the output of udevadm and replace <your_name> with, well... your name! The name MUST start with "ipod_" or it won't work.

    9. Unplug and reconnect your iPod and it should now work with Amarok! You will see it should connect as "iPod_<your_name>".

    That's it, hopefully this will work for others. Unfortunately, album art does not transfer using Amarok for me. But it works using gtkpod (which is strange as they both use libgpod).
    Verrry nice!

    Worked for me in Precise/Rhythmbox by only performing steps 1-4!

    Thanks, DL3wis
    Lenovo W520 | NVIDIA Quadro 2000M | Ubuntu 11.04 64-bit

  2. #342
    Join Date
    Oct 2010
    Windhoek, Namibia
    Ubuntu 10.04 Lucid Lynx

    Re: Ipod Nano 5G with linux?

    Hey, there having problems with this trying to get to sync with rhythmbox, banshee or gtkpod. the former two give no error when syncing but music is still not there when i disconnect the ipod, even though it shows some space has been taken up by the synchronisation. gtkpod just plain crashes (seg faults when run from a terminal) with nothing being picked up. On Ubuntu 12.04, running cinnamon.

Page 35 of 35 FirstFirst ... 25333435

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts