Page 29 of 35 FirstFirst ... 192728293031 ... LastLast
Results 281 to 290 of 342

Thread: Ipod Nano 5G with linux?

  1. #281
    Join Date
    Jun 2008

    Re: Ipod Nano 5G with linux?

    Quote Originally Posted by edpatterson View Post
    I recceived the following

    Remember, my intelligence level is that of someone who would spend $175.00 to listine to music through 1/8" speakers

    sudo apt-get remove gtkpod-data

  2. #282
    Join Date
    Jan 2008
    Manchester UK

    Re: Ipod Nano 5G with linux?

    Quote Originally Posted by Greya View Post
    update, new links (built on native platform)
    libplist 1.2, libgpod 0.7.92, gtkpod 0.99.15

    32 bit:
    64 bit:

    before installing: (To be sure that you don't have old libraries )
    sudo apt-get remove libgpod-common
    sudo apt-get remove libgpod4
    sudo apt-get remove libplist0
    sudo apt-get remove libplist
    sudo apt-get remove gtkpod-data
    sudo apt-get remove gtkpod

    *** Your rythmbox will be automatically uninstalled with libplist, so you have to install it later.

    Double-click to install
    1. libplist
    2. libgpod
    3. gtkpod

    after installing:
    sudo ln -s /usr/local/lib/libplist* /usr/lib
    (sorry, i don't know how to work with cmake)

    if you miss your rythmox: sudo apt-get install rythmbox

    it works!

    I've applied for PPA, but it will be available in few days... if i'll have time...
    64 bit works for me. Cheers.

  3. #283
    Join Date
    Apr 2009

    Re: Ipod Nano 5G with linux?

    Quote Originally Posted by Greya View Post
    You had older version of libplist.
    I have the same problem!
    I remove everything from /usr/lib and create the new link to the files with this lines:

    cd /usr/lib
    sudo rm -rf libplist*
    sudo rm -rf /usr/local/lib/libplist*
    But the problem persist...

  4. #284
    Join Date
    Oct 2009
    London, UK
    Kubuntu 9.10 Karmic Koala

    Re: Ipod Nano 5G with linux?

    Has someone tried with Lucid? I mean without installing anything fancy, it should work out of the box.

  5. #285
    Join Date
    Mar 2008
    Normal, IL

    Re: Ipod Nano 5G with linux?

    but how do you create new platlists and sinc them onto the ipod...
    (i have and ipod nano 3G)
    -ASUS U46: Intel Core I5(Sandy Bridge) 8 gb Ram, Integrated Graphics card. Currently running Ubuntu 13.04(64bit)

  6. #286
    Join Date
    Mar 2010

    Re: Ipod Nano 5G with linux?

    First I'd like to thank all the committed people in this community. I'm new to Linux (I don't know much about computers and software anyways...) and so far i got to solve all my problems just by searching the forums. Good work out there.
    As you can probably tell from my spelling I'm no native speaker, so please excuse any mistakes i make.

    I am running 9.10 Karmic Koala and followed Greya's guide for the 32 bit version. Well.. it didn't quite work out as planned.
    When I try to install Rhythmbox from the software centre afterwards, I get the following error message:

    (Reading database ... 5% (this goes on until 100%)

    (Reading database ... 285672 files and directories currently installed.)
    Unpacking libgpod4 (from .../libgpod4_0.7.2-1ubuntu1_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libgpod4_0.7.2-1ubuntu1_i386.deb (--unpack):
    trying to overwrite '/usr/lib/', which is also in package libgpod 0:0.7.92-1
    Unpacking libgpod-common (from .../libgpod-common_0.7.2-1ubuntu1_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libgpod-common_0.7.2-1ubuntu1_i386.deb (--unpack):
    trying to overwrite '/usr/share/hal/fdi/policy/20thirdparty/20-libgpod-sysinfo-extended.fdi', which is also in package libgpod 0:0.7.92-1
    Selecting previously deselected package media-player-info.
    Unpacking media-player-info (from .../media-player-info_3-0ubuntu1_all.deb) ...
    Selecting previously deselected package rhythmbox.
    Unpacking rhythmbox (from .../rhythmbox_0.12.5-0ubuntu5.2_i386.deb) ...
    Processing triggers for hal ...
    Regenerating hal fdi cache ...
    hal start/running, process 10759
    Processing triggers for man-db ...
    Processing triggers for hicolor-icon-theme ...
    Processing triggers for desktop-file-utils ...
    Errors were encountered while processing:
    As long as i don't uninstall Rhythmbox via the terminal, ubuntu keeps trying to make me install libgpod4 by using the update manager, which also produces error messages about missing dependencies and so on.

    But this won't be my biggest problem, as I could probably solve it by just removing the changes.

    GTKPOD recognises my iPod nano 5g (i already had music on it, i am/was using windows back home. Unfortunately i only have my netbook available until the end of june, although i could probably find an internet-cafe with windows where i could install iTunes. Running iTunes on WINE didn't work out so far, my netbook seems to be too weak, it freezes during the installation).
    I also installed gtkpod-aac, as I kept getting error messages when I imported big parts of my music in gtkpod and i was optimistic/dumb enough to do additional changes before checking if everything works out... well, I hope this didn't cause my problem.
    Even though I didn't change anything on my iPod except for letting gtkpod recognise all of its data [edit: oh, i deleted an empty playlist which i accidentally created in windows to see if everything works. forgot about that], my iPod now tells me there wouldn't be any music on it. Checking the "Settings - About" my iPod now says 7.2GB (all the music on it) would be consumed by "other".
    gtkpod still finds the music on my iPod and even manually browsing it reveals the music to be there - i can even open the mp3s on my iPod with a music player on my netbook.

    Anyways, copying new music on the iPod via gtkpod doesn't seem to work. gtkpod says it's there, my iPod begs to differ.
    What shall I do now? Judging from the other posts here, the old patches in this thread aren't necessary any more and I am sort of anxious about breaking even more.
    Whether I could restore the music that's on it (I read something about connecting the iPod to iTunes after putting music on it to fix the playlists in this thread) or even get it to work with Linux... anything would be fine.
    Last edited by irdo; March 28th, 2010 at 06:39 AM.

  7. #287
    Join Date
    Jun 2008

    Re: Ipod Nano 5G with linux?

    I had the same problem first time. I had to connect ipod to the iTunes once. But my mate's ipod worked from the first time...
    If you connected ipod to old gtkpod - it can break your database (i think so).

  8. #288
    Join Date
    Mar 2010

    Re: Ipod Nano 5G with linux?

    Plugging it into iTunes did the trick, even without synchronising it with the particular iTunes. Anyways, iTunes seems to convert the data on the iPod from category "other" to "music" and leaves a 30KB file "autorun.inf" on the iPod, which gtkpod deletes.
    I also get your

    by the way, after fixing database in iTunes i started gtkpod and i've got "iTunesDB does not match checksum in extended information file. gtkpod will try to match the information using SHA1 checksums."
    looks like it is not compatible

    Anyways, i will keep my iPod away from gtkpod for at least the next 3 weeks, as I'm in the Australian outback and won't get any new music. If somebody wants to take a look at the autorun.inf file just tell me, i'll upload it for you.
    Last edited by irdo; March 29th, 2010 at 05:30 AM. Reason: typo

  9. #289
    Join Date
    Mar 2010

    Re: Ipod Nano 5G with linux?

    Thanks for this thread, folks. I actually went thru, tried it all and found none of it work. On a whim, I did a google search that resulted in finding a free program called Floola, which works flawlessly with my 5G in 9.10

    you may need to use synaptic to download and install two additional files (floola will complain if you don't have them installed; just note them and install them). Beyond's pretty much self explanatory.

    HTH someone!

  10. #290
    Join Date
    Dec 2007
    Den Haag, NL and Paris, F
    Ubuntu 10.04 Lucid Lynx

    Re: Ipod Nano 5G with linux?

    too bad that I forgot my ipod and can't try it. It sure will make my day. Iwould be able to free these remaining 10GB occupied by WinXP on my HD

    -> Floola is the answer to all problems:

    Download from here:

    No install required - it only needs to be unpacked.

    On my system a library "" was missing, for which install instructions can be found here:

    ... that do not work, because they refer to an older version,

    Just change the version number in the wget instruction:


    and add a symbolic link to the file

    /usr/lib/ -> /usr/local/zlib/lib/

    As of now WinXP is gone from my system ... again =)

    Guess I'll even donate some money now to flooa
    Last edited by Veloteuton63; April 1st, 2010 at 09:47 AM. Reason: Update with additional information

Page 29 of 35 FirstFirst ... 192728293031 ... LastLast

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts