Results 1 to 6 of 6

Thread: PulseAudio and Logitech webcam mic. Mic doesn't work.

  1. #1
    Join Date
    Jun 2005
    Location
    Canada
    Beans
    94
    Distro
    Ubuntu 9.10 Karmic Koala

    PulseAudio and Logitech webcam mic. Mic doesn't work.

    Hi

    I have a logitech quickcam communicate STX (which has an inbuilt microphone). I've also installed the latest Skype 2.1 beta. Now, I'm trying to get the microphone to work but it isn't I need ideas on what I can do to fix the problem.

    When I run pavucontrol, and watch my webcam mic's progress bar while talking to it, it moves, but I am not hearing what I'm saying coming out of the speaker. As a result when I use Skype, the mic does not pick up my voice.




    Thanks in advance.
    Attached Images Attached Images
    Last edited by Blackie_Chan; September 15th, 2009 at 03:05 PM.

  2. #2
    Join Date
    Jun 2005
    Location
    Canada
    Beans
    94
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: PulseAudio and Logitech webcam mic. Mic doesn't work.

    I have solved my problem. All I had to do is disable pulse audio's autospawn and then change my Skype sound settings.

    1. Disable autospawn.
    Open ~/.pulse/client.conf with your favorite editor and add autospawn = no

    2. Stop pulse audio.
    In your terminal, run pulseaudio -k

    3. Run Skype and change audio settings:


    4. After using Skype to make my long distance call, I just restart pulse audio
    In your terminal, run pulseaudio -D
    After step 3, I had to run "Gnome Volume Control" and unmute the Master Playback control in Alsa mixer.
    Attached Images Attached Images
    Last edited by Blackie_Chan; September 20th, 2009 at 02:14 AM. Reason: Restart pulseaudio after using Skype

  3. #3
    Join Date
    Jul 2009
    Beans
    37

    Re: PulseAudio and Logitech webcam mic. Mic doesn't work.

    I don't have skype, and my client.conf file was in /etc...

    and I still can't get it to work.

  4. #4
    Join Date
    Jun 2005
    Location
    Canada
    Beans
    94
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: PulseAudio and Logitech webcam mic. Mic doesn't work.

    Quote Originally Posted by Zoey.Marie View Post
    I don't have skype, and my client.conf file was in /etc...

    and I still can't get it to work.
    If you create and add ~/.pulse/client.conf, the autospawn setting will override the value in /etc/pulse.

  5. #5
    Join Date
    Jun 2005
    Location
    Canada
    Beans
    94
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: PulseAudio and Logitech webcam mic. Mic doesn't work.

    Quote Originally Posted by Zoey.Marie View Post
    I don't have skype, and my client.conf file was in /etc...

    and I still can't get it to work.
    What are you using the webcam mic for? How do you plan on using it? If I knew what you are using it for, I can see how the app works on my computer.

  6. #6
    Join Date
    Jul 2009
    Beans
    37

    Re: PulseAudio and Logitech webcam mic. Mic doesn't work.

    Oops. I suppose I should've updated this when I finally got it to work...

    I'm not sure how I did, but I did. After I changed the auto-spawn thing, I just tinkered around with sound settings (under system>preferences>sound) and then played around in the programs that I was trying to get it to work in (Ardour, JACK, Audacity, Pure Data, ...) and had to find the specific settings that worked for it. I had to change all the "default" values in the input device field to the "hw:" whatever thing that it is in, and then I needed to make sure that I wasn't running any sound program with a sample rate of 16000Hz (or else it wouldn't work).

    I'm pretty sure that's all I did. <3

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •