Page 9 of 84 FirstFirst ... 78910111959 ... LastLast
Results 81 to 90 of 837

Thread: HOWTO: Use b43 driver with 14e4:4315 (Broadcom bcm4312 rev 01)

  1. #81
    Join Date
    Oct 2009
    Location
    Madrid, Spain
    Beans
    9
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: Use b43 driver with 14e4:4315 (Broadcom bcm4312 rev 01)

    Sorry but my answer isn't correct. After an hour my computer freeze and after reboot, the b43 driver load but it throw this error:
    "[ 699.977734] b43-phy0: Controller RESET (DMA error) ...
    [ 700.196356] b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
    [ 705.769367] b43-phy0: Controller restarted
    [ 705.780442] b43-phy0 ERROR: Fatal DMA error: 0x00000400, 0x00000000, 0x00000000, 0x00000000, 0x00000000, 0x00000000
    [ 705.780469] b43-phy0: Controller RESET (DMA error) ...
    [ 706.000430] b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
    [ 711.545398] b43-phy0:
    [ 711.545409] b43-phy0 ERROR: Fatal DMA error: 0x00000400, 0x00000000, 0x00000000, 0x00000000, 0x00000000, 0x00000000
    [ 711.545431] b43-phy0: Controller RESET (DMA error) ...
    "

    and i can't load wl driver

  2. #82
    Join Date
    Aug 2007
    Location
    Off the Alaskan Coast
    Beans
    794
    Distro
    Ubuntu Development Release

    Re: HOWTO: Use b43 driver with 14e4:4315 (Broadcom bcm4312 rev 01)

    Nice Howto chenxiaolong, but you might want to add build-essential to it, before the make part for those that don't know already:
    Code:
    sudo apt-get install build-essential
    FIC K8-800T AMD64 3200+ 2GB PC3200 GeForce 6800GT Mandriva 2010 KDE+Compiz+Emerald
    MSI K9N2GM AMD 9950BE 4GB DDR2-800 GeForce 8200 10.10 WUSB600N
    Acer 6920 Core 2 Duo 4GB GeForce 9500GS 10.04 Ubuntu User #17586

  3. #83
    Join Date
    Oct 2009
    Location
    Madrid, Spain
    Beans
    9
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: Use b43 driver with 14e4:4315 (Broadcom bcm4312 rev 01)

    Quote Originally Posted by rusty73 View Post
    Sorry but my answer isn't correct. After an hour my computer freeze and after reboot, the b43 driver load but it throw this error:
    "[ 699.977734] b43-phy0: Controller RESET (DMA error) ...
    [ 700.196356] b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
    [ 705.769367] b43-phy0: Controller restarted
    [ 705.780442] b43-phy0 ERROR: Fatal DMA error: 0x00000400, 0x00000000, 0x00000000, 0x00000000, 0x00000000, 0x00000000
    [ 705.780469] b43-phy0: Controller RESET (DMA error) ...
    [ 706.000430] b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
    [ 711.545398] b43-phy0:
    [ 711.545409] b43-phy0 ERROR: Fatal DMA error: 0x00000400, 0x00000000, 0x00000000, 0x00000000, 0x00000000, 0x00000000
    [ 711.545431] b43-phy0: Controller RESET (DMA error) ...
    "

    and i can't load wl driver
    I removed all backports package with synaptic and I inserted b43 module into blacklist file and after reboot (because my system freezed again) the system load b43 module and it seem that work well :S:S. That's very very strange.

    My system is Dell mini 9 with the damned wireless card.

  4. #84
    Join Date
    Jul 2008
    Beans
    13

    Re: HOWTO: Use b43 driver with 14e4:4315 (Broadcom bcm4312 rev 01)

    Quote Originally Posted by kngharv View Post
    help

    during the installation of b43-fwcutter, i pressed YES to extract the firmware.

    how to reverse that? I did that before I read this howto. I went to /lib/firmware and remove b43 directory. would that do it?

    now, my wireless driver is crippled, I got this message after being connected to an access point for about 30 seconds:


    b43-phy0 ERROR: Fatal DMA error: 0x00000400, 0x00000000, 0x00000000, 0x00000400, 0x00000000, 0x00000000
    b43-phy0: Controller RESET (DMA error) ...
    b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
    b43-phy0: Controller restarted


    Help, please.

    Dear all:

    I think I found the problem.

    According o the B43 driver site, there is a list of chipsets supported, my chipset is "in progress."

    So, I apologize for being a dumb *** and wasted a these precious cycle from you guys.

    I can't wait to get monitor mode on this chipset works, though.


    Harv

  5. #85
    Join Date
    Mar 2009
    Beans
    24

    Re: HOWTO: Use b43 driver with 14e4:4315 (Broadcom bcm4312 rev 01)

    I'm also suffering now I've upgraded from 9.04 to 9.10 ( I actually did it as a clean install of / )

    I've tried everything in this thread so far but nothing helps.

    Now my wifi doesn't work, when I do modprobe b43 I get dmesg output of:
    Code:
    [ 4253.680567] b43-phy0: Broadcom 4312 WLAN found (core revision 15)
    [ 4253.880930] phy0: Selected rate control algorithm 'minstrel'
    [ 4253.882907] Registered led device: b43-phy0::tx
    [ 4253.882957] Registered led device: b43-phy0::rx
    [ 4253.883002] Registered led device: b43-phy0::radio
    [ 4253.883135] Broadcom 43xx driver loaded [ Features: PML, Firmware-ID: FW13 ]
    [ 4254.042897] b43 ssb0:0: firmware: requesting b43/ucode15.fw
    [ 4254.050930] b43 ssb0:0: firmware: requesting b43/lp0initvals15.fw
    [ 4254.060369] b43 ssb0:0: firmware: requesting b43/lp0bsinitvals15.fw
    [ 4254.210360] b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
    [ 4268.042984] b43-phy0 ERROR: Fatal DMA error: 0x00000400, 0x00000000, 0x00000000, 0x00000000, 0x00000000, 0x00000000
    [ 4268.042991] b43-phy0: Controller RESET (DMA error) ...
    [ 4268.392879] b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
    ...
    [ 4808.924078] b43-phy0: Controller restarted
    [ 4808.942918] b43-phy0 ERROR: Fatal DMA error: 0x00000400, 0x00000000, 0x00000000, 0x00000000, 0x00000000, 0x00000000
    [ 4808.942937] b43-phy0: Controller RESET (DMA error) ...
    [ 4809.280448] b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
    Those last 4 lines repeat every couple of minute until I get fed up and disable it!

    iwconfig reports:
    Code:
    $ iwconfig
    wlan0     IEEE 802.11bg  Mode:Managed  Access Point: Not-Associated
              Tx-Power=20 dBm
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
    Code:
    $ lshw -C network
    WARNING: you should run this program as super-user.
      *-network
           description: Network controller
           product: BCM4312 802.11b/g
           vendor: Broadcom Corporation
           physical id: 0
           bus info: pci@0000:06:00.0
           version: 01
           width: 64 bits
           clock: 33MHz
           capabilities: bus_master cap_list
           configuration: driver=b43-pci-bridge latency=0
           resources: irq:19 memory:f4000000-f4003fff
    Anyone any ideas what's broken with this driver since 9.04 ?

  6. #86
    Join Date
    Dec 2008
    Location
    /home/chenxiaolong&/root
    Beans
    474
    Distro
    Ubuntu Development Release

    Re: HOWTO: Use b43 driver with 14e4:4315 (Broadcom bcm4312 rev 01)

    For now, you might want to just use the Broadcom STA (wl) driver, since it's stable and works well in Ubuntu 9.10. I'm waiting until the b43 developers fix what is wrong.
    Laptop broke ...

  7. #87
    Join Date
    Oct 2009
    Beans
    11

    Re: HOWTO: Use b43 driver with 14e4:4315 (Broadcom bcm4312 rev 01)

    You may congratulate me, I finally received that BCM4311 card (tnx ebay), and it works fine, including airmon-ng and kismet!
    Going to sell the dreaded BCM4312 in a few days. I advise you guys do the same =)

    Oh and I installed Debian in place of Ubuntu. Time to move up, you know?

  8. #88
    Join Date
    Dec 2008
    Location
    /home/chenxiaolong&/root
    Beans
    474
    Distro
    Ubuntu Development Release

    Re: HOWTO: Use b43 driver with 14e4:4315 (Broadcom bcm4312 rev 01)

    Too bad for me. Dell uses half size mini-pci express cards.
    Laptop broke ...

  9. #89
    Join Date
    Mar 2009
    Beans
    24

    Re: HOWTO: Use b43 driver with 14e4:4315 (Broadcom bcm4312 rev 01)

    Mines a Dell laptop too ( Vostro 1710 ).

    I'm using the STA driver now I think. Tried so many things over the last few days!

    hybrid-portsrc-x86_64-v5.10.91.9.3.tar.gz
    from here:
    http://www.broadcom.com/support/802.11/linux_sta.php

    I had problems with the 80211 libraries and had to do this:
    Code:
    export KERN=`uname -r`
    rmmod /lib/modules/$KERN/kernel/net/wireless/wl.ko
    rmmod /lib/modules/$KERN/kernel/net/wireless/lib80211.ko
    rmmod /lib/modules/$KERN/kernel/net/wireless/lib80211_crypt_wep.ko
    rmmod /lib/modules/$KERN/kernel/net/wireless/lib80211_crypt_tkip.ko
    rmmod /lib/modules/$KERN/kernel/net/wireless/lib80211_crypt_ccmp.ko
    
    cp wl.ko /lib/modules/$KERN/kernel/net/wireless/
    insmod /lib/modules/$KERN/kernel/net/wireless/lib80211.ko
    insmod /lib/modules/$KERN/kernel/net/wireless/lib80211_crypt_wep.ko
    insmod /lib/modules/$KERN/kernel/net/wireless/lib80211_crypt_tkip.ko
    insmod /lib/modules/$KERN/kernel/net/wireless/lib80211_crypt_ccmp.ko
    insmod /lib/modules/$KERN/kernel/net/wireless/wl.ko
    modprobe wl
    Then I had a new problem, I have two wifi networks at home(long story) one is using WEP ( must change that soon ) and the other is WPA(802.11g).
    I used to use the WPA network all the time from 9.04 but now I could only
    connect to the WEP network. If I try the WPA it asks for the password but then just waits a while and silently fails, then asks again for the password. No errors appear in dmesg.
    I changed my wifi router from WPA to WPA2 and now it also works.
    Now I'm happy

    Thanks guys for all the suggestions here.

  10. #90
    Join Date
    Jul 2005
    Beans
    63

    Re: HOWTO: Use b43 driver with 14e4:4315 (Broadcom bcm4312 rev 01)

    To all,

    I have the same wireless chip as this thread [Broadcom Corporation BCM4312 802.11b/g [14e4:4315] (rev 01)] and found that it worked out of the box with Xubuntu 9.10 with both managed mode and full aircrack-ng monitor mode & aireplay-ng commands. Only an installation of aircrack-ng was needed.

    Not sure why...but it did not work out of the box with Ubuntu 9.10. I used a remastersys of Xubuntu 9.10 on a usb stick (remastersys with the 9.10 requires some fiddling though because of the the new grub 2.0....but, if you have the available PC, just do an install of Xubuntu 9.10 and you are in business).

    A

Page 9 of 84 FirstFirst ... 78910111959 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •