Page 4 of 11 FirstFirst ... 23456 ... LastLast
Results 31 to 40 of 103

Thread: HOWTO: Install GNU Emacs with antialiasing

  1. #31
    Join Date
    Jan 2006
    Location
    Lynchburg, VA (US)
    Beans
    278
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: HOWTO: Install GNU Emacs with antialiasing

    hmmm... not working for me yet. this is what i get after editing the rules file, and then trying to do the ./configure command.
    Code:
    reed@ubuntu:~/emacs$ ./configure --with-x-toolkit=gtk --with-xft=yes
    checking build system type... i686-pc-linux-gnulibc1
    checking host system type... i686-pc-linux-gnulibc1
    checking for gcc... gcc
    checking for C compiler default output file name... configure: error: C compiler cannot create executables
    See `config.log' for more details.
    reed@ubuntu:~/emacs$
    so i opened up "config.log" and this is what it reads.
    Code:
    This file contains any messages produced by compilers while
    running configure, to aid debugging if configure makes a mistake.
    
    It was created by configure, which was
    generated by GNU Autoconf 2.59.  Invocation command line was
    
      $ ./configure --with-gtk --with-xft --prefix=/usr
    
    ## --------- ##
    ## Platform. ##
    ## --------- ##
    
    hostname = ubuntu
    uname -m = i686
    uname -r = 2.6.12-10-686
    uname -s = Linux
    uname -v = #1 Mon Feb 13 12:18:37 UTC 2006
    
    /usr/bin/uname -p = unknown
    /bin/uname -X     = unknown
    
    /bin/arch              = i686
    /usr/bin/arch -k       = unknown
    /usr/convex/getsysinfo = unknown
    hostinfo               = unknown
    /bin/machine           = unknown
    /usr/bin/oslevel       = unknown
    /bin/universe          = unknown
    
    PATH: /usr/local/bin
    PATH: /usr/local/sbin
    PATH: /sbin
    PATH: /usr/sbin
    PATH: /bin
    PATH: /usr/bin
    PATH: /usr/bin/X11
    PATH: /usr/games
    
    
    ## ----------- ##
    ## Core tests. ##
    ## ----------- ##
    
    configure:1643: checking build system type
    configure:1661: result: i686-pc-linux-gnulibc1
    configure:1669: checking host system type
    configure:1683: result: i686-pc-linux-gnulibc1
    configure:2767: checking for gcc
    configure:2783: found /usr/bin/gcc
    configure:2793: result: gcc
    configure:3037: checking for C compiler version
    configure:3040: gcc --version </dev/null >&5
    gcc (GCC) 4.0.2 20050808 (prerelease) (Ubuntu 4.0.1-4ubuntu9)
    Copyright (C) 2005 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions.  There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
    
    configure:3043: $? = 0
    configure:3045: gcc -v </dev/null >&5
    Using built-in specs.
    Target: i486-linux-gnu
    Configured with: ../src/configure -v --enable-languages=c,c++,java,f95,objc,ada,treelang --prefix=/usr --with-gxx-include-dir=/usr/include/c++/4.0.2 --enable-shared --with-system-zlib --libexecdir=/usr/lib --enable-nls --without-included-gettext --enable-threads=posix --program-suffix=-4.0 --enable-__cxa_atexit --enable-libstdcxx-allocator=mt --enable-clocale=gnu --enable-libstdcxx-debug --enable-java-gc=boehm --enable-java-awt=gtk --enable-gtk-cairo --with-java-home=/usr/lib/jvm/java-1.4.2-gcj-4.0-1.4.2.0/jre --enable-mpfr --disable-werror --enable-checking=release i486-linux-gnu
    Thread model: posix
    gcc version 4.0.2 20050808 (prerelease) (Ubuntu 4.0.1-4ubuntu9)
    configure:3048: $? = 0
    configure:3050: gcc -V </dev/null >&5
    gcc: '-V' option must have argument
    configure:3053: $? = 1
    configure:3076: checking for C compiler default output file name
    configure:3079: gcc    conftest.c  >&5
    /usr/bin/ld: crt1.o: No such file: No such file or directory
    collect2: ld returned 1 exit status
    configure:3082: $? = 1
    configure: failed program was:
    | /* confdefs.h.  */
    | 
    | #define PACKAGE_NAME ""
    | #define PACKAGE_TARNAME ""
    | #define PACKAGE_VERSION ""
    | #define PACKAGE_STRING ""
    | #define PACKAGE_BUGREPORT ""
    | #define MAIL_USE_POP 1
    | /* end confdefs.h.  */
    | 
    | int
    | main ()
    | {
    | 
    |   ;
    |   return 0;
    | }
    configure:3121: error: C compiler cannot create executables
    See `config.log' for more details.
    
    ## ---------------- ##
    ## Cache variables. ##
    ## ---------------- ##
    
    ac_cv_build=i686-pc-linux-gnulibc1
    ac_cv_build_alias=i686-pc-linux-gnulibc1
    ac_cv_env_CC_set=
    ac_cv_env_CC_value=
    ac_cv_env_CFLAGS_set=
    ac_cv_env_CFLAGS_value=
    ac_cv_env_CPPFLAGS_set=
    ac_cv_env_CPPFLAGS_value=
    ac_cv_env_CPP_set=
    ac_cv_env_CPP_value=
    ac_cv_env_LDFLAGS_set=
    ac_cv_env_LDFLAGS_value=
    ac_cv_env_build_alias_set=
    ac_cv_env_build_alias_value=
    ac_cv_env_host_alias_set=
    ac_cv_env_host_alias_value=
    ac_cv_env_target_alias_set=
    ac_cv_env_target_alias_value=
    ac_cv_host=i686-pc-linux-gnulibc1
    ac_cv_host_alias=i686-pc-linux-gnulibc1
    ac_cv_prog_ac_ct_CC=gcc
    
    ## ----------------- ##
    ## Output variables. ##
    ## ----------------- ##
    
    ALLOCA=''
    CC='gcc'
    CFLAGS=''
    CPP=''
    CPPFLAGS=''
    C_SWITCH_X_SITE=''
    DEFS=''
    ECHO_C=''
    ECHO_N='-n'
    ECHO_T=''
    EGREP=''
    EXEEXT=''
    GETLOADAVG_LIBS=''
    GETOPTOBJS=''
    GETOPT_H=''
    GTK_CFLAGS=''
    GTK_LIBS=''
    GZIP_PROG=''
    INSTALL_DATA=''
    INSTALL_INFO=''
    INSTALL_PROGRAM=''
    INSTALL_SCRIPT=''
    KMEM_GROUP=''
    LDFLAGS=''
    LD_SWITCH_X_SITE=''
    LD_SWITCH_X_SITE_AUX=''
    LIBOBJS=''
    LIBS=''
    LIBSOUND=''
    LN_S=''
    LTLIBOBJS=''
    MAINT='#'
    NEED_SETGID=''
    OBJEXT=''
    PACKAGE_BUGREPORT=''
    PACKAGE_NAME=''
    PACKAGE_STRING=''
    PACKAGE_TARNAME=''
    PACKAGE_VERSION=''
    PATH_SEPARATOR=':'
    PKG_CONFIG=''
    RANLIB=''
    SET_MAKE=''
    SHELL='/bin/sh'
    XFT_CFLAGS=''
    XFT_LIBS=''
    X_TOOLKIT_TYPE=''
    ac_ct_CC='gcc'
    ac_ct_RANLIB=''
    archlibdir='${libexecdir}/emacs/${version}/${configuration}'
    bindir='${exec_prefix}/bin'
    bitmapdir=''
    build='i686-pc-linux-gnulibc1'
    build_alias=''
    build_cpu='i686'
    build_os='linux-gnulibc1'
    build_vendor='pc'
    c_switch_machine=''
    c_switch_system=''
    canonical='i686-pc-linux-gnulibc1'
    carbon_appdir=''
    configuration='i686-pc-linux-gnulibc1'
    datadir='${prefix}/share'
    docdir='${datadir}/emacs/${version}/etc'
    etcdir='${datadir}/emacs/${version}/etc'
    exec_prefix='NONE'
    gamedir='${localstatedir}/games/emacs'
    gameuser='games'
    host='i686-pc-linux-gnulibc1'
    host_alias=''
    host_cpu='i686'
    host_os='linux-gnulibc1'
    host_vendor='pc'
    includedir='${prefix}/include'
    infodir='${prefix}/info'
    libdir='${exec_prefix}/lib'
    libexecdir='${exec_prefix}/libexec'
    liblockfile=''
    lispdir='${datadir}/emacs/${version}/lisp'
    lisppath='${locallisppath}:${lispdir}'
    locallisppath='${datadir}/emacs/${version}/site-lisp:${datadir}/emacs/site-lisp:${datadir}/emacs/${version}/leim'
    localstatedir='${prefix}/var'
    machfile='m/intel386.h'
    mandir='${prefix}/man'
    oldincludedir='/usr/include'
    opsysfile='s/gnu-linux.h'
    prefix='/usr'
    program_transform_name='s,x,x,'
    sbindir='${exec_prefix}/sbin'
    sharedstatedir='${prefix}/com'
    srcdir='/home/reed/emacs'
    sysconfdir='${prefix}/etc'
    target_alias=''
    version=''
    x_default_search_path=''
    
    ## ----------- ##
    ## confdefs.h. ##
    ## ----------- ##
    
    #define MAIL_USE_POP 1
    #define PACKAGE_BUGREPORT ""
    #define PACKAGE_NAME ""
    #define PACKAGE_STRING ""
    #define PACKAGE_TARNAME ""
    #define PACKAGE_VERSION ""
    
    configure: exit 77
    none of the really makes any sense to me, so let me know what you think. thanks.
    Linux user since January 31st, 2006.
    two ways to live :: the choice we all face

  2. #32
    Join Date
    Aug 2005
    Location
    The Local Group
    Beans
    631

    Re: HOWTO: Install GNU Emacs with antialiasing

    Quote Originally Posted by thermans
    I don't think it has anything to do with Hoary. I'm on Dapper and have redraw problems:

    Not sure what the cause is.
    When I tried it on Hoary, it was much worse than that. I couldn't see what I was typing. I occasionally see the same bug you're seeing (on Breezy). I don't know what the cause is, either, but you can (mostly) fix it when it happens by giving Emacs the command M-x redraw.

  3. #33
    Join Date
    Jan 2006
    Beans
    18

    Re: HOWTO: Install GNU Emacs with antialiasing

    Hi there,

    any news on the redraw bug og the mode-line?
    I figured out that it only occurs on some buffers. Exclusively on buffers that do have a formatting that has lines of different heights (customization, LaTeX-mode, etc.).
    Is there a patch available? It is really anoying not to see the mode-line

    fladd

  4. #34
    Join Date
    Jul 2005
    Location
    Ontario, Canada
    Beans
    366
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HOWTO: Install GNU Emacs with antialiasing

    This worked exactly as described -- many thanks!

    My one question: how I can get Ruby support? When I try to install it through Synaptic, it wants to install the emacs package.

    *emacs "newbie"*

  5. #35
    Join Date
    Oct 2005
    Beans
    2

    Re: HOWTO: Install GNU Emacs with antialiasing

    I'm totally new to installing the emacs, I used it at my work long time ago and like it a lot for writting code in c and c++. I tried to download, ./configure and make, which worked and I also got through the error message about the termcap database, but now I'm stuck with the terminal version. When I type in emacs in a terminal it start the non windows version of emacs instead of the nice emacs window I remember from the past.

    I dont know how to completly uninstall the emacs and start all over again, or make it work with the gui.

    Any help wil really be appreciated.

    Thanks,
    Ebaad.

  6. #36
    Join Date
    Oct 2005
    Beans
    244
    Distro
    Ubuntu Development Release

    Re: HOWTO: Install GNU Emacs with antialiasing

    I followed the instructions as per post #1, but after successfully finishing the make and installation processes, running emacs gave me the same error as other people in this thread:

    Code:
    emacs: Cannot open termcap database file
    I had installed the gtk dev libraries before running ./configure, and as I said, everything compiled and installed fine. I haven't tried installing the ncurses dev library though, as I saw from other posts that that wasn't really helpful either.

    Any ideas?

  7. #37
    Join Date
    Oct 2005
    Beans
    148

    Re: HOWTO: Install GNU Emacs with antialiasing

    Hello,

    i have been using emacs-snapshot for a while now. It is being very nice. Since Im in the middle of project I didn't get rid of emacs21. So, both emacs-snapshot and emacs21 are co-existing. Now, it so happen that there is one thing with is bothering me. In emacs22 somethings seem to be missing. For instance, in latex-mode I don't have C-c C-c to run latex, then view, etc. Further, reftex is not being loaded (it is in my .emacs) when I call .tex file, as it used to be in emacs21. in python-mode, I don't have the automatic tab. So many of this little features are missings. Also, I have installed planner-el, but emacs-snapshot don't recognize it. Nevertheless, emacs-snapshot is being very good. Then, I would like to change to it once for all. Now, my question:

    how can i enable all this features in emacs-snapshot, like in emacs21?

    It seems my old .emacs has no good use in emacs-snapshot.

    Thanks

    P.S.: Im really ready to leave emacs21 for emacs22. And this weekend seems to be a good period to do so.

  8. #38
    Join Date
    Oct 2005
    Beans
    2

    Re: HOWTO: Install GNU Emacs with antialiasing

    Quote Originally Posted by desp
    Code:
    emacs: Cannot open termcap database file
    Any ideas?

    Hi Desp,

    I did a lot of things since I installed the emacs to make it work, but when I checked the history I found the following command that installs the ncurses which fixed the above issue. Please give it a shot and see if it works.

    sudo apt-get install libncurses5-dev

    Thanks,
    Ebaad.

  9. #39
    Join Date
    Oct 2005
    Location
    Helsinki, Finland
    Beans
    1,351

    Re: HOWTO: Install GNU Emacs with antialiasing

    No more crashes!!

    Just recompiled with this one line change to xfaces.c and emacs is stable in addition to looking good.

    http://www.nabble.com/patch-for-cras...0.html#a454431

  10. #40
    Join Date
    Apr 2006
    Beans
    7

    Re: HOWTO: Install GNU Emacs with antialiasing

    Hi all, Im a Ubuntu newbie. I just installed it on my laptop. I follow #1 post but I got this error:
    longtran79@ubuntu:~$ cvs -z3 -dserver:anonymous@cvs.savannah.gnu.org:/cvsroot/emacs co emacs
    bash: cvs: command not found
    longtran79@ubuntu:~$
    Please give me some advice, thanks a lot!!!!!

Page 4 of 11 FirstFirst ... 23456 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •