Results 1 to 2 of 2

Thread: glib version confusion when trying to compile atk (for gimp)

  1. #1
    Join Date
    Feb 2008

    glib version confusion when trying to compile atk (for gimp)

    am trying to compile the gimp under ubuntu 9 (frustratingly i had all this compiling a while back)
    got the source (2.6.7), went on to get others:-
    atk-1.27.90 gegl-0.1.0 gtk+-2.16.6 pango-1.24.5
    babl-0.1.0 gimp-2.6.7 glib-2.20.5 intltool-0.40.6

    ./configure, make, make install in each..
    However on getting to atk, configure is telling me this.
    Q1 Any ideas how to fix? where *is* the old version of glib?

    checking pkg-config is at least version 0.16... yes
    checking for GLIB - version >= 2.0.0...
    *** 'pkg-config --modversion glib-2.0' returned 2.20.5, but GLIB (2.20.1)
    *** was found! If pkg-config was correct, then it is best
    *** to remove the old version of GLib. You may also be able to fix the error
    *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    *** /etc/ Make sure you have run ldconfig if that is
    *** required on your system.
    *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
    *** to point to the correct configuration files
    configure: error:
    *** GLIB 2.0.0 or better is required. The latest version of
    *** GLIB is always available from If GLIB is installed
    *** but not in the same location as pkg-config add the location of the file
    *** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

  2. #2
    Join Date
    Nov 2005
    Bordeaux, France
    Ubuntu 12.04 Precise Pangolin

    Re: glib version confusion when trying to compile atk (for gimp)

    Why did you compile glib from source? The versin shipped with your Ubuntu is perfectly sufficient.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts