Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: skype no microphone in jaunty

  1. #21
    Join Date
    Mar 2009
    Beans
    232

    Re: skype no microphone in jaunty

    I had the same problem when updating to Skype 2.1 beta and this is what I did.

    1. Install paman (pulseaudio manager). It should install pulseaudio preferences, device chooser, etc. (I think it's just the device chooser that's required but it doesn't hurt to install the manager.)

    2. Run the pulseaudio device chooser. It should show an applet in your notification bar. Left click it and click on Volume Control. Then click on the Configuration tab. It should show several devices including your mic. My mic is on my external usb cam and my soundcard is an HDA Intel. Under the profile of every device that is NOT the mic device, make sure they are NOT set to input. E.g my HDA Intel device profile was "Output analog stereo + Input analog stereo". I changed it to "Output analog stereo". My USB camera profile was set to "Input analog mono".

    Everything works now. I imagine the default input device for pulseaudio was my soundcard's stereo input which I wasn't using. So by disabling it, pulseaudio defaulted to my webcam.

    By the way, the quality of Skype 2.1 seems better than 2.0, so I'm glad I'm using it. And it doesn't seem like my mic input drops out every now and then. So it's all good!

  2. #22
    Join Date
    Aug 2007
    Location
    Ct. USA
    Beans
    25

    Re: skype no microphone in jaunty

    To get jaunty 9.04 w/PulseAudio to show mic in Skype Options.....
    I wrote this script to launch Skype which utilizes the
    PULSE_SERVER variable
    You feed the PULSE_SERVER your IPaddress for your connected device..
    As you can see, for me my devices are eth0 and wlan0
    Modify the script devices to your needs.
    A simple ifconfig <deviceName> ...i.e. ifconfig eth0 will give back the info for that device then we just parse it ...
    NOTE: I have installed my Skype in a Particular Dir /home/sqlpython/skype..
    ......If yours is in a different Dir CHange the Script..
    ...Also for Notification Sounds Move the /home/sqlpython/skype/sounds dir to
    ..../usr/share/skype/ .. You probably will have to create that one in as sudo user of Konqueror or Nautilus
    Even with all this PulseAudio and SKype work poorly together as they will hog CPU% and result in squashing all other playbacks while Skype is connected to another Skype User VOIP.. like if you are streaming Radio music or just trying to Play a Music CD at the same time..
    To put it in eloquent technical terms "PulseAudio Stinks"
    In the end for my 8.10 and 9.04 installs I will probably uninstall Pulse.
    Here You Go... Mic in Skype.
    #!/bin/bash

    ifconfig wlan0 | grep "inet addr" | cut -d: -f2 | cut -d" " -f1 $1
    ifconfig eth0 | grep "inet addr" | cut -d: -f2 | cut -d" " -f1 $2
    if [ $1 -gt $2 ]
    then
    echo $1
    PULSE_SERVER=$1 /home/sqlpython/skype/skype
    fi
    if [ $2 -gt $1 ]
    then
    echo $2
    PULSE_SERVER=$2 /home/sqlpython/skype/skype
    fi
    Last edited by sqlpython; October 23rd, 2009 at 09:21 PM.
    #!-Kubuntu-Gentoo-Debian-Slackware
    Calculate-Sabayon-Jessie-Sid

  3. #23
    Join Date
    Jun 2008
    Beans
    49

    Re: skype no microphone in jaunty

    Quote Originally Posted by nortexoid View Post
    2. Run the pulseaudio device chooser. It should show an applet in your notification bar. Left click it and click on Volume Control. Then click on the Configuration tab. It should show several devices including your mic. My mic is on my external usb cam and my soundcard is an HDA Intel. Under the profile of every device that is NOT the mic device, make sure they are NOT set to input. E.g my HDA Intel device profile was "Output analog stereo + Input analog stereo". I changed it to "Output analog stereo". My USB camera profile was set to "Input analog mono".
    I don't see a configuration tab

  4. #24
    Join Date
    Oct 2009
    Beans
    1

    Re: skype no microphone in jaunty

    1. Choose "Volume Control" and open "Input Devices" tab. Than select your device to default.

    2. Go to ~/.pulse/ and find file like "3fc1801253b192fb3a453426489ca151:default-source". Copy content of that file, in my was "alsa_input.usb_device_4f2_a13c_noserial_if2_sound _card_0_alsa_capture_0"

    3. Left click on "Device Chooser" and choose "Default Source" and select "Other". Paste content of your file there.

    It works good for me
    Last edited by funnycat79; October 24th, 2009 at 09:54 AM.

  5. #25
    Join Date
    Jun 2009
    Beans
    286

    Re: skype no microphone in jaunty

    Quote Originally Posted by dgdriscoll View Post
    OK, I killed 2.1.0.47. I see in synaptic package manager a skype-mid 3.0.0.93-3jaunty1. Is that worth trying? Or is that a Very Bad Idea?
    Thanks
    Dave
    Skype-Mid is the only version I have been able to get running, although it took me a while to figure out how to quit.

    In the leftside Skype-mid panel, click on More.
    Three options are presented: History, Sign Out, and Quit.
    Last edited by libssd; May 19th, 2010 at 08:33 PM.

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •