Long time user, yet just signed up as i couldnt find anything dealing with my issue. First let me thank everyone for all the great advice that has gotten me this far in fully switching my desktop to ubuntu and getting rid of Windoze..LOL

I am working on a Dell Inspiron, 2400 ( yes its old) It has a 2.4G Celeron, with 512M of memory 250G sata drive. I did a fresh install of Jaunty when it came out, with all the usual packages, from google, flash, Java, etc. Nothing really out of the ordinary. When i removed UFW and tried to replace it with SELinux i had an issue. During the "apt-get install selinux" install at the terminal, it disabled AppArmor as i knew it would, and installed fine or so it said and looked, then asked me to reboot for finalization. So i did. It booted to the log in screen just fine, but now i cant type to log in, cant move the mouse, nothing. It is just locked on the login screen. I did this once before with the same result and that time i just wiped the drive and reinstalled. This time i really need to keep the info on the drive and there is a LOT of it, over 50Gigs of data i need. Can someone please use their expertise to help me save this install and keep my data, or in the least use the live cd to uninstall SElinux and see if i can go from there?? PLEASE. You are all the best, thanks in advance for the help.