Results 1 to 5 of 5

Thread: Creating permission on file server...

  1. #1
    Join Date
    Jul 2008
    Location
    Dayton, OH
    Beans
    5
    Distro
    Ubuntu 8.04 Hardy Heron

    Question Creating permission on file server...

    Ok, so i created a file server with server 9.04. Installed ubuntu-desktop so id have a gui. I have in my /srv/samba/share directory , two folders. One is called public and the other is called private.

    I want to set it up so my mom, dad, and one employee can access the public (so not everyone can get in) and then only my mom and dad can get into the private. I have Employee as under the group Public and my parents under Private group. I just do not get how i should change the permissions on each directory folder.

    Can someone help me out?

    Thanks,

    Patrick

  2. #2
    Join Date
    Feb 2009
    Location
    Texas
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Creating permission on file server...

    Quote Originally Posted by pkbest87 View Post
    Ok, so i created a file server with server 9.04. Installed ubuntu-desktop so id have a gui. I have in my /srv/samba/share directory , two folders. One is called public and the other is called private.

    I want to set it up so my mom, dad, and one employee can access the public (so not everyone can get in) and then only my mom and dad can get into the private. I have Employee as under the group Public and my parents under Private group. I just do not get how i should change the permissions on each directory folder.

    Can someone help me out?

    Thanks,

    Patrick
    Hi

    In Linux, you can change permissions via "chmod" command. For a complete guide of what you can or can't do, type this on your console

    Code:
    man chmod
    But in a short, if you want to grant read and write to a group you should do something like this

    Code:
    chmod g+rw MyFile
    the "g" is for the group

    To remove the permissions to the others, is something like this

    Code:
    chmod uo-rw MyFile
    where "u" and "o" stands for user and others.

    Now, that's a file system or Linux level. You must configure permissions at Samba Level as well. A simple Samba configuration for Home, could be

    Code:
    [home]
    read only = no
    browseable = no
    Here, the user mapped to home can write there but can not browse outside of its own folder.

    This Samba guide will explain that easily but more in depth: http://samba.netfirms.com/index.htm

  3. #3
    Join Date
    Jul 2008
    Location
    Dayton, OH
    Beans
    5
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Creating permission on file server...

    thanks...ill check out that link.. i think its probably something i need to set up in samba and not so much in the ubuntu permissions.

    thanks for the speedy response!

  4. #4
    Join Date
    Jul 2008
    Location
    Dayton, OH
    Beans
    5
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Creating permission on file server...

    ok now im running into problems. i found where the problem lies tho. when i right click on the directory it has the right group...but instead of saying read and write it says ---. i want to change this but dont know how. i have the group set, but not the permissions OF that group? understand? i have to restrict the private folder due to pay roll stuff so that is why i have to keep it secure. if i try and change it via GUI under properties it reverts my settings every time.

  5. #5
    Join Date
    Feb 2009
    Location
    Texas
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Creating permission on file server...

    Quote Originally Posted by pkbest87 View Post
    ok now im running into problems. i found where the problem lies tho. when i right click on the directory it has the right group...but instead of saying read and write it says ---. i want to change this but dont know how. i have the group set, but not the permissions OF that group? understand? i have to restrict the private folder due to pay roll stuff so that is why i have to keep it secure. if i try and change it via GUI under properties it reverts my settings every time.
    DO it via console ...

    Let's say the folder is Payroll

    Code:
    chmod g+rw Payroll
    then

    Code:
    ls -la
    to check permissions, it should read rw now ... btw, I believe you should have X too in order to browse or open that folder

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •